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LibreOffice™ Writer offers, both to the amateur and the pro-
fessional of the letters, a series of versatile and powerful tools 
that facilitate the work of the writer,  automating the most 
“difficult” tasks and leaving the author with the sole responsi-
bility of writing.

Different page styles, cross references, bibliographical in-
dexes, advanced typographical options, complex text designs, 
tables, mathematical formulas,  graphics… all this and more 
can be done in LibreOffice™ Writer. 

Not everything is perfect, we will have problems to solve, 
so in this book you will also see the limitations of the pro-
gram and how to overcome them.

The text has been organized in the form of a “course” that, 
starting from the most basic, progressively shows all that this 
program has to offer.

This edition focuses on version 6.1, explaining its many 
new features and indicating what 6.2 will bring.

Several chapters will be dedicated to offer an introduction 
to other components such as Draw, Math and Chart.
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Basic Ideas



Because using a program without knowing how it works is  
like trying to build a house without knowing what the foun-

dations are for

Chapters of this Part
About this book, and some general advice..... 11
The graphical interface.............. 21
Essential tools.................. 33
The structure of a document........... 55
Typography and related topics.......... 63



Chapter 1

About this book, and 
some general advice

This book is the first English edition of a text with a long history.
Originally a series of articles written in Spanish and presented in 

the now defunct digital magazine “Begins” between October 2006 and 
September 2008, it was born as an independent book (also in Spanish) 
in early 2010 and saw an important series of editions and reviews that 
made it grow both in content and in complexity, including an Italian 
edition in 2016.

This English edition is based upon the 2018 Spanish edition, which 
was a huge turning point in the history of this book: rewritten almost 
from scratch, this new incarnation of the book explores new ways of 
explaining how to use LibreOffice Writer at  its  maximum potential, 
presenting everything a writer needs to know when using LibreOffice 
Writer with ease and efficiency.

In this first chapter I tell you what to expect from this text and how 
to use it to get the most out of it.

I’ll tell you when not to use Writer, present how this book is struc-
tured and the conventions used and to whom is this book addressed. 
We’ll also talk about which version we should use and some general 
advice for Linux users will be provided.
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1.1 Everything clear
It must be said from the beginning: there is no perfect program that 
does everything we need easily and without problems.

Some programs are  great for  certain tasks,  but  they will  give us 
headaches for others and in this regard Writer is no exception.

Everything depends on the context: to know if a program is useful 
to us we need first to define the task that we want to carry out, only 
then it is possible to evaluate the tools that the program offers and de -
cide if we are willing to make the effort to understand them. And the 
task in which Writer stands out is the creation of extensive and com-
plex documents.

Yes, we can use Writer to create the invitation cards for the birthday 
party of a 3 years old kid, but all the battery of styles and typographical  
abilities would be a waste of resources so in that case it will be better to 
use Draw (Chapter 14). Yes, we can write mathematical formulae with 
Math, the equation editor (Chapter 15), but we will quickly regret try-
ing if the document has more than a couple of them: for texts where 
mathematics, physics or chemistry are the protagonists, better  1 
or some of its derivatives.

There are many things that Writer can do with great solvency, some 
that can perform with some difficulty and a few that are completely 
out of its reach. In this book I will show virtues, defects and limitations 
of this program, so you can decide if it suits your needs or not.

So let’s get to the point and let’s say from the beginning when you 
should  not try to use Writer for your documents, that way you’ll see 
that the options that are left are really many.

• The most  obvious  limitation  is  in  mathematics:  for  a  small 
number of simple equations you can use Math without (major) 
drawbacks, for a “reasonable” number of complex equations 
you can use a mix of additional software, extensions and a lit-
tle  work,  but if  you need to write many complex equations 
better  to  think about   or  any of  its  derivatives,  maybe 

1 And yes, I used  to write . At the end of Chapter 15 I will return 
to this topic.
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with a graphical interface such as 2. 

• Will your document have many figures and / or tables floating 
in its pages? Then perform the following calculation:

     

If the DIHO number3 is clearly different from zero (let’s say, 
greater than 1/4), then no way:  / . That is, it is perfectly 
possible to work with many figures and tables in Writer (I have 
done it), but I do not recommend it (just for having done it).

• If terms like “microtypography” or “optical sizes” have a strong 
meaning for you, Writer will not help you either: a  vari-
ant with Unicode support such as  will be more appro-
priate. 

• Related with the previous item: as we will see in Chapter 5, if 
the font you want to use in your document offers more than 
the four typical “shapes” (normal,  italic,  bold and  bold italic) 
either  you  choose  a  different  font  or  you  change  program: 
LibreOffice will not work well for you.

Everything else is possible in Writer, which is no small thing. Prob-
lems will arise, it is true, but most of them have a more or less accessi-
ble solution.

To give an example of duet “problem and solution:” the templates 
that come in Writer, especially the default, are wrong in so many ways4 
that it would even be difficult to make a complete list of their defects,  
but on the other hand creating templates in Writer is so incredibly sim-

2 In case you are interested:
https://frommindtotype.wordpress.com/lyx-book/ 

3 Despair Index due to the Handling of Objects.

4 Yes, there are bug reports and enhancement requests that talk about the 
default templates. But better we do not get into that topic than just think-
ing about the discussions in some of those reports makes my blood pres-
sure  rise, and that’s not good. I mean, it’s not good for me.
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ple that we can ignore remorselessly those that come “out of the box” 
and build what works for us in a matter of minutes.

Remember that what you can do with Writer is a lot. Not every-
thing, it’s true, but a lot.

1.2 To whom is this book addressed
Perhaps one of the worst ways to learn how to use a computer is just  
sitting in front of a word processor, so I will assume that you know (or 
have someone that can explain all that to you) how to install the pro-
gram or how to search or save a file in your system, that you are famil-
iar with the use of menus and dialog boxes, that the mouse or the key-
board shortcuts are not a problem for you and that you are not afraid 
to modify the configuration of the program, try new things, move the 
old ones, etc.

Of course, if you use Linux download only from the official reposi-
tories  of  your distribution! And if  you do not use  Linux,  download 
only from the official project page!

https://www.libreoffice.org/download/download/ 

Another thing that I will take for granted: your willingness to learn 
new things.

If the word “styles” causes you a rash, this book is not for you. In 
fact, I would dare to say that Writer is not for you.

Therefore, you will not read in these pages about how to use the 
“format brush”5 or how to manually change this or that detail. I will fo-
cus on the extremely powerful tools that Writer gives us for the auto-
matic construction  of  structured documents  (hierarchical  paragraph 
styles, character styles, page styles, field, variables, indexes…).

This is why topics such as mail merge, forms or databases will not 
be remotely treated in these pages: that is material for another manual  
that could be called “Writer for office workers” and that I let others 
write.

So if you want to continue, dear reader, make yourself comfortable: 

5 I suppose that you have already guessed it by the book cover.
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I will do everything possible so that you have a good time and some 
fun while you are going through these pages, but still you will not save 
yourself from working a bit. You are warned!

1.3 Not everything is text in this life
Sometimes we need diagrams, math expressions or graphics, so I will 
dedicate some pages to components such as Draw (Chapter 14),  Math 
and related topics (Chapter 15) and Chart (Chapter 16). These chapters 
will necessarily be superficial, but they will serve, I hope, as an entry 
point to those tools.

1.4 Book structure
In  Apendix  B I  will  comment  in  detail  the  typefaces  used  and  the 
“building blocks” of this book, but as for now, I tried to simplify as 
much as possible (but not more than needed) the content presentation.

It does not make sense to read a manual without having at hand the  
product about which that manual speaks, so I have tried to reduce the 
number of figures to the minimum necessary. And after finishing the 
book I have reviewed everything again to remove some more figures, 
so be prepared: although we have some figures that try to explain im-
portant and complex concepts of  Writer,  the number of screenshots 
you will find in this book is exactly zero.

So you know, dear reader: I will assume that you are not only read-
ing this book about Writer but also  working with Writer.  Only with 
work it is possible to learn.

This book consists of several chapters grouped in three parts (Basic
Ideas,  Fundamental  tools,  More tools)  and a series  of  Appendixes with 
complementary information. 

Although it  may seem contradictory,  the  importance of  styles  in 
Writer has led me to delay its detailed introduction until  Chapter 6: 
only after understanding the “model” that Writer uses to build a docu-
ment will we be able to discuss the implementation of that model.

The first part will then talk about the graphic interface of the pro-
gram, some of its basic tools, the theory behind the structure of the 
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document and about typography.
The second part will be about the most important tools: styles and 

templates,  lists and numbering,  notes,  indexes, automatic correction, 
sections, frames, fields and cross references.

In the third part we will talk about the “extra” tools: Draw, Math, 
Chart, the master documents and the advanced search through regular 
expressions.

1.5 Conventions used in this book
During the development of the text, “explanatory notes” will be used, 
written in italics and with a gray background, as seen in the following 
example:

The text of the note

To give examples of code (code to build equations in Math, regular 
expressions or the structure of an odt file of which we will speak in 
Apendix A) a style with gray background and a mono-spaced font will  
be used6:

Example of code

A character style with a sans font7 will be used to indicate how to 
reach a particular menu, separating each of the steps with a “triangle,” 
using a light gray background with a “border:”

Tools ▶ Customize ▶ Keyboard tab
A character  style  based on the  Libertinus Keyboard font  will  be 

used to indicate key combinations.  For example, the combination of 
the “Control” key with the “Shift” and “R” will be shown as follows:

CtrlShiftR
Similarly, individual keys will be shown as “tab”  Tab, “Enter”  Enter, 

the space bar Space, etc..
References to the names (but not the numbers) of the titles of chap-

6 Source Code Pro.

7 Eau de Garamond.
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ters or sections are shown in italics.
All the names,  menus and other program elements mentioned in 

the book refer to version 6.1.
During the development of the text, I will refer to different bug re-

ports and enhancement request related to the topics discussed. You can 
access these reports simply by clicking on their numbers in the PDF, or 
by copying the report number and going to this address

https://bugs.documentfoundation.org/

to insert the report number in the “Quick Search” box.
By the way: in the PDF the internet links are shown with the same 

sans font mentioned above and in blue while the “internal” links (the 
index, the cross references, the anchors to the footnotes)) are shown in 
green.

One important note: I am aware that the keyboard of Mac systems 
is different and some of the key combinations discussed in this book do 
not work with the “small apple,” but I have been using Linux8 exclu-
sively  for  two decades  and I  do  not  know  the  equivalences  well.  I 
know,  for  example,  that  you  must  change  Tools  ▶  Options  by 
LibreOffice ▶ Preferences  and that in many keyboard shortcuts you 
should change Ctrl by ⌘: for everything else I trust you, my reader: 
I know that it will not be difficult to discover the differences.

1.6 Useful links
The project website

https://www.libreoffice.org/

The wiki

https://wiki.documentfoundation.org/Main_Page

The bug tracking system (always check if there is  an existing re-

8 Or, if you prefer, GNU/Linux. Or maybe GNU/BSD/MIT/Apache/MPD
/etc./Linux, to be more precise. I use openSUSE Leap.
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port!)

https://bugs.documentfoundation.org/

… 
And now we arrive at a point as important as difficult: the support 

to the user.
The LibreOffice project (from now on,  LibO) has several  mailing 

lists and an “ask” service that tries to be some sort of forum:9

https://www.libreoffice.org/get-help/mailing-lists/ 

https://ask.libreoffice.org/en/questions/ 

For reasons that I will not discuss here and although there are many 
people who with great effort and knowledge try to bring these services 
forward (my problem is not with the  people, but with the  service), the 
truth is that the mailing lists are almost dead and that the instance of  
“ask” is so misconfigured that it offers more problems than solutions. I 
know that for many this will sound almost sacrilegious, I do not want 
to enter  into these  discussions,  but  today the  best  user  support  for 
LibO is still in the forums of the Apache OpenOffice community (from 
now on, AOO): 

https://forum.openoffice.org/ 

The volunteers of these forums have a lot of experience (the forums 
have been around for more than a decade) and they usually have both 
packages installed, AOO and LibO, so they will not have problems in 
helping you.

1.7 Which version to use
The LibO project  maintains  two lines  of  development,  the so-called 
still that is considered stable and the fresh one that brings the last of the 
latest.

9 But fails.
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However, the separation between the two lines is, as we shall see 
below, somewhat “arbitrary.”

The versions are identified with four numbers, of which only the 
first three are important (the fourth says how many release candidates 
there  were  before  the  final  version).  For  example,  version  6.0.5.2. 
Changes in the first number indicate modifications in the program that 
might not be compatible with previous versions, changes in the second 
indicate new features while changes in the third indicate versions of 
error correction.

Let’s see an example of how this works. When 6.0.0 was released,  
this  version  was  considered  fresh while  the  previous  fresh  version, 
5.4.5 was considered still and the 5.3.z passed to end of life, that is, they 
lost support for updates.

Over the years the development of LibO has improved greatly (the 
first versions were very problematic), but we should not fool ourselves 
and think that a  still version is perfectly stable: especially in business 
environments, you have to carefully test the product before using it in 
important documents.

So, which version to choose? Here are two non-strict rules that can 
help us decide:

1. In a version X.Y.Z.w avoid as much as possible a zero, specially 
in the Z

2. Choose the Z ≥ 3

In fact, with a sufficiently high Z we could even forgive that the Y is 
zero (6.0.5 worked quite well).

1.8 General notes for Linux users
LibO uses its own “infrastructure,” called VCL, to draw the graphical 
interface.  This  system  has  been  inherited  from  OpenOffice.org  and 
only AOO and LibO use it. The LibO project has made a great effort to 
improve  VCL,  overcoming  its  original  limitations  and  allowing  to 
build  a  more pleasant  and stable  interface,  but  still  has  some small 
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problems that must be taken into account.
VCL “connects” with more modern libraries through specific plug-

ins. Currently, in addition to a generic plug-in used when everything 
fails, there are “connections” with GTK 2, GTK 3 and kde4, with a ver-
sion for Qt5 / Plasma in development, but not yet ready.

The most developed  plug-in of all  is by far the GTK3. Since both 
GTK 2 and kde4 / Qt4 are in end of life since a long time, the two cor-
responding plug-ins are problematic. This is why I recommend to all 
free system users to choose the GTK3 interface, even those who use 
LibO from a Plasma desktop: the GTK3 interface may not be as well 
integrated, but it definitely works much better than the archaic one for  
kde4.

What will surely cause an allergic reaction to any Plasma user is the 
first  view of  the  menu to  select  files,  especially  because,  by  default, 
folders and files appear mixed. The latter is easy to solve: with a right 
click on a folder or file in the file selector we have the option of having 
folders sorted first. Yes, double click to open, unfortunately.

And since we are here: unless you really know what you are doing, 
use only the official repositories of your distribution . This avoids having 
duplicate fonts in the system, it allows the use the dictionaries installed 
by your Linux distribution and gives you quick updates through the 
package manager without having to mess with an infinitude of .dev 
or .rpm files.


Well, as an introduction this is already a bit long. Let’s move on to 

more “complex” issues.
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Chapter 2

The graphical interface

In this chapter we will talk about the graphical interface of LibO, its 
structure and the ways to modify it, the keyboard shortcuts and how to 
work with several documents (or several views of the same document) 
simultaneously.

We will also briefly discuss the alternatives to the “traditional” in-
terface that the LibO project is currently developing and how to enable 
them to see what they offer.

You will not fin here1 screenshots of the graphical interface. This is  
partly due to the growing variety of “themes” and alternatives of-
fered by the program: it is highly likely that things in your system  
look very different from what I see in mine, even if we both use the  
default options.

I am sure that you will not have problems when following the in-
structions I give in the text to find and use all the options: with a  
minimum of attention and having the program in front of you, the  
task will be more than simple.

So I advise you to have opened not only the book, but also the pro-
gram before you start to try new things.

1 Nor in any other part of the book, everything must be said.
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2.1 What is available
The default graphical interface of all LibO applications has the typical  
“menus + toolbar” structure, where each of these elements either per-
forms an immediate action or opens a dialogue box with more options.

Many of these menus and toolbars are “fixed,” while many of them 
are “contextual,” appearing only when they are necessary or when we 
call them explicitly.

For years, the selection of default options has certainly not been the 
most careful aspect of the program, but in the latest versions the LibO 
project has taken enormous steps forward in this area. New tools have 
been added to modify the menus while those that already existed to 
change the toolbars are now more functional. With all these changes,  
achieving the perfect working environment becomes more and more 
simple with each new version.

The sidebar (of which we will talk later) has gained more relevance, 
improving its presentation, the way of interacting with it and its capac-
ity.

But there is more: several alternatives are being developed to the de-
fault interface, among which is the  notebookbar, a cross between tool-
bars,  tabs and menus that promises great flexibility2.  At the time of 
writing this book, many of these options are still “experimental,” but 
they are already arriving.

Therefore,  dear  reader,  if  the  general  aspect  of  the  program has 
given you a strange impression do not worry, that the problem of the 
graphical interface of Writer and LibO in general is not the lack or the 
excess of characteristics,  the problem lies in learning how to change 
the default presentation of those characteristics and choose those of-
fered in the foreground. What may seem wrong is  not the “face” of 
Writer, but its “makeup.”

And as we will see below, changing that makeup is really simple.

2 And that brings several memories. I do not know how many of my read-
ers are old enough to remember certain products for DOS of the eighties  
of the past millennium… Great ideas always come back.
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2.2 Keyboard shortcuts
It is possible to access almost any functions of Writer (and LibO in gen-
eral) through keyboard shortcuts, which are really easy to customize 
according to our needs.

We can use  Tools ▶ Customize ▶ Keyboard tab  to configure the 
keyboard shortcuts to our liking or simply use it to see which ones are 
defined.

The process  goes  as  follows:  after  selecting the  Function that  we 
want to configure (previously selecting the correct  Category) we look 
for a free  Shortcut Key that suits own needs,  we select it  and finally 
press Modify. To find the function that we need more quickly we also 
have the “filter” that is in the dialog under the name Functions.

If the function to which we want to assign a new keyboard shortcut  
already has another assigned shortcut, by selecting it the dialog could 
jump to that shortcut. In those cases it is better to first select the func-
tion and then the new combination.

As you can see almost everything is available to receive a keyboard 
shortcut and this includes not  only standard functions but also any 
style, macros… almost everything.

It is important to note that the keyboard shortcuts used by the op-
erating system take precedence over those used by LibO. For example, 
in Linux systems the CtrlF2 shortcut is usually used to go to the sec-
ond virtual  desktop,  so the function assigned by Writer  to that  key 
combination (More Fields) will not be activated: it is then be necessary 
to define another combination.

One last point: it is possible to save the keyboard shortcuts configu-
ration to a file that can then be loaded into another system. Indeed, the 
buttons for “save” and “load” allow us to use the configuration files for 
keyboard  shortcuts  (they  are  compressed  XML  files  with 
extension .cfg).

Remember: in the case we end up ruining everything with so many 
changes, we also have a button to Restore the default settings.
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2.3 Toolbars
In addition to the “normal” toolbars (where we can find the icons to 
save or open a document, copy and paste, redo or undo the latest ac-
tion, insert tables…) you have a long list of toolbars in  View ▶ Tool-
bars .

Some of these bars are “contextual:” they appear only when neces-
sary. Examples of these contextual bars are (we will return to some of 
them later): that of configuring a table, that of numbered lists, those re-
lated to images, graphic objects… These bars are visible only when you 
have selected an element on which those bars are applicable. 

This system is extremely useful since it does not overload the user 
interface with tools that are needed only once in a while. 

In addition, when we call these “contextual” functions, many of the 
corresponding toolbars appear already anchored in the lower part of 
the program window, where they do not bother us. 

This was not always the case and in fact with some toolbars it still is 
not:  the  Insert bar,  Align objects,  etc.,  simply “appear” floating in the 
middle of the window on which we are working, which can be some-
what uncomfortable.

The solution to this is actually very simple, we just have to grab the 
bar with the mouse and move it to one of the edges of the Writer win-
dow to “anchor” it there: as soon as a dotted rectangle is shown it will 
be possible to release the bar, which will stay in position. Then “fine ad-
justments” can always be made.

It should be noted that toolbars containing drop-down lists with 
text (such as the font selector) do not work very well when they are 
vertical.

If we want a contextual bar to no longer appear (for example, be-
cause its  functions are covered by the sidebar),  when it  appears,  we 
have to go to View ▶ Toolbars  and disable it.

We can edit the content of toolbars to add or remove buttons, or 
even create new bars at will in  Tools ▶ Customize ▶ Toolbar tab , or 
with a right click on an empty place in a particular bar ▶ Customize  
toolbar . There we can select the toolbar to edit, activate or deactivate 
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its buttons or change their order, remove buttons or add new ones and 
modify existing ones (changing the icon, for example). 

The tools to customize toolbars are really easy to use so I will only 
comment on an interesting feature of that dialog, the Scope menu: with  
it we can create toolbars that are saved exclusively in the current docu-
ment.

These “local” toolbars will be displayed only when you open  that 
document. 

This  could  be  useful  for  creating  special  templates3 that  require 
quick access to certain tools or macros, in addition to allowing us to 
take the document or  template  to a different  system without losing 
those elements of the graphic interface that we have created. 

For example, I have created one of those local toolbars to write this  
book: in it I have placed buttons for the various character and para-
graph styles that I needed.

2.4 Menus
The menus, both traditional (“File,” “Edit,” “Insert,” etc.) and the contex-
tual ones (those that appear when we right click on an object of the 
document or an element of the graphic interface), can also be config-
ured in a simple way from Tools ▶ Customize .

These tools to modify the menus have improved greatly in the latest 
versions of the program and their use is now so simple that they do not 
deserve further discussion, except to indicate that, here too, it is possi-
ble to define menus for specific documents.

2.5 The sidebar
The sidebar is a very interesting graphic element that puts the most 
commonly used tools at your fingertips.

The sidebar appears by default “closed” to the right of the editing 
window, showing only a series of buttons that represent the content it 
offers: with a click on any of those buttons, the corresponding panel 

3 For example: https://frommindtotype.wordpress.com/templates 
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opens to allow us to work.
The sidebar is  therefore  a kind of  “vertical  container”  that offers 

several panels,  all  accessible through the buttons on the right of the 
sidebar itself. Each of these panels is in turn divided into one or more  
“sections,” each offering several tools classified by “themes” (paragraph, 
character, image…).

By default (some extensions and the “experimental features” could 
add more) in Writer we have available five panels that correspond to 
the five buttons, starting with the  second and listing from top to bot-
tom, which are to the right of the sidebar:

1. Properties: here we have tools to modify the text or images 
inserted, to activate numbered lists or bullets, for graphic ob-
jects, and so on.

2. Page: options to modify the page style in use. We will come 
back to this in the Chapter 6.

3. Styles: the tool to manage styles in Writer. We will talk about 
it also in the Chapter 6.

4. Gallery: LibO offers a large number of  images and sounds 
ready to add in our documents. We’ll talk about it in the Chap-
ter 14.

5. Navigator:  The  indispensable  tool  that  not  only  helps  us 
move quickly throughout the document,  it  also allows us to 
manage its content by changing the order of the chapters or 
the  “level”  of  its  parts.  We will  talk  about  this  tool…  many 
times.

The first button (a menu, actually) that we have skipped serves to 
configure the sidebar, choosing which panels to display (checking or 
un-checking the corresponding entry under Customization), “un-dock” 
the bar to convert it into a floating window, etc.

The sections that we have available in each panel depend on the se-
lected content.

The sidebar can only be anchored to the right or to the left of the 
LibO window, it can not be anchored to the upper or lower edges: the  
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sidebar is, well, only lateral.
In addition to using the configuration menu, to un-dock the sidebar 

it is enough to take it with the mouse from the top where you can read 
the title of the panel currently in use and simply move it away from its 
position. 

To re-dock the sidebar, simply drag it to one of the sides of the pro-
gram window, similar to how you anchor a common toolbar. A third 
option to dock / un-dock the sidebar is to Ctrl double-click on a free 
part of it.

Those who for any reason prefer not to use the sidebar can deacti-
vate it (or reactivate it,  after missing it)  in  View ▶ Sidebar  or with 
CtrlF5.

There are two ways to “hide” the sidebar. The first one is by clicking 
on the button of the active tab. For example, if we have the style editor 
active and click on the button that represents it, the bar closes on itself 
leaving only the buttons that represent the tabs. With a click on any of  
the buttons, it will open again.

When you have the sidebar open and anchored to one of the sides 
of the active window, in the middle of the free edge you have a thin 
button: clicking on it the entire “box” that forms the sidebar “hides,” 
closing about itself. The only thing that remains visible is a thin bar 
with the even thinner button (this time inverted) that allows us to open 
our “toolbox” again.

And now a well-kept secret, but extremely interesting: if instead of 
clicking the button to open our toolbox again we click anywhere else 
in the thin bar  the  toolbox opens too,  but it  will  close  automatically  
when the cursor returns to the document. That is, the sidebar can be hidden  
automatically when we no longer need it.

2.6 Other panels and bars
Except for the “properties” and “page” panels that are new, the other 
three panels that are part of the sidebar existed previously as indepen-
dent dialog. 

Moving forward in the development history, all  of those floating 
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panels have been removed to privilege the sidebar, except for the Navi-
gator that is still available, at least for the moment, as an independent 
panel.

But there are other panels: that of the page thumbnails in Draw that 
we will discuss in  Chapter 14, for example, or the data source panel 
that we will briefly discuss when talking about the bibliographic data-
base in 9.5. 

Other tools are presented as stand alone windows that cannot be 
anchored,  such  as  the  “full”  search&replace  tool  we  will  discuss  in 
Chapter 18.

An extremely important bar is the “status bar,”  which can be en-
abled or disabled (don’t do that!) in View ▶ Status Bar . 

This status bar is always at the bottom of the working window in all 
LibO components and shows important information. For example, in 
Writer shows, in this order: 

1. the page number: a click there opens the tool “Go to Page”

2. the number of words and characters in the document or selec-
tion: a click opens the word counting tool

3. the page style used in the cursor position: a click on the name 
opens a menu to edit that style (we will talk about the styles in 
the Chapter 6)

4. the language of the text on which the cursor is located: a click 
on it provides several options that we will see later (we will 
talk about the spell checker in the section 3.3)

5. a button (not very visible) that with a click changes between 
“Insert  Mode” and “Overwrite”  (it  does  the same as  the key 
Ins)

6. a drop-down menu (right click) to select the way text is se-
lected:  Standard for  normal mode,  Extended (select from the 
cursor position where we click), Added for a multiple selection 
(if we had selected something in  standard, changing to added 
the second selection will be added to the first) and Block to se-
lect a “block” of text
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7. an icon that indicates whether the active document has been 
saved or not

8. a small, almost invisible box that indicates whether the docu-
ment has  been signed electronically  or  not  and that  with a 
click allows us to access the signature option (we will not dis-
cuss it in this book)

9. a wider box that shows different  information depending on 
context, such as the numbering level if the cursor is in a num-
bered list or a heading title, giving us access with a single click 
to modify the properties of that numbering, or the name of the 
“section” (no, they are not what you think:  11.1) in which we 
are, giving access to its settings

10. the tool  to  control  the  zoom level  of  the  document,  if  two 
pages or one are shown, and so on.

2.7 Colors and icons
In  Tools  ▶  Options  ▶  LibreOffice  ▶  Application  Colors  you  can 
change the colors of the graphical interface. 

For example, it is possible to change the color used by Writer to 
show the page breaks, the limits of the text, the edges of the objects, the 
color of the edge of the sections… all the colors that make the program, 
not the document.

For those who want to give to the program a more… how to define 
it, personal appearance?, LibO supports the use of Firefox themes. It is 
possible to configure this in Tools ▶ Options ▶ LibreOffice ▶ Person-
alization , but do not ask me how such a thing works that I always try 
to keep distance from those things.

In Tools ▶ Options ▶ LibreOffice ▶ View  you can select between 
the different icon themes available and the size in which they should be 
displayed. The notebookbar item there refers to an experimental inter-
face we will briefly discuss at the end of this chapter.

From version 6 it is possible to install icon themes as extensions. 
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We will return to this later.
Finally, in View ▶ Text Boundaries  we can select if we want to see 

or not the four small angles that frame the text area during the editing  
of the document, while in View ▶ Table Boundaries  we can make the 
same decision for the “editing edges” of the tables (the real edges are al-
ways shown).

Here, I must confess, I have to take a deep breath to be able to keep 
going without exploding in an annoying rant, so we better leave it here  
and jump to the next topic that those “little angles” that LibO uses as 
“text boundaries” and the need to activate the mostly annoying “non 
printable characters” to see the more than useful full edges make my 
blood pressure and heart rate rise, so I’ll simply leave you with the link 
to the following bug report:

Bug  74386 -  UI:  Provide  obvious  way  to  turn  full-page  text  
boundaries on/off, independent from Show non printing characters  

OK, let’s move on.

2.8 WYSIWYG, ma non troppo
Writer is usually classified as a “WYSIWYG” program (What You See Is  
What You Get), which is only partially true. 

Luckily, Writer shows during the editing some details that will not 
be  printed  nor  sent  to PDF:  elements  handled  automatically  by  the 
program such as the fields that indicate the page numbers or cross ref-
erences, the indexes, etc., show by default a gray background.

As we said, this background is neither printed nor exported to PDF 
and it is there only to indicate that the content it highlights is “special.” 
In Tools ▶ Options ▶ LibreOffice ▶ Application Colors , under General 
and Text Document we can modify (or deactivate) those colors. 

These gray backgrounds are really useful when it comes to know-
ing, in a complex document, what has been written by us and what has 
been generated automatically,  so I recommend you experiment with 
the colors that you like most, but do not deactivate it.
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2.9 Windows and more windows
For  those  who like  the  word processors  that  allows  them  to  work 
“without distractions” (whatever that means), LibO offers a “full screen 
mode” where no toolbars are visible: you only see the page, the “com-
ments” bar and the button to exit from this mode. 

To activate this “distraction free” mode, View ▶ Full Screen  or the 
keyboard shortcut CtrlShiftJ. In this mode it is possible to activate 
the simplified search bar with CtrlF.

Writer has a “one document per window” interface, which means 
that if  we open two or more documents they will  open in separate 
windows.

The list of all open windows can be seen under the Window menu, 
which also allows us to move from one document to another. 

There we can also find the option of cryptic name  New Window: 
what this option does is to open a new window with the same docu-
ment on which we are working, in order to see or even modify two 
different parts of it simultaneously.

2.10 Other interface options
Under the menu View ▶ User Interface  we can select between differ-
ent options of the graphic interface.

In addition to the default scheme we have one with a single toolbar 
and another centered on the sidebar.

But there is more: still considered an experimental characteristic, it 
is possible to activate an experience where instead of the classic menus 
we have a series of bars with tabs. 

In order to use this new interface scheme, we have to first activate 
the “experimental  options” under  Tools ▶ Options ▶ LibreOffice ▶  
Advanced ▶ Activate Experimental Features . After restarting the ap-
plication, in the menu indicated above we will find other provisions of 
toolbars to test.

I leave it to your curiosity to try these “new” options: in the remain-
der of the book I will use only the default interface as a reference.
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With the sidebar open, of course. I love the sidebar.
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Chapter 3

Essential tools

In this chapter we will outline some of the essential tools for working 
in Writer. 

We will start by talking about the User Data and the document Prop-
erties as this will give an “identity” to our documents and will make our 
work easier. 

We will continue with the comments and version control. 
Then we will talk about the dictionaries and the spell checker. 
We will also dedicate a space to the handling of images. 
We will introduce a tool that will be essential when handling com-

plex documents: the Navigator. 
The chapter closes with a brief comment on the “extensions,” small 

add-ons that allow us to add even more functionality to the program.
Some of the topics will only be outlined in this chapter, since the 

complete understanding of them requires the use of tools that will be 
discussed later.

Important: in the rest of this book it will assumed that we are  
working with the ODF file format (.odt for Writer, .odg for Draw,  
etc.).

Many of the LibO features discussed in this book may not work if  
“alien” file formats are used, so to get the best results you should  
always work with LibO’s native file formats.
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3.1 User information and document proper-
ties
Writer has a very ingenious way of deciding whether when opening a 
document it should go to the last edited point or at the beginning of it:  
if the user data of the program matches the information of the author 
of the file it goes to the last edited point, otherwise to the beginning of  
the document.

The logic behind this  behavior is  quite simple:  the author of  the 
document surely wants to continue editing it at the point where he/she 
left it, while someone who is not the author simply wants to read it and 
therefore the beginning of the file is the most logical place. If in any 
case  you want  to go to  the last  edited point  the  keyboard shortcut  
ShiftF5 (Restore Edit View) will be enough, just as CtrlHome allows us 
to go to the beginning of the document.

Now, where does Writer get the information to make these com-
parisons? Everything we need is in Tools ▶ Options ▶ LibreOffice ▶  
User data : it is not necessary to fill in all the fields, one will be enough 
to  give  an  “identity”  to  the  user.  When  creating  a  new  document, 
Writer by default includes in it this information so the system works 
perfectly.

And what to do with the documents that were created before com-
pleting this information? How can we say that we are the “owners” of 
those files? Simple:  after opening a file without user information or 
with wrong information, we must go to the menu File ▶ Properties ▶  
General tab  where it is enough to check the option Apply User Data  
to then press the button Reset Properties .1

In these “properties” of the document we can add more information 
that will be very useful when generating a PDF.

Consider, for example, the  Description tab. There we can write the 
Title2 and the Subject of the document, add Keywords or even a descrip-
tion of the document content.

1 This same procedure, but removing the mark can be used to delete user in-
formation from a file.
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In the Custom Properties  tab we can define new fields, such as the 
“author.”

All the information that we enter in these tabs is also available to be 
used in the document: we will come back to this when talking about 
fields in Chapter 13.

CMIS is an integrated document management standard that I will 
not discuss in this book, nor will I discuss security options.

The last tab of this menu with some relevance for this book is the 
one labeled as Font, which allows us to embed the typographical fonts 
used in the document.  But attention: although embedding fonts can 
simplify taking a document to another system, it also increases the size 
of the file. We will comment more about this in 5.5. 

3.2 Comments and “versions”
When we write an extensive document it is always useful to associate 
some “notes” to certain parts of the text, either to remind us to review 
a wording that still does not convince us, to indicate what is missing or  
to declare an idea that we do not want to forget.

Especially when working in collaboration (although some people 
might  find it  useful  for  personal  use)  it  might  also be  important  to 
track changes or maintain a “versioning system” so we have the possi-
bility to go back in a not-quite-happy change.

In this section we will briefly review the options offered by Writer 
for both tasks.

3.2.1 Comments
Insert ▶ Comment , or CtrlAltC, adds to the right of the page a 

box waiting for text, which is “anchored” to the point of the document 
where the cursor was when inserted. This box lives in a gray bar, which 
can be closed or opened with the Comments button at the top of it. The 

2 If this field is empty, when exporting the document to PDF the title of the 
latter will be that of the template used to create the document, which can 
be somewhat… confusing. Better give it a name!
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comments present in the lower part information about the user who 
introduced them, the day and time of its creation and a menu. From 
this menu we can eventually delete the comment or even Replay it (if 
the user who modifies the document is different from the one who cre-
ated the original comment).

The notes can also be assigned to a range of text, not just to a point:  
it is enough to select the text with the cursor before entering the com-
ment.

The Comments button to close or open the comments bar is visible 
only if the “ruler” is active:  View ▶ Rulers ▶ Rulers  or with the key-
board shortcut CtrlShiftR.

Comments entered by different users in the same document are dis-
played in different colors.

Currently there is no graphic option to customize the colors of the 
comments, which are automatically selected, but it is possible to con-
figure the font used in them through the menu that we mentioned: the  
option Format All Comments.

It is possible to print the comments alone or with the document, ei-
ther in the margins of the page where they were introduced (the page 
will be automatically reduced), in a separate page or at the end, simply 
selecting the appropriate option in the lower part of the “General” tab 
of the print menu (CtrlP or File ▶ Print ).

3.2.2 Track changes
With  the  menu  Edit  ▶  Track  Changes  ▶  Record ,  Writer  will  start 
tracking every change performed in the document.

It is important to note that there is a toolbar called Track Changes 
that simplifies the use of this option.

With the change tracking active we see that the text that we enter 
have a different color and is underlined. We can also see how the lines 
that have changed are indicated on the left margin. With the mouse 
pointer  over  the  text  a  small  message  that  indicates  who made  the 
change and when is shown.

By right clicking (or using the toolbar) on the marked text we can 
choose between accepting or rejecting a change. If now on an accepted 
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text, which is normally seen, we make an edit it will again be in an-
other color and with a different format: for example, any text that we 
try to erase will remain there until the change is explicitly accepted.

In Edit ▶ Track Changes ▶ Manage ▶ List  we have a list of changes 
that have not yet been accepted: by selecting one of the changes in the 
list the corresponding text is highlighted in the document. If several 
authors have made changes in the same document, they will be clearly 
displayed.

With a right click on a change in the list it is possible to add a “com-
ment” on it, which is shown in the Comment column. These comments 
should not be confused with those we have discussed at the beginning 
of this section.

In the Filter  tab it is possible to filter the changes by author, cre-
ation date, type of action (add, delete…), and so on.

In the menu Tools ▶ Options ▶ LibreOffice Writer ▶ Changes  we 
can  customize  the  colors  used  to  indicate  the  changes  or  how  the 
changed lines are indicated.

It is possible to make the changes not explicitly marked (although 
they continue to be registered) by disabling  Edit ▶ Track Changes ▶  
Show : this will make the document more “readable” during editing.

There is much more to say about this tool, but since I do not use it 
that much… in short, I let you explore it.

3.2.3 Compare documents
Edit ▶ Track Changes ▶ Compare Document  allows us to take two 
documents that are modifications of an original document and com-
pare them to each other to see what their differences are: it is enough,  
from one of the documents, to go to this menu and select the other 
document to  let  Writer  automatically  mark the differences  between 
both, allowing us to accept or reject them.

This is particularly useful when several collaborators work simulta-
neously on copies of the original document: by opening the reference 
document and from there calling the comparison function to see what 
has changed in the copy, we can control the changes without fear of 
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forgetting anything.
The window that is presented works exactly like the one we found 

in the previous section to compare the changes of a document with the 
“track changes” recording being active.

3.2.4 Versions
An alternative way to control changes, which is perhaps more “legible” 
while editing the document, is to use Versions.

Instead of “save as” periodically and use another name to have a 
different file for each version, the functions offered by the menu File ▶  
Versions  can be used to save several versions of the document within 
the same file.

The menu that is  presented allows us to not only save a version 
whenever we want, but also to  force Writer to create a new version 
each time we save the document (the option Always save a new version  
on closing).

When we manually save a version we have the possibility to write a 
small comment about it which can be later edited by selecting the ver-
sion of the list and clicking on Show.

The  Open button shows the selected version of  the list  as  a  new 
read-only document,  while  Delete will  completely erase that version 
without touching the others.

The  Compare button works  in  the  same  way  as  the  comparison 
function discussed above.

It is important to note that the version control system clearly gives 
much larger files since a complete copy of the content is saved in the 
file each time we save a new version. Therefore, if we work in low-re-
source systems or if the document is particularly large and complex, it 
is better to save the versions as independent documents that we can 
later compare manually with the option shown above.

3.3 Dictionaries
Here we will  review the  possible  causes  of  the  main problems that 
could be had with the spell checking in Writer. We will go from the 
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most obvious to the not so. At the end, the possibility of using a gram-
mar checker is discussed.

It is important to note that the management of the language of the 
text is done through paragraph and character styles, which we will dis-
cuss in  Chapter 6, so some points will be discussed only superficially 
here.

3.3.1 Where to look if there are problems
First of all, to know which language uses the text on which the cursor 
is located, it is enough to look at the status bar at the lower edge of the 
Writer window, where it shows (in this order, from left to right) the 
page number, the number of words in the document / selection, the 
page style and the language of the text: if  the language is wrong, or 
even worse says “none,” we can understand why the correction is not 
working.

If  the  language  is  correct,  then  check  that  the  “automatic  spell  
checking” is active. For this it is enough to look at the Tools  menu.

If it still does not work, it is necessary to check that the dictionary  
is installed! In Tools ▶ Options ▶ Language Settings ▶ Languages , it is 
necessary to check the list of  Default Languages for Documents. If the 
dictionary is correctly installed, to the left of the name of the language  
there should be an icon whose shape depends on the icon theme used: 
with Breeze it is an «A» with green ellipsis, in Elementary it is «AB» 
with a green check-mark, etc. Let’s say, the important thing is to have 
an icon. If next to the name of the language there is nothing this means 
that the dictionary is not available. Below we will see how to solve this  
problem.

Once this has been resolved, let us return to the cases in which the  
language “is wrong.”

It is very tempting to change the language of a document with the 
menu Tools ▶ Language , or with Format ▶ Character ▶ Font tab , but 
that would be a direct formatting, which in the long run always brings 
problems.

As we will see in the styles and templates guide (Chapter 6), both 
paragraph and character styles can define the language (Font tab). The 
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paragraph style called “Default” is the first one that should be checked 
if the language of the document is not correct, since many paragraph 
styles inherit characteristics of it and therefore can also inherit their 
language settings. It is thus necessary to edit the “Default” paragraph 
style and make sure that the correct language is selected in the Font tab 
(and that the aforementioned icon  is there).  If that paragraph style is 
correct, you should proceed to check that the other styles used do not  
show changes in the language: this problem is very common with files 
imported from other programs.

It is also necessary to ensure that no character style is applied to the 
text or, even worse, direct formatting, since these could change the lan-
guage of the text. The problem is that selecting “clean direct format-
ting” (CtrlM) to erase direct formatting does not change the manu-
ally changed language3

Bug 79455 -  FORMATTING: Ctrl+M does  not  clear  language  
settings 

If for some reason the language of a piece of text has been changed 
manually, the simplest way to go back to what is predetermined by the  
paragraph style is to select the text and click on the name of the lan-
guage used that is shown in the status bar (remember that that bar was 
the first thing we had to look at?): among the available options is one to 
reset the language to recover what is predetermined in the style.

Again, using direct formatting is always a bad idea.

3.3.2 The dictionary is not installed!
In LibO the dictionaries are installed as extensions (we will talk about 
them at the end of this chapter). The extensions with the dictionaries 
can be found on the following page

https://extensions.libreoffice.org/extensions?
getCategories=Dictionary&getCompatibility=any

Depending on the configuration of the system, it is possible to in-

3 This is another one of those issues that gives me a rise of blood pressure. 
Better not to talk about it! Let’s move forward.
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stall the downloaded extensions by double clicking on them (one only 
if you use Plasma) or from the menu  Tools ▶ Extension manager ▶  
Add  and navigate to the extension file.

Important: The dictionary must match the language of the text  
exactly. For example, if the dictionary of “Spanish of Spain” is in-
stalled, but the language is configured as “Spanish of Venezuela”  
the correction will not work.

3.3.3 Why is the system like this?
The system to define languages in LibO is very powerful because with 
it is possible to:

• have our language by default, for example English, easily de-
fined in the default template.

• write  paragraphs  in another language,  for  example  Spanish, 
quickly thanks to paragraph styles.

• introduce in these paragraphs in another language citations in 
a third one, for example Italian, thanks to the character styles.

And all this automatically recognized by the spell checker.

3.3.4 Thesaurus
Writer includes the possibility of using a thesaurus from the context 
menu ( right click on the word ▶ Synonyms ).

From this context menu, with a click on Thesaurus, you get to the 
full version of the thesaurus. It is also possible to access it with Tools ▶  
Thesaurus  (CtrlF7).

It must be taken into account that although the system recognizes 
plurals and verb conjugations without problems, it will offer singular 
and infinitives for the substitution.
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3.3.5 Grammar checker?
In addition to some very simple tools that however only work for Eng-
lish ( Tools ▶ Options ▶ Language Settings ▶ English sentence check-
ing ), LibO includes an interface to use external grammar checkers. At 
this time the most developed extension is perhaps LanguageTool:

https://languagetool.org/

For French we also have Grammalecte:

https://www.dicollecte.org/?download_lo 

In the page of the extensions (we will talk about them below) there 
are tools for other languages such as Portuguese, Russian, etc., but the 
development of most of them seems stagnant.

3.3.6 The hyphenation has been wrong!
Creating a dictionary is much more than gathering a list of words, so it 
is a really difficult task: you have to take into account declensions, con-
jugations of verbs, compound words… if we only list all the combina-
tions the dictionaries would result in files of monstrous size and com-
pletely unusable.

Establishing rules to construct or divide words is essential to have 
an efficient dictionary, but since human languages are complex, these 
rules are also complex, so mistakes can be made: although most of the 
time they do the right work, the hyphenation dictionary every so often 
can give us a strange separation by cutting where it should not.

The only thing we can do about it is to be attentive to locate the er-
ror and tell Writer where we want the word to break. For this we move 
the cursor to the place where we want to break the word if it is close to 
the margin and select  Insert ▶ Format Mark ▶ Soft hyphen , or press 
Ctrl-.  This separation hyphen is shown during the editing of the 
document with a gray background to indicate that it is “special,” but it  
will only come into operation when necessary.
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3.3.7 Extra notes
• After installing or uninstalling a dictionary it is necessary 

to completely restart LibO. This involves closing all appli-
cations: Writer, Calc, Draw… everything.

• Linux users have the dictionaries available in the reposito-
ries  in  the  form  of  myspell  packages:  for  example, 
myspell-es_ES. 

• Depending on the configuration of the program, it could 
happen that the spell checker does not correct words that 
are completely written in uppercase. To change this, sim-
ply go to Tools ▶ Options ▶ Language settings ▶ Writing  
Aids  and under Options select Check uppercase words.

There it is also possible to select Check words with num-
bers .

3.4 Quickly change the order of paragraphs
CtrlAlt↑  to  “move  upwards”  a  paragraph  or  CtrlAlt↓ to 
“move it downwards.”

This also works for paragraph selections: if  more than one para-
graph is selected (even in non-complete form), all of them will move 
together.

Tables4 “block” this movement, but if instead of moving the para-
graph we select the entire table as if it were text (at least one line before 
and one after it must be selected) then we can move the whole table 
without problems using these keyboard shortcuts.

Attention should be paid if there are objects “anchored” to the para-
graphs that we are moving, especially if the position of those objects is 
determined with respect to the text area of the page. We will return to 
this in 11.2.

4 We will see more problems with tables in 12.2. We will also see solutions, 
yes.
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3.5 Special characters
Who has not had to insert in a document a Greek character, a mathe-
matical symbol or anything else that does not appear on the keyboard 
of our computers.

LibO offers several methods to insert special characters. In this sec-
tion we will see some that are useful to insert special characters every  
so often, while in 10.1 we will see what to do to always have at hand 
that special character that we need to use frequently.

It is advisable not to mix typographical fonts just to insert a special  
character. Modern fonts offer a wide variety of symbols and alpha-
bets, so it is usually not necessary to search for a font other than  
the one used as the basis for the document.

3.5.1 The special character menu
Either from  Insert ▶ Special  Character  or  from the corresponding 
icon in the standard toolbar we can open the classic tool to select a font 
and character from that font.

Since version 6, LibO offers us two very interesting features in this 
dialog: a list of recently used characters and the possibility of marking, 
with a simple right click, a character as “favorite.”

Modifying the Standard toolbar, we find that there is a second but-
ton called “symbol.” This second button is actually a menu that offers 
three options: the list of favorite characters, the recently used ones and 
the access to the classic menu to insert special characters of which we 
spoke before. Let each one test whether this “symbol” menu is useful or 
not. I do not use it for myself.

As of version 6.2, this “second button/menu” will replace the origi-
nal one as a predefined option.

3.5.2 Unicode code
The Unicode standard gives a unique hexadecimal code for most of the 

44 Special characters



characters of all  human languages, in addition to identifying mathe-
matical and other symbols.5 

With LibO it is really simply to pass from the hexadecimal code to 
the symbol that that code represents: it is enough to use the AltX key 
combination.

On mac systems the combination appears to be  ⌘⌥X or,  in  
certain locations, AltC.6

For example, the triangle with a bar below  is associated with the⧋  
Unicode code 29CB, so to insert it in Writer (or in Math, or anywhere 
in LibO where you can use the keyboard) it is enough to type 29cb and 
immediately press AltX.

To know the hexadecimal code of a given character we can simply 
look at it in the tool to insert special characters commented above, or 
transform a character already inserted in its code with the same AltX 
keyboard shortcut.

3.6 Define colors
Almost  any element of  a  document  can receive  a  color:  text,  back-
grounds, pages, graphic objects…

LibO uses the concept of  “palette” to manage colors.  The offered 
palettes are many (standard, LibreOffice, tonal, HTML). Now, if we do 
not find a color that we like in the predefined palettes, can we define 
other colors to use in our documents?

Yes, but the way to do it is somewhat “hidden.”
We have to:

1. Insert any graphic object, for example a square, into any docu-
ment

2. Go to the properties of the object ( right click ▶ Area ) and se-
lect the Area tab

5 Also emojis, of course.

6 They told me so. No idea.
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3. Under Colors we select the Custom palette and there we define 
our color

4. Press Add and provide a name for the color

Once this is done, the new color will be available in the custom pal-
ette and can be used in any property that accepts a color.

This definition can be done both in Writer and in Draw or even 
from Calc: the color thus created will be available in all  the compo-
nents.

3.7 Images embedded or linked
When we do Insert ▶ Image , at the bottom left we have the option In-
sert as Link .

This option makes the image not included in the file, only linked.
When selecting this  option the program will  ask  us  if  we  really 

want  to  do  what  we  are  doing  with  a  signal  that  seems  to  try  to 
frighten us, what is the problem? Well, if we move the file and we for-
get to also carry the image, we will have a “broken” document.

Writer stores the links in a relative way, so if you save the file in the 
Documents/Work  folder  and  in  Documents/Work/Images  the  im-
ages, it is enough, if you want to move the whole project to another 
computer, to copy in full the Work  folder.

To make the linked images to be embedded in the document, go to 
Edit ▶ Links to External Files , select the links in the list and press the 
Break Link  button. 

Unfortunately, there is no simple way to make an image embedded 
in the document become linked… there is, however, a not so simple 
way: we will talk about it in Apendix A.

When  inserting  an  image  with  the  menus  (instead  of  “drag  and 
drop”) we also have the option to choose the frame style to use, but 
since we have not yet talked about styles we will leave that topic for the 
moment: we will return to this (and more!) both in the  Chapter 6 as 
well as in 11.2.
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3.8 Image captions
If we make a right click on an image, we will see the option Insert Cap-
tion.

With this option we can number our images, add to them an ex-
planatory text and a “category.” By default, we have the category “Fig-
ure” for the images, but we can choose any other from the  Category 
menu and even define a new one: we simply delete what is  written 
there to create the name we want (for example, Photography).

Once the category is chosen, we only have to write the Caption (we 
can edit the text after inserting it, so do not worry about the content 
yet), choose if the caption goes above or below the image, a separator 
that is written between the numbering and the text of the legend and 
we can click in OK.

The Options button gives us many, well, options, such as choosing to 
modify the numbering in order to include the chapter number, among 
other things (we will return to this later). There you can also select a 
character style for the category label, but do not get too excited that 
you have to do this every time: the selection is not maintained for the 
next figure.

Going back to the “caption,” what Writer does with all this is to en-
close the image in a frame (11.2) and create a number range (13.5) that 
not only numbers the image, but also makes possible the creation of an 
index (Chapter 9). A particular paragraph style (Chapter 6) is applied to 
the caption with which its format is controlled.

Later we will see how to configure all these things.
One last observation: it is possible to have Writer automatically in-

sert captions in all the figures, tables, whatever it is necessary for us to 
insert:  Tools ▶ Options ▶ LibreOffice Writer ▶ AutoCaption . These 
automatic captions work only for images inserted from the menu: drag 
and drop does not work. The advantage is that the character style for 
the category label will be applied every time. But hey, we still have not  
talked about styles, so let’s leave this for now. Just for now.
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3.9 Writer, PDF and vector images
Writer (like all LibO applications) has the ability to export files to PDF 
format, generating documents that include the fonts, which respect the 
links,  to  which  a  “security”  can  be  assigned,  which  may  contain  a 
form… It is enough to explore the possibilities of the menu presented 
in File ▶ Export as ▶ Export as PDF  to see the power of this tool.

Important note: By default, when you export to PDF Writer  
does  not  include blank pages  inserted automatically,  which is  a  
problem if we use the PDF to print.

To change this, go to File ▶ Export as ▶ Export as PDF  and se-
lect the option Export automatically inserted blank pages.

It is convenient to avoid the temptation to use the button to export  
to PDF directly: by going to File ▶ Export as ▶ Export as PDF  
we will always have everything under control.

It is not possible to open PDF files in Writer,7 but in the latest ver-
sions the support for using a single page PDF as another image format 
is improving. At the moment it is still advisable to use SVG instead of 
PDF, especially if you want to retain the vector character of the image.

3.9.1 PDF types
LibO can export in PDF / A-1 format, which is an ISO standard for 
“document preservation.” This format includes all the fonts used, so it 
usually gives larger PDF files, but offers the benefit that the document 
can be opened without problems in any system.

It is also possible to create forms that can be filled from a normal 
PDF viewer and in fact Writer offers four formats to save them. It is  
possible to digitally sign the files, set a password…

A whole world to explore.

7 It is possible to open them in Draw to make small modifications, but un-
less the document is particularly simple the results may not be as good as 
we might expect.
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3.9.2 PDF properties
PDF files also store different “properties,” such as the name of the docu-
ment, its author, some “key words” that define it, etc., which are avail-
able to all PDF readers.

As we saw in 3.1, to configure these properties, before creating the 
PDF we must go to the menu File ▶ Properties  and complete the in-
formation on the Description tab. We also have to be sure that when we 
export to PDF, in the User Interface tab, the option Display document ti-
tle is selected (this is the default in any new installation).

3.9.3 Picture formats and PDF
Virtually any image format supported by Writer will be exported to 
PDF, but some formats give better results than others.

For “bitmap” images, PNG will be the best option for screenshots 
while it is convenient to choose jpeg for photographs.

It is important to bear in mind that by default  LibO reduces the 
quality of the images when exporting to PDF. If we want to maintain 
the original quality of the images, when we do File ▶ Export as ▶ Ex-
port as PDF , in the General tab, under Images we must select Lossless  
compression and, possibly, remove the check mark on Reduce image res-
olution.

Certainly this will give us larger PDF files,  which is not always a 
good idea: maintaining images with a higher resolution than the sys-
tem we will use to print or, even worse, view the PDF is meaningless,  
so it is important to think with care about what we really need.

Let’s talk now about “vector” image formats.
The EPS image format (Encapsulated PostScript) is one of the oldest 

vector image formats that exist. It is possible to include EPS images in 
Writer documents, but these will be shown only through a low-quality 
“preview” in raster format and only when this preview is included in 
the file. This means that if Writer’s own tool is used to export to PDF 
the preview and not the actual image will be included in the result.

It is best to look for some tool to convert the EPS image into an 
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SVG image before inserting it in Writer.8
In fact, LibO includes native support for the SVG vector image for-

mat. This means that it is possible to insert an image generated for ex-
ample in Inkscape or another vector drawing program and use it with-
out problems as another format.

When exporting to PDF format, SVG images are included as vector 
images giving the highest possible quality to our documents.

LibO can also use a vector format called  Graphics Device Interface  
metafile (GDI). This format is particularly useful for, for example, copy-
ing an object created in Draw and pasting it in Writer as a vector im-
age. We will come back to this in the Chapter 14.

3.10 The Navigator
The Navigator, accessible both in the sidebar and in the form of a sepa-
rate panel (by pressing  F5 or with  View ▶ Navigator ), is one of the 
most useful tools when editing complex documents. In this section we 
will try to show its virtues.

3.10.1 Navigate the document
The Navigator offers an ordered list of all  the elements in the docu-
ment. We see in it, for example, all the chapters of the document, all the 
tables, all the frames, the images, the objects, the text marks, the sec-
tions, the comments… everything, organized in a “tree” structure sepa-
rated into “Nodes.” With a double click on an element of the list we will  
be “carried” there by Writer while the triangle on the left can be used to 
open or close the corresponding node.

It is important to note that the behavior of the Navigator against 
double click has changed in LibO 6.1: in the headings, the double click 
only takes us to the selected element while in previous versions this 
double click also opened / closed the node on which we were acting. 
For the other elements of  the Navigator,  the double click continues 

8 If you use Linux, you may be interested in this article:  
https://frommindtotype.wordpress.com/2018/10/15/convert-eps-files-
into-modern-vector-formats-linux/ 
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opening or closing the node as before, it is only for the headings that 
the behavior has (luckily!) has changed.

At the top of the Navigator we have several options, grouped into 
two lines of buttons.

The first three buttons in the first row are to “navigate” the docu-
ment: the first opens the  Navigation toolbar where you can select an 
object type while the other two buttons are used to jump to the previ-
ous object or the next one in the category selected with the first button.

Next, there is a page selector.
The next button (actually,  a  menu),  the  Drag Mode,  is  interesting 

when building documents with dynamic links that need to be exported 
to PDF: if Insert as Hyperlink is selected, when dragging an object from 
the Navigator to a position in the document a hyperlink to the object 
will be created there. If, on the other hand, you have Insert as Link or 
Insert as Copy, the element will be “copied” in the new position, either 
through a link or a “real” copy.

Leaving the last two buttons of the first line for later, let’s move to  
the second line (whose last two buttons will also be relegated for the 
moment).

The first button of this second line switches between the full view 
of the document structure or only the headings.

This button is also a quick way to “update” the list, forcing the selec-
tion of the heading under which the cursor is located. In fact, in this 
mode called  Content Navigation View,  the heading within which the 
cursor is located will always be selected, which is very convenient.

Before  someone  asks:  “headings”  are  paragraphs  with  particular 
styles, so we’ll come back to this point in the Chapter 6.

The next icon (Set Remainder) is used to leave a “remainder” on the 
document… which is not visible. To use these remainders we must se-
lect, using the navigation menu mentioned above, the icon of the “re-
minders” and then we can use the previous / next buttons to go from 
one reminder to the other. Up to five marks can be defined.

Do not confuse these “reminders” that, in fact, are not very useful, 
with the “bookmarks” that can be introduced with Insert ▶ Bookmark . 
The latter are displayed in the Navigator list (not in the text), so it is  
much simpler to locate them and they are not limited in their number.
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Following in this second line, there are three buttons to quickly go 
to the header / footer (the first two) or jump between the area of the 
footnotes or their anchors (the third, we will talk about the footnotes 
in the Chapter 8).

Finally, a button with a drop-down menu that can be used to select 
the number of levels of the titles displayed by the Navigator. We can 
leave it at 10 without remorse.

3.10.2 Reorganizing the document
Let’s suppose that after reviewing what we have written, we decided 
that Chapter 3 should really be number 5 while Chapter 7 does not de-
serve to be so separate and would be better as a section of Chapter 6 
(something  that  has  happened to  me innumerable  times  during  the 
writing of this book).

For the first of the problems we can use the last two buttons of the 
first line of Navigator’s top buttons: selecting in the Navigator list the  
heading that corresponds to the chapter or section that we want to 
move, we simply use those buttons to move it (together with the sec-
tions and sub-sections under it) to the new position.

It is also possible, simply by activating the Content Navigation View 
mode we talked about above, to “drag and drop” any heading in the 
navigator to take it to another position.

For the second of the problems, the last two buttons of the second 
line can be used: by selecting the corresponding heading we can “in-
crease” or “decrease” its level. For example, if our chapters are charac-
terized by the paragraph style Heading 1 and the “sections” by the style 
Heading 2, selecting a Heading 1 from the list and pressing the last but-
ton, this paragraph will become Heading 2. And yes, we will return on 
this of the styles in the Chapter 6.

It is important to emphasize that we can make these modifications 
without “going” to the corresponding part of the document, only se-
lecting the heading to be moved / modified from the list.
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3.10.3 Viewing other documents
In the lower part of the Navigator we have a drop-down menu that to 
choose between the documents  that  we have open at  that  moment. 
Thanks to this we can see the content of  a document from another 
document, and even “go” to a particular element of that other docu-
ment with a simple double click: Writer will change window, taking us 
to the point of interest.

Now, we can not insert links by dragging elements of those docu-
ments from the Navigator, nor modify the order or level of headigns, 
we can only see what those other documents offer us.

3.10.4 Select items with the keyboard
For keyboard shortcuts lovers, the Navigator (as well as the style and 
format editor) offers the possibility of selecting a particular entry by 
simply pressing the first letter of its name.

For example, if we have several items in Navigator’s list that start 
with “P,” by repeatedly pressing the letter P the selection will go to the 
next entry that starts with that letter.

Certainly, in order for this to work, one of the entries in the list 
must be previously selected in order for the focus to pass to the Navi-
gator, otherwise we will only keep writing “P” letters in the original 
document… 

Once you have reached the entry of interest, it is enough to press 
Enter to go to the selected element.

3.11 Extensions
In this chapter we have given a quick review of the most basic tools 
offered by Writer in particular and LibO in general. Later we will see 
more advanced tools to handle the content of our documents in an ex-
quisite way.

But there is more: in LibO we can add other functions not present in 
the base package thanks to the use of extensions.

We have already mentioned them when we have talked about dic-
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tionaries  and grammar checker,  but  extensions  can do much more: 
they  can  give  us  templates  and  gallery  elements,  or  tools  to  insert 
mathematical expressions written in .9 There are extensions with 
which we can create diagrams, while others facilitate the search for el-
ements in our documents. We have icons themes or translation tools. 
Color palettes, tools that automatically format lines of code, highlight-
ing the instructions according to the language used. Integration with 
LilyPond or MuseScore to insert musical scores. Even computational 
algebra systems to perform symbolic calculations.

The extensions  open a  range  of  possibilities  only  limited  by  the 
imagination of its developers.

The main page for extensions and templates is:

https://extensions.libreoffice.org/

From there it is possible to filter the search by component or type 
of extension, categories, etc..

To manage the extensions it is enough to open Tools ▶ Extension  
manager  to install, remove or update extensions, access the extensions 
page (when the extensions offer that information), and so on.

In the next chapters we will see some examples of extensions, but I  
highly recommend to all LibO users to explore the extensions page to 
see what the system offers. More than 700 projects between extensions 
and templates are waiting to be explored. Not all are active and more 
than one have a dubious usefulness,  but  certainly  there  is  a  project 
there that will be appreciated by the user.

9 We will come back to this in the chapter Chapter 15.
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Chapter 4

The structure of a docu-
ment

When it comes to building a document, we can say that there are two 
well-defined “paradigms:” page-oriented or content-oriented. On these 
paradigms we can apply two “work methods:” direct control of the for-
mat or use of styles.

Writer is a “content-oriented” program that favors the use of styles 
during composition. In this chapter we will see what this really means 
and how a document is structured in Writer.

4.1 Continent and content
A document can not be just content: a “support” structure for that con-
tent will always be necessary. 

This means that the creation of the structure (the “continent”) and 
the content go hand in hand, but is it the structure (say, the page) that  
gives rise to the content or is the content that forces the creation of the 
structure?

Depending  on  how  we respond  to  this  question  we will  have  a 
“page-oriented”  document  processor  or  a  “content-oriented”  docu-
ment processor.
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An example of a “page-oriented” program is Scribus1: in it, the page 
is  first  configured and only then do we “fill”  it  with elements.  Only 
when the continent is ready can we think of the content.

An example  of a program (or  rather,  system) content-oriented is 
, where the content is prepared and the pages are automatically 

generated as needed, following predetermined rules.
Within LibO we can say that both Draw (Chapter 14) as well  as 

Impress (the tool to generate presentations, I will not talk about it in 
this book) are “page-oriented” programs: with them, the page / slide is 
first created to then position on it the different elements of the docu-
ment, such as text, images, and so on. 

Writer, on the other hand, is a program that is unquestionably con-
tent-oriented.

To say that one type of paradigm is better or worse than the other 
does not make sense: both have their uses. 

The “page-oriented” paradigm is better when the format is variable 
and we have many graphic elements, such as a magazine or a photogra-
phy book, while the “content-oriented” is more useful when the format 
has to be homogeneous and predictable, that is, when it can be auto-
mated.

And on automation goes the next section.

4.2 A matter of style
To understand what  styles  are,  I  think it  will  help a  small  personal 
anecdote.

A few years ago I  was commissioned to write a particular book. 
Originally it was going to be a good “production:” generous page for-
mat with wide margins and typography in 12 points… then, when I 
had already accumulated a hundred pages, it turned out that «better 
that it is A5, with 11 points fonts».

Now,  suppose  for  a  moment  that  I  had  configured  everything 
(headings, page, text) manually, deciding the format of each point inde-
pendently… terrifying! Fortunately it was not the case and, thanks to 

1 https://www.scribus.net/
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the use of styles, the change of format was ready in a matter of min-
utes.

Yes, minutes.
And that is the whole idea of using styles: by separating the content 

from its format it is possible to update the format without having to 
touch the content.

When working with styles, instead of saying “since this is a chapter 
heading we have to write it in 16 points, bold and with this font,” we 
simply say “this is a chapter heading:” then, in another part, we define 
how chapter headings have to look. 

We do not say “the first page of each chapter is like this, the others  
are like that,”  we say “the paragraph style ‘chapter heading’ calls the 
page style ‘first page.’”

Then, in another place, we define how all these styles should look.
But we can say  more: for example, that the style “chapter heading” 

must be followed by the style “Text Body.” We can say that when the 
page with the “first page” style is filled the content automatically flows 
to a page with the “content” page style while this last page style is fol-
lowed by itself.

We can also  say  that  any  text  with  the  paragraph style  “chapter  
heading” applied to it must be automatically included in the table of 
contents.

We can also say that the paragraph style “Quotations” must be iden-
tical to “Text Body” in everything except the margins, so that if we then 
change the font used in “Text Body” we do not have to worry about 
changing  “Quotation”  too,  since  it  will  have  been updated  by  itself 
without extra effort from the writer.

And if that were not enough, we can put all those styles together in 
a special document that we would call “template” with which it is pos-
sible to create new documents that have exactly the same format as the 
original, but with different content.

In Writer  we have several  types  of  styles  that  we will  discuss  in 
great detail in  Chapter 6, but for this chapter we will concentrate on 
the generalities of how paragraphs and pages are constructed, which 
will give us the ability to define the structure of a document.
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4.3 Design a page
A page is defined by several parameters, many more than it might seem 
at first glance.

The most obvious of these parameters is  the  size of  the page:  its 
width and its height, but only with that we can not achieve that much.

We also have to indicate the  margins:  superior,  inferior,  left  and 
right… or maybe  internal and  external? Because we could need alter-
nating lateral margins to take into account the possibility that, once the 
document is printed, we have to bind it.

These margins define the limits of what we might call the “text area,” 
the place where the content will actually go, but by themselves they are 
not  enough:  for  different  reasons  (we  have  added a  graphic  outline 
there, for example) it could be necessary separating those limits from 
the content by establishing an extra distance, what it is usually call (not 
only by Writer) Padding.

But that will not be enough: we need to indicate where the header 
and footer of the page should be placed.

All these parameters can be seen in the Figure 4.1.
It is important to note a peculiarity in Writer: while in systems such 

as  both headers and footers are independent of the text area, usu-
ally located within the area of the upper and lower margins, in Writer  
they are part of this text area. This means that we actually have an “effec-
tive text area” that will be reduced by adding a header or a footer, so 
we will very likely have to correct the margins to take into account this 
fact

Bug 33304 - Header / Footer should be inserted into margin, not  
into text body 

And yes, we can also define how high or wide the headers or footers 
will be, but the drawing would have been too “crowded…” we will see 
these issues in more detail in future chapters.

Well, we have already defined the forms of the pages, let’s see now 
what we can put in them.
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4.4 Objects on the page
Before talking about the text, let’s consider for a moment the possibil-
ity of  inserting other objects,  such as images,  vector drawings from 
Draw… and tables, but they are a complex topic, so we will talk about  
them in more detail in 12.2.

In Writer it is possible to determine the position of the objects in 
reference to the paragraph or the page in which they are or how the 
content flows around these objects, the distance to the content, etc. (see 
11.2). 

4.5 Paragraph styles: the kings of content
We will come back to this in Chapter 6, but paragraph styles in Writer 
control not only how the text looks like but also the page breaks and 
page style changes.

In addition, and perhaps more importantly, paragraph styles pro-
vide structure to the document: they us not only give a coherent format 
to all chapter headings, they also indicate which paragraphs should be 
considered as chapter headings. And it is precisely thanks to this “tag-
ging” that we can have indexes that are generated automatically, cross  
references and much more. This is achieved by giving each paragraph 
style a “level…” but do not anticipate, we still have some issues to re-
solve before.

Let’s talk now about the geometry of the paragraphs then, leaving 
for later the line spacing, the hyphenation and the “levels.”

Everything is indicated in the Figure 4.2.
Measured from the position indicated by the “distance to the con-

tent,” we can add even more space to the left or to the right of a para-
graph indicating the “before / after text indentation.” Taking “before 
text” as a reference, we can also establish a “first line indent.” This first-
line indentation can be added or even subtracted from the “before text 
indentation,” which can be used for example to create a “hanging in-
dent” where the first line begins more to the left of the rest of the para-
graph.
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We also have to take into account the space above or bellow the 
paragraph and if that space should be maintained when we have two 
consecutive paragraphs of the same style.

As we will see later, it is possible to associate a change in page style 
to a certain paragraph or paragraph style, which can be executed both 
before (it is the default option) or after the paragraph. This is what hap-
pens  in  this  book where  the  paragraph style  that  indicates  chapter 
headings automatically generates, before of it, a page break with a style 
change.

Other objects such as tables can also be associated with changes in  
page styles, both before and after the objects themselves. We will  
return to this later.

And that’s it, we already have most of the basic elements we need to 
build a complex document easily. In the next chapter we will talk about 
typography and, in the next, we will finally start talking about styles 
and templates.

We are almost there!
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Chapter 5

Typography and related 
topics

There are many places in this book where the combination of “f” with 
“i” does not give us “fi,” but “fi:” this is what is called a “typographical 
ligature,” a type of substitution that occurs automatically thanks to a 
combination of technologies grouped under the general term of “smart 
fonts.”

Sometimes  these  substitutions  are  made for  aesthetic  reasons  or 
“readability,”  but  there  are  languages,  especially  in  the  Middle  East, 
where not replacing characters according to their position or environ-
ment can result in a spelling or even grammatical error.

But there is more. Compare the following:

Text TEXT Text Text
What we see here, surrounded by normal text that serves as a refer-

ence, are simulated (left) and real (right) Small Caps.
The simulated small caps are created simply by using the normal 

capitals and “reducing” them so that they look smaller, but this has the 
problem that the lines of each glyph will become proportionally thin-
ner too, giving the impression that the text is “more clear.” This prob-
lem can be solved using true small caps, which are not only designed 
specifically for the task and therefore always look right in the context: 
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they can also be accessed (if the font used offers them) through the op-
tions of the “Smart Fonts.”

Another example: real and simulated sub- and superscripts
22222
As can be seen, some look good and the others do not, guess which 

is which? In fact, compare an “artificial” fraction with an “appropriate”  
one

23/37  23/37
It is the same font!1 Here it is quite clear which is the “real” frac-

tion… 
In this chapter we will see an introduction to these technologies 

and how to use them in LibO, in addition to touching related topics 
such as line spacing… and the limits of all this, that the implementation 
of the font management offered by LibO is not perfect.

5.1 All about typefaces
The typographical fonts that we select so carelessly in our word pro-
cessor are much more than a series of symbols that magically appear 
when we hammer our keyboards.

We can see a modern font as a “container” for the different glyphs 
(and some “additional information” we will discuss later) where each 
glyph is in turn represented by a series of points and a “rule” about 
how to join those points. Basically there are two of these rules: join 
them  with  fragments  of  parabolas  (quadratic  splines)  or  with  cubic 
functions (cubic splines). The .ttf file format, generally known as “true-
type,” only supports quadratic splines, while the .otf file format, gener-
ally known as “opentype,” supports both.

And here it  is where things get a little more confusing since the 
term “OpenType” refers not only to the file format of the font file but 
also to those “advanced properties” that we presented in the introduc-
tion to this chapter (the “additional information” of which we talked 
above): with OpenType we can also refer to the substitution tables that 

1 Cormorant.
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allow two letters to automatically be replaced by their corresponding 
ligature, that when we have an f and a t together the first one gets auto-
matically  replaced by a  “thinner”  version of it  (its  “contextual alter-
nate”) in order to avoid a “clash” with the t, that when writing a word 
in Greek a σ at its end is automatically replaced by its variant ς, and so  
on.

And to make matters worse, it is possible to include OpenType tables  
in TrueType fonts, as in Junicode2.

There is another technology that offers advanced typographic fea-
tures: Graphite. This technology can only be applied to ttf fonts and for 
the moment it is only recognized by Firefox and by the derivatives of 
OpenOffice.org,  AOO  (through  an  old  implementation  that  nobody 
else uses anymore and that has certain limitations) and LibO.

5.2 Using these technologies in LibreOffice
Everything has to be said: the implementation of these technologies, at 
least in terms of the user’s point of view, is somewhat strange: someone 
has to present it to you, that nobody would think that it could be used  
in that way, but at least it is simple to learn and from LibO 6.2 we will  
have a sort of “wizard” of which we will talk about below.

We  will  return to  all  of  this  in  more  detail  when  talking  about 
styles, but you can start playing with these options by typing directly in 
the font name box found in the format toolbar as well as in the “prop-
erties” tab of the sidebar3.

Well, the idea is to use “extensions” for the font name that indicate 
the functions that we want to activate or deactivate. Something like 
this

Font Name:tag1&tag2

Depending on the technology used (OpenType or Graphite) these 
labels have different structures or even accept parameters. Let’s look at 

2 http://junicode.sourceforge.net/ 

3 But you should not get used to doing that, that direct formatting is our  
declared enemy.
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each of the technologies separately.

It is important to note that not all fonts offer the same level of op-
tions. In fact, most of the fonts that you have installed in your sys-
tem probably offer few or even none of these advanced features, so  
you have to pay attention to the font used.

Later we will talk about how to know the options offered by each  
font.

5.2.1 OpenType
Here the tags are of four characters, they do not accept parameters but  
they can be preceded by a “+” to activate and optional feature4 or a “-” 
to deactivate a predefined characteristic.

For example, to activate the small caps in the font used in this text, 
the smcp (Small Caps) label is necessary, whereas if for any reason we 
want to deactivate the typographic ligatures we should use -liga:

Cochineal:smcp
Cochineal:-liga

Labels can be combined: to obtain the capital letter q with the “long 
tail” in this font, the tag swsh5 is used, so to obtain the text

Qué Bellas Versalitas
we have to use as a font name

Cochineal:swsh&smcp

Bellow, a table with some of the main OpenType tags. It is impor-
tant to note that, except for really standard features such as small caps 
or fractions, what each font gives us when activating each option will  
depend to a large extent on the creativity of the author of the font. An-
other important thing to note is that some features are enabled by de-

4 The “+” is “taken for granted,” so it is not necessary to write it.

5 In other fonts, such as Libertinus Serif, this variant is found in the table of 
contextual alternates, calt.
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fault (standard and contextual ligatures) in all fonts, while other fea-
tures may or may not be active according to the developer preferences. 
For example, most fonts comes by default with lining numerals in tab-
ular format, while EBGaramond, used for many of the examples in the 
table, activates by default the old style and proportional numerals.

Characteristic Tag
Examples (EBGaramond, 

Vollkorn, Cochineal, 
Sukhumala)

Numbers

Lining lnum 1234567890

Old style onum 1234567890

Proportional pnum 1234567890

Tabular tnum 1234567890

Slashed zero zero
Not offered by EBGaramond 
(in Cochineal gives 0)

Ligatures

Standard (on by default) liga fi ff fl ffl fj

Contextual (on by default) clig
Free to the author imagina-
tion. In EBGaramond gives 
us Finales instead of Finales

Discretionary dlig
Free to the author imagina-
tion. In EBGaramond gives 
us The instead of The

Historical hlig Estilo actual

Formats, styles and position

Small caps smcp Small Caps

Superscript sups N123bcABC

Subscript subs N123abcABC

Scientific inferiors sinf N123abcABC
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Variants

Stylistic alternates salt
Not offered by EBGaramond 
(in Vollkorn change from 
agy to agy)

Contextual alternates calt In EBGaramond, gives the Q 
with “long tail” in Qué 

«Swash» swsh
Free to the author imagina-
tion. In EBGaramond 
changes Qué Reacción into 
Qué Reacción

Stylistic sets ss01 a 
ss20

Free to the author imagina-
tion. In Vollkorn, ss14 
changes 4 into 4

Character variants cv01 a 
cv99

Free to the author imagina-
tion. In EBGaramond, cv21 
changes from a to a

Fractions

Numerator numr N123abcABC

Denominator dnom N123abcABC

Fraction frac 23/37 251/1234

Alternate fraction afrc
Not offered by EBGaramond 
In Sukhumala gives 2/3 33/64

For a table with more OpenType tags, it is possible to consult the 
page of Dario Taraborelli

http://nitens.org/taraborelli/TeXOpenType 

5.2.2 Graphite
The labels that activate or deactivate the different options in Graphite 
fonts are not standardized and depend on who has developed the font,  
so in each case the documentation that accompanies it must be con-
sulted.
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The use in LibO is similar to that of OpenType fonts, with the addi-
tion of a parameter to configure the option

Font Name:label=parameter

For example, with Andika, using

Andika:dig7=1

we can change 7 into 7.
I will not talk about Graphite technology anymore, at least for now: 

although it is conceptually interesting, in practice it is practically irrele-
vant, especially for those who write in Western languages. And it is not 
only that Graphite fonts are few: the creator of this technology, SIL In-
ternational,  also includes in its  Graphite fonts OpenType tables that 
perform exactly the same functions so, except for rare exceptions, it is  
a technology that does not contribute much to the end user.

5.2.3 The “typographical limitations” of LibO
The implementation of OpenType support in LibO is neither perfect 
nor complete. One of the problems is the lack of support for “optical 
sizes.”

“Optical size” means having several versions of the same typeface, 
specially adjusted to be displayed at specific font sizes and thus im-
prove readability. Generally speaking, the details are reduced and the 
shapes are made “wider” for small sizes, while the shapes for large sizes 
are “taller,” “thinner” and more detailed. In OpenType this is handled 
with the size option, which, unfortunately, is not supported by LibO.

Very  few  fonts  offer  this  feature  (Latin  Modern,  Antykwa 
Połtawskiego, Coelacanth), but all of them are of the highest quality… 
and none of them works correctly in LibO:

Bug 112805 - Support for "size" (optical size) OpenType table 
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Another problem: the cursor moves in “strange” ways when the re-
placement takes up less space than the substituted characters (you can 
see the small video attached to the following bug report)

Bug 30731 - Cursor behaviour with Graphite fonts 

And perhaps what most affects the majority of users of these tech-
nologies: if the name of the font is extended with a tag, be it OpenType 
or Graphite, the tool to insert special characters gets confused and of-
fers the wrong font

Bug 56363 - Using Graphite features prevents Special Character  
dialog from preselecting the Graphite font 

But the most important problem is that of  interoperability.  And is 
that all this support to smart font technologies is a rather “intense” type 
of hack.

Don’t get me wrong, I love being able to use all these options and I 
applaud the work of the developers of LibO who have achieved this 
important improvement in the program. But it is that everything has to 
be said and the implementation of all this is a way to overcome a limi-
tation in the file format used by LibO, ODF, which in its current ver-
sion does not offer support for these technologies

https://issues.oasis-open.org/browse/OFFICE-3414 

So yes, LibO uses this weird thing of extending the font names be-
cause the ODF standard does not offer another possibility. This certainly 
means that other ODF editors will fail (miserably, I would add) when 
trying to open documents generated in LibO that use advanced typo-
graphic options. In fact,  when  exporting from LibO to other formats 
such as EPUB or xhtml, there are problems if OpenType options have 
been used.
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Bug 118417 - Export OpenType tags as CSS property font-feature-
settings with HTML or EPUB 

To finish I will mention a problem not strictly related to OpenType 
or Graphite, but with the general font management within LibO and 
that requires a little explanation.

The same font can have several “weights” and different “shapes.” Ex-
amples of “weights” are Normal vs.  Bold, while examples of “shapes” 
would be Normal vs. Italics. This gives us the four typical variants of a 
font, namely, Normal, Italic, Bold and Bold Italic.

Well, LibO can present problems when the font have more weights,  
ignoring some, or more shapes, confusing them.

An example of these problems is the XCharter font, which in addi-
tion to the four classical forms offers an alternative to the italic one 
called “slanted:” if all the variants are installed, LibO will say to offer 
only the italic when in fact it will give us the slanted.

Another  example:  FiraGO  is  a  sans  serif  font  that  offers  many 
weights (the last time I counted, they were 15 or so), but not all of them 
are recognized by LibO (at least three “get lost”).

Bug 77830 - PDF: slanted text becomes italic after roundtrip 

5.2.4 How to know what each font offers us
For Graphite fonts we can only check the documentation that comes 
with them, while with OpenType technology we have more options, 
especially from LibO 6.2.

In the menu to configure a font,  either as a direct formatting or 
through the use of styles, from version 6.2 of LibO we have a tool that  
“asks” the selected font what it offers and what it does not, allowing us 
to select the different tags to be used simply by activating some check 
marks.  Accepted the selection,  the  program writes the tags  as  com-
mented above.

While waiting for the arrival of 6.2, for Linux systems we have the 
command line utility  otfinfo,  which is part of  lcdf-typetools 
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package. Typing

otfinfo -f font_name.otf 

we get a list of all the OpenType features offered by the font.

5.3 Line spacing
When we review the properties of a paragraph (we will come back to 
this in  Chapter 6) Writer offers several line spacing options. Some of 
them, such as “Simple,” “1.5 lines” or “Double” seem clear enough and 
easy to understand, until we realize that we have no idea of what “sim-
ple” actually means.

The problem comes from a misconception about what is, and what 
is not, the size of a typographic font.

When we choose the canonical “12 points” (or eleven, or whatever) 
in the “size” dialog box of the font we are actually using only one of the 
possible parameters that serve to define how large a font is.

Who design typographical fonts, in addition to thinking about the 
classic  number called “font  size,”  they have to worry about  defining 
several strange things… among which is the default line spacing.

Compare the text in both columns below

Lorem ipsum dolor  sit  amet, 
consectetur  adipiscing  elit. 
Vestibulum  consequat  mi 
quis pretium semper. 

Lorem ipsum dolor  sit  amet, 
consectetur  adipiscing  elit. 
Vestibulum  consequat  mi 
quis pretium semper. 

As you can see, there are no differences between the typographical  
characters beyond the line spacing,  which is defined as simple in both  
paragraphs. The font used in the column on the left is called Gentium 
Plus while the one on the right is Gentium Plus Compact: both fonts are 
made by SIL international and the only difference between them is the 
default line spacing, which in the compact version has been deliber-
ately reduced by those who designed the typeface.

It is therefore evident that to the question “what is meant by simple 
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spacing” the only possible answer is “whatever the person who devel-
oped the font has decided:”  the distance of the simple line spacing is a  
characteristic defined by the font, it is not something controlled by Writer.

A font of, say, 12 points6 may take more than 14 because of the need 
to leave room for diacritics and other “extensions.”

The line spacing of the text depends, therefore, on the typeface con-
sidered.  For example,  for Libertinus Serif  the default  line spacing is 
about an 118% of the size of the font, while for Sukhumala the differ-
ence is 130%.

In the Chapter 6 we will see how to configure these options.

5.4 Distance between words and characters
“Justify” text, that is, make moth margins “straight,” creates a problem: 
how to regulate the space between words or, even, between characters 
of the same word to “fill” the line in a homogeneous way.

There are different techniques to improve the appearance of a justi-
fied text,  but Writer can only automatically perform the simplest of 
them: to change the distance between words in combination with the 
hyphenation at the end of the line.

As we commented in 3.3.6, the hyphenation does not always do the 
right thing, so it is better not to trust it and review the document be-
fore publishing it.  Remember: the  Ctrl- combination can save us 
from many problems.

It is  possible, although not recommended, to modify the space be-
tween characters manually, overwriting the character spacing prede-
fined by the font. We will return to this in  Chapter 6, but remember 
that it is better not to do that kind of maneuvers unless you know very  
well what you are doing.

5.5 Embed fonts in the document
We already commented7 on the end of 3.1 the possibility of embedding 

6 One point is 1⁄72 of an inch, approximately 0,353 mm.

7 Dear reader, you are about to enter a loop.
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fonts in the document: the menu File ▶ Properties ▶ Font tab . Up to 
version 6.1 the options there are somewhat limited, but starting with 
6.2 we can select to embed only the fonts actually used in the docu-
ment8 and even choose the fonts of a particular writing system. 

Still not many options (it is not possible to embed only a subset of a 
font), but it gives more possibilities.

8 Yes, exactly what you have read.
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Chapter 6

Styles and templates

The outstanding feature of Writer is the use of styles. Understanding 
how styles are used means understanding how Writer is used, thus sav-
ing unnecessary work.

We have already talked in the preceding pages about what is the im-
portant  idea behind the  concept  of  “style:”  to  separate  the  different 
components of our document according to their “function” (say, this 
paragraph is a chapter heading, this one is a note, these others the body 
of the text, this page is the first of the chapter, these others the follow-
ing…) and define elsewhere the form of each of those components (the 
first page of each chapter has these margins, the following these others 
and a footer with the page number, the headings for each chapter have 
this format and force a change of page, the body of the text has this  
other format). All these definitions happen in the style and formatting 
editor which is accessed from the corresponding tab in the sidebar or 
by pressing F11.

In this chapter we will begin to delve into each type of style in par-
ticular and we will see how to create (and modify) these styles.

Some of the topics will be dealt within this chapter only in a super-
ficial way since, due to their importance, they require chapters of their 
own.

In Writer almost everything can be associated with a style. We have 
paragraph styles, character styles, frame, page, list and table styles.

At the top of the style and format editor we have a series of buttons: 
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the categories of styles I have named above are classified with the first  
six buttons on the left. For each category we have a list of the available 
styles which can be “filtered” with the drop-down menu at the bottom 
(we will see what “hierarchical” means below). With a double click on 
the name of the style in the list, it will be applied at the cursor position.

To apply a style you can also use the first of the two buttons on the  
right, the so-called “Fill Format Mode:” the cursor turn into a kind of  
“paint jar” that can be used to “paint” the selected style on a portion of 
text. This is particularly convenient when applying character styles. To 
exit this function, press the Esc key.

If, while using the “paint jar” the right mouse button is pressed, the 
last change made will be reversed.

The last button on the right can be used to define (or update) styles 
from a manually formatted text. But since here we are enemies of the 
direct formatting we will not use that option.

6.1 Paragraph styles, and also character
As the name implies,  Paragraph styles are applied to full  paragraphs, 
where by paragraph is understood the text between two consecutive 
Enter (the “line break” produced with  ShiftEnter is  not considered as the 
start of a new paragraph), while Character styles are applied to small se-
lections within a paragraph or to certain elements such as the numbers 
of chapters or numbered lists,  entries in indexes, etc.  (we will come 
back to these things later).

Beyond  this,  important,  difference,  the  paragraph  and  character 
styles have much in common, so although in this section we will focus 
on paragraph styles, we will also indicate the similarities that they have 
with character styles, leaving the small differences for later.

By right-clicking on a paragraph style listed in the style and format 
editor and choosing Modify, we find a menu separated in different tabs 
where we can define all the characteristics of the style we are modify-
ing: font, indents, spaces, alignment, language…

The tabs are organized in two rows. It must be keep in mind that  
the active tab will always be in the lower row, so that both rows  
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will be swapped according to the chosen tab.

The characteristic that I want to highlight is the  Organizer tab: in 
the paragraph styles, in that tab is defined not only the name of the 
style but also (and mainly) what will be the paragraph style that follows it.

This is  extremely important: it is possible to define a “sequence” of 
styles in such a way that one follows the other automatically. For ex-
ample, if we apply the paragraph style “Heading 1” to a text and at the  
end of it we press Enter, Writer automatically changes to the “Text Body” 
style. Now, if we press Enter after a paragraph with the style “Text Body,” 
the next paragraph remains as “Text Body.”

As you can see the styles not only give greater consistency to the 
document, they also save us work, especially considering that in Writer 
it is possible to assign keyboard shortcuts to apply styles: by default, to 
the  styles  “Heading  1”  to  “Heading  5”  are  assigned  the  shortcuts 
Ctrl1 to  Ctrl5, while “Text Body” is assigned to  Ctrl0. It is 
also possible to create a toolbar to simplify the assignment of the styles 
we use most frequently: this is what I have done to have at hand the 
paragraph and character styles I use in this book. We have already seen 
how to organize keyboard shortcuts and toolbars in the Chapter 2.

Another point of great importance of the  Organizer tab is the op-
tion, present in almost all types of style, Inherit from. With this it is pos-
sible to have several  styles that “depend” on a main style forming a 
bond where a “parent style” passes some characteristics (the “inheri-
tance”) to one or several “child styles.” Let’s see an example. By default  
the “Heading 1” to “Heading 10” styles depend on the “Heading” style 
and therefore if we edit the “Heading” style to change the font used, 
this change will automatically be reflected in all “child” styles. This hi-
erarchy of styles, which can be evidenced in the style editor by select-
ing the “Hierarchical” filter, makes managing the structure of our doc-
uments extremely simple.

If in the style and format editor we right click on an existing style 
and select  New, the style that is generated inherits the format of the 
style on which we made the right click. If, on the other hand, to create 
the new style we right click on a blank area, the style that is generated 
is not linked to any particular style.
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When you have two styles “linked” in this way, you can configure 
the “child” style so that its font size is proportional to that of the “par-
ent”  style.  This  is  usually  configured  by  default  in  paragraph  styles 
“Heading 1” to “Heading 10” that have a font size proportional to that  
of the “Heading” style. On the Font tab of the menu to edit the style this 
is seen as a percentage value in the Size box: for example, 160%. If you 
want to break this proportionality it is enough to erase the percentage 
and simply write the size in points: for example, 18pt.

In an analogous way, to go from absolute to relative sizes it is suffi-
cient to erase the size in points and write the desired percentage.

The “inheritance” of other elements is more difficult to see. For ex-
ample, if in the  Family box both the parent and child styles have the 
same font name indicated, we have this inheritance link.

Most of the tabs you have when editing a paragraph style are easy 
to understand, so we will only review them briefly below. The excep-
tion to this is perhaps the tabs Text Flow and Outline & Numbering, of 
which we will talk in greater depth in 6.3 and 7.2.

6.1.1 Organizer tab
Also applicable to character styles.

Regarding what was previously commented, it only remains to in-
dicate that if the style inherits some characteristics of another, under 
“Contains” the list of elements that differentiate that style from the par-
ent style are displayed. Another convenient detail is that next to the 
name of the “parent” and “follower” styles we have buttons to quickly 
access to edit them.

When we create a new style we can assign there a “category” to clas-
sify it.  By default,  the new style  is  assigned to the category  Custom 
Styles, but we can choose any of those present in the menu.

6.1.2 Indent & Spacing tab
Here we can determine the indents and spaces around the paragraph 
that uses the style, as well as the line spacing.

Except for the obscure option “Register-true” of which we will talk 
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about later and the line spacing options discussed below, the elements 
of this menu are simple.

It is important to note that it is also possible to use negative values 
for indentations. Later we will see some examples.

If at the beginning of a paragraph with first line indent we delete  
backwards  with  Back,  instead  of  deleting  the  paragraph  break  
Writer will delete the indentation. To delete the paragraph break  
and go to the end of the previous one, press CtrlBack.

Important: the “First line indent” is always defined from the “be-
fore text” indent. That is, if we define the “before text” indent as  
1 cm and a first line indent of 0.5 cm, this first line will be found  
at (1 + 0.5) cm = 1.5 cm from the effective edge of the text area.  
On the other hand, if we define a “before the text” indent as 1 cm 
and a first line indent of –0.5 cm, the first line will be (1 − 0.5) cm 
= 0.5 cm from the effective edge of the text area.

I do not recommend the use of the “automatic” first-line indent.

A useful  option in this  menu is  “Don’t  add space between para-
graphs of the same style.” With this option it is possible to configure a 
space before and / or after a paragraph style that will  only be used 
when the other paragraph is of a different style, obtaining, for example, 
that the Text Body is separated from a Heading, but flow without inter-
ruption between paragraphs of the same style.

We already talked about the meaning of the single line spacing in 5.3. 
Of the other line spacing options,  Proportional refers to “proportional 
to single line spacing:” that is, proportional at 100 % is equal to single 
line spacing. In this option it is also possible to use values lower than 
100 % to obtain a more compact text1.

Writer’s default template uses, for the Text Body style, a propor-
tional line spacing of 115 %… In short,  I already said that you  
should not use the templates that come with Writer.

1 It is not that I recommend it. In fact I do not recommend it.
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The option At least refers to “at least this distance:” if you set lower 
values than the one corresponding to single line spacing, nothing will 
change.

The Leading option also refers to the single line spacing: the value 
that is configured there is added to the value of the single line spacing. 
That is, if the single spacing is 0.5 cm and this option is set to be 0.1 cm, 
a line spacing of 0.6 cm will be used.

The Fixed option gives a constant line spacing for all text, regardless 
of what is in that text. For example, if you have a larger character or an  
image anchored “as character,” the line spacing will not change and the 
character or image may be “cut off.” Here it is also possible to define 
smaller distances than the single line spacing.

Although Writer shows all the values in the unit defined for the en-
tire program in Tools ▶ Options ▶ LibreOffice Writer ▶ Gen-
eral  (for example, centimeters) it is possible to enter the desired  
value in the units that you want. For example, if we activate the  
Fixed option and in the box corresponding to the desired value for  
the line spacing we enter 15 pt, Writer understands without prob-
lems  what  it  has  received  and  will  automatically  change  it  to  
0.53 cm.

6.1.3 Alignment tab
The most characteristic elements of this menu are the possibility of in-
dividually selecting the alignment of the last line of the paragraph (to 
have, for example, a justified paragraph with a last centered line) and 
the “text-to-text alignment.”

Text-to-text alignment controls vertical alignment when you have 
fonts of different sizes in the same paragraph, as you can see in the fol-
lowing table

Base line A Top A Middle A Bottom A

Yeah, it’s weird. Better let it as “automatic.”
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6.1.4 Text Flow tab
In this tab it is possible to configure the hyphenation options (it is nec-
essary to have the hyphenation dictionary installed, as we discussed in 
3.3), associate page breaks to that paragraph style, so we can change the 
page style and even the page number (we will come back to this in 6.3 
and 7.2) and some other options.

The “extra” options for the text flow are (use them with caution!):

• Do not split paragraph: this means that when the paragraph 
reaches the bottom of the page, it passes to the next page in 
one block. It will only be available if the last two options are 
disabled.

• Keep with next paragraph: keep the paragraph on the same 
page as the next one. The styles Heading 1 to 10 usually have 
this option checked to avoid getting an “abandoned” heading 
at the end of the page.

• Orphan / Widow control: it avoids that when going to the 
next page only one line of a paragraph is left behind (or only 
one line goes to the next page). Attention, they can leave “gaps” 
at the end of the page!

6.1.5 Font tab
Also applicable to character styles,  it  can be used to define both the 
font (under “family”) and the “style” (italic, bold…), its size and the lan-
guage of the paragraph / selection (for character styles) to which it is 
applied. In the lower part you have a preview of the text with the cho-
sen options.

This is where you can apply all the tricks we saw in the Chapter 5!

6.1.6 Font Effects tab
Also  applicable  to  character  styles.  Several  “strikethroughts,”  under 
(and “over”) lining, color, small caps (simulated, better go back to the 
previous tab with a good OpenType font)… 
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6.1.7 Position tab
Also applicable to character styles. Controls the position and size of  
the sub- and superscripts (also simulated, go back two tabs) as well as 
the character spacing (better not to touch it) and the pair kerning (bet-
ter leave it active).

Ah! And the rotation of the text.
Keep in mind that the rotation is somewhat “strange,” so I recom-

mend you make a couple of tests before getting too excited about this 
feature, especially when applied to paragraph styles.

That is, it is not very useful in reality.

6.1.8 Highlighting tab
It gives us the chance to select a background color, such as we would 
have on a paper when passing a highlighter over a line of text.

6.1.9 Tabs tab
(Pun intended)  The famous  “tab”  key  Tab has  changed its  functions 
since its creation in the old mechanical typewriters: we currently use it 
to change windows (in combination with Alt), to jump from one form 
field to another, from a preselected button to another… and we also 
use it to generate annoying formatting problems.

In most WYSYWYG (What You See is What You Get) text processors, 
and in this Writer is no exception, this key has partly held the function 
of jumping between “imaginary columns” in the text, but with the ag-
gravating circumstance of being represented by a formatting character 
that  can be moved together with the text  itself  generating in many 
users great confusion.

If we go to  Tools ▶ Options ▶ LibreOffice Writer ▶ General , we 
have a configuration option called Tabs, by default fixed at 1.25 cm (I’m 
a metric person). Many people usually think that this means that if in 
an empty paragraph we press Tab several times the cursor will “jump” 
of 1.25 cm at a time, but what actually happens is that this configura-
tion divides the width of the text area into fixed columns 1.25 cm wide,  
so the Tab key will take the cursor to the column closest to the right of the  
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insertion point.
This difference is important to use the tabs correctly: try to insert a 

Tab in the middle of two words and then slowly add text in front of the 
first one… now it should be clear why the text behind the Tab “jumps” 
as it does.

Now, given its “mobility,” the Tab are a “dangerous” formatting re-
source:  the  distribution of  the  paragraph could change dramatically 
even with the addition of a single character.

If you want to use the Tab correctly it is necessary to know where 
they are placed and perfectly control their properties.

Fortunately, both tasks are simple to achieve: the first enabling the 
view of the Formatting Marks (the button with the symbol ¶ in the stan-
dard  toolbar),  the  second  setting  these  “imaginary  columns”  not  as 
something general of Writer but in the paragraph style. That is, in the 
“tab” of which we are just talking about here.

These columns are useful to quickly get particular alignments, such 
as the one found in the page headers in this book.

If you edit the paragraph style called Header in any document you 
will see that it has two tab stops defined, one at the center of the page 
and the other at the right of the page, the first one “centered” while the  
second aligned to the right.

Yes, these “imaginary columns” between which we can jump with 
the Tab key can have alignment properties: if the alignment is “left” the 
text after the tab starts at the position indicated by the tabulator itself, 
if the alignment is “centered” the text is, well, centered in that position 
whereas if the alignment is “right” the text  ends in the position indi-
cated by the tabulator.

Therefore, if in a paragraph to which the Header paragraph style has 
been applied, a text is written,  Tab is pressed, another text is written, 
Tab is pressed again and it ends with another bit of text we will have  
the following:

first text centered text right aligned text

I would like to emphasize the concept that tab stops should be used 
exclusively to achieve these alignment effects,  never to create indents 
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that as we have seen are perfectly controlled with the options of the 
Indent & Spacing tab.

In fact, the tab stops can be applied in combination with the inden-
tations to achieve effects such as the following:

Definition a paragraph style with “before text” indentation of 
3 cm, “first line” indentation of –3 cm and a tab 
stop, aligned to the left, fixed at 3 cm.

Example between the text “to be defined” and its “definition” 
we need to insert a Tab.

On the “text to be defined” I applied a character style that uses real 
small caps2.

The type of tabulator called “decimal” is used to align numbers with 
respect to the decimal point, achieving for example the following:

22.35
1235.8

1.4
We will talk about how to use tab stops within tables in Chapter 12.
As you can see in the menu, when creating a new tabulator we can 

also define a “fill character.”
I would like here to insist on a concept already indicated above: tab-

ulators can be useful,  but at the same time they are dangerous. If to 
achieve a certain paragraph format you need more than one tab per 
line perhaps you should think about using a table instead, since the for-
mat could quickly become uncontrollable.

6.1.10 Drop caps tab

etting a “drop cap” or “initial” as you can see in this para-
graph can be done in the “drop caps” tab: make the first let-
ter (or even the first word) of the paragraph occupy more 
than one line. Being a purely aesthetic issue, each one must 

decide whether they like it or not. To activate it,  the option  Display 
drop caps must be checked.

S
2 We already saw how this is done in the Chapter 5.

86 Paragraph styles, and also character



he drop cap will be visible only if the paragraph has more 
than one line, and this letter will have at most the number 
of lines in the paragraph. This means that if we configure 
the drop cap so that it takes 5 lines and the paragraph has 

only three, then we will have a drop cap letter of only 3 lines.
T

es, we can have a shorter paragraph, but we have to work a 
bit more.
   The simplest way to achieve what we have done here is to 
insert a Tab followed by a line break (ShiftEnter). And possi-

bly add some spaces to simulate the first line indentation of this second 
“paragraph.”

Y
et me emphasize it is possible to assign to the drop cap let-
ter a particular character style, which for example uses a 
“decorative” font to give a more fanciful aspect to the para-
graph. For the “drop cap” style used here I have chosen the 

Pali typeface with the OpenType salt option.

L
ven if all this seems very simple, unfortunately there are 
limitations: although it is possible to configure the hori-
zontal  distance  between that  letter  or  highlighted  word 
and the rest of the text, we can only do so to separate the 

text: it is not possible to assign negative values to this function.
E

 
 
urely, some of those limitations can be overcome with a 
little effort. For example, it might be of interest to us to en-

sure that the drop cap is “raised,” projecting one or more lines from the 
beginning of the paragraph. The only option we have to achieve this is  
to insert, after the initial letter, a space followed by a line break, as I 
have done here.

S
And yes, on the rest of the first word I applied a character style with 

True Small Caps. It is more elegant.
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6.1.11 Area, Transparency and Borders tabs
The use of these three tabs is immediate: assign either a background 
color (or a background image), make that background semitransparent 
and apply a border. The style used in this book for “notes” has a back -
ground, while the character style used for “paths” also includes an edge.

It is important to note two things when applying a border to a char-
acter style. The first one is that each line of the text selection to which 
we have applied the style will have the edges that we have configured. 
The second is that you can have problems with hyphenation, since the 
automatic hyphen will remain “out of the edge”

Bug 109018 - Character border conflict with hyphens

The only thing that we can do at the moment in this case is to re-
place the automatic hyphen with a manual one, inserted with Ctrl-. 

6.1.12 Condition tab
Conditional styles are a very powerful tool, but at the same time they 
are strange. Actually, in the years that I have been using Writer I have 
not yet found a practical use for them, so I will not go into much detail.  
Basically it is possible to define a unique style that behaves like other 
styles given a certain condition. An example would be to make the “text 
body” style behave as “table content” when it is inside a table or as an -
other style when it is within a frame or section.

It could be said that a conditional style is “a style to rule them all.” 
They may be useful in complex office document templates, but we will 
not discuss them here.

6.1.13 Outline & Numbering tab
We will talk about this tab in 7.2, Organize and number chapters at page 
108.

6.2 Character styles
Much of what we have said about paragraph styles applies directly to 
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those of character, so there is not much left to add… beyond a couple 
of details, of course, that there is always something to say.

Let’s see, applying a style is simple: double click on its name and the 
style gets applied to the point where the cursor is or to the text selec-
tion. As we already mentioned, we can also use the  Fill Format Mode 
tool  to  apply  character  styles  at  various  points  with  great  ease,  by 
“painting” the style on each portion of the text that we want to modify. 
But how do we do to remove a character style that we have applied? The 
action of “clean direct formatting” (CtrlM) logically will not help us 
here since we are talking about styles.

Simple: Applying a special character style called Default Style. This 
style can not be edited and its only function is to return control of the 
format to the paragraph style, so we only need to select the text with 
the character style that we want to remove to go to the style and for-
mat editor, select the “character styles” list and double-click on Default  
Style.

If we work a lot with character styles, maybe we should add it to a  
toolbar with the styles we use…

6.3 Page styles
This section will be a bit more complex than others, since by touching 
the page styles issue we will enter into many “related topics,” such as 
page numbering, numbering types, etc.

Well, as we discussed briefly before, page styles allow us to “group” 
pages according to the characteristics we want to give them. For exam-
ple, we can quickly define with these styles how the first page of each 
chapter  will  look,  or  the  following pages,  establish that  the  style  of 
“first page” follows that of “next page” and that the latter is followed by 
itself, etc.

One thing that unfortunately can not be done with page styles is to 
define “hierarchies:” the option Inherit from is grayed out and can not 
be used.

Bug 41316 - Page styles should support hierarchical parent-child  
relationships (like paragraph or character styles)

Styles and templates 89

https://bugs.documentfoundation.org/show_bug.cgi?id=41316


As can be seen in the report, this is a limitation of the file format 
used by LibO, so it will be difficult to resolve in a short time.

The way to number pages in Writer is  completely different from 
other programs. Possibly at the beginning it will seem that this form is 
little intuitive / erroneous / … (use your preferred adjective), but read 
what follows until the end as this only apparent greater difficulty leaves 
in your hands an extremely powerful tool.

6.3.1 The page number as a “field”
While the page number is a property of the page, in Writer the way to 
display that number is not.

The page numbers in Writer are shown through a “field” (we will 
talk more about the topic in the  Chapter 13):  Insert ▶ Field ▶ Page  
Number  or from the drop-down menu of the Insert field button found 
in the standard toolbar. In principle it is possible to place this field any-
where in the document, which may seem strange, but this is one of the 
bases of the flexibility of the system.

6.3.2 Headers and footers / Page styles
Obviously, the place where the page number is most useful is in the 
header / footer of the page.

As already mentioned above, page styles organize our pages in “cat-
egories,” each of which have its own characteristics, different from the 
other groups. We can, for example, define how the pages for the index 
are, or for the first page of each chapter, or for the pages that follow 
that first one, the appendices… whatever is necessary to provide struc-
ture to our document, and we can define / modify the characteristics of 
a group without disturbing the other groups.

There is no direct formatting for pages as it exists for paragraph or  
character3, only styles can be used. 

3 Technically speaking, it does not exist there either. We will come back to 
this in Apendix A.
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Let’s go to the styles and formatting editor and click on the fourth 
button: Page Styles. There are several predefined styles that can be mod-
ified at will ( right click ▶ Modify ), or you can simply create a new one 
( right click ▶ New ). In both situations, the headers / footers for that 
particular style can be activated or deactivated in the corresponding 
tabs (Header and Footer) of the dialog that is presented. There it is also 
possible  to  choose to  have  (or  not)  different  content  on left  /  right 
pages, which makes it possible to quickly build really complex docu-
ments with a reduced number of page styles.4 

I do not recommend the option to change the content of the “first 
page” (remove the mark to  Same content on first page) since it is only 
(marginally) useful for very simple documents: it is better to use a spe-
cial style for that first page.

An extremely important feature to insist on is that in the Organizer 
tab you can choose the “next style” to the style that is being defined / 
modified, so it is possible to achieve that Writer automatically applies a 
succession of different  styles:  for  example,  that the  first  page of the 
chapter with a number centered on the footer is followed by pages that 
show the number in the header and that this second style “follows it-
self.”

In the Page tab it is possible to define the size of the page, the mar-
gins, the orientation, the type of numbering (the option Page numbers: 
Arabic, Roman…), if the page will be equal for odd and even numbers 
or it should mirror the margins (the Page Layout option) to make room 
for binding…

It is also possible to activate, without opening the style settings, the  
headers / footers for any page style used in the document from the  
menu  Insert ▶ Header and footer ▶ Header (Footer)  where  
you can see a list of the page styles used in the document with a  
box  on  the  left  that  shows  a  mark  on  those  where  the  header  
(footer) is enabled.

Another way to activate headers / footers is directly on the page:  

4 In the appendixes I tell how many styles I have used for this book.
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clicking on the corresponding region activates a button that can be  
used to activate the header / footer. Once activated, this button be-
comes a menu with some options that do not need further explana-
tion. In fact, since 6.1 we can quickly add the page number from  
there.

In any case, I do not recommend these paths to new users, since we  
lose sight of what is really happening: the modification of the page  
style.  This  loss  of  perspective  can  lead  to  some  confusion  that  
should be avoided and, after all, it is not that you save so much  
work by going there…

Once the page style has been defined / modified to incorporate the 
necessary header / footer, it is possible to apply that style to any page 
in which the cursor is located by double clicking on the name of the 
style. It should be noted that if there is no “page break” that style will 
be applied to all pages of the same type both before and after the se-
lected page. Later we will see how to control this.

It  is  preferable  to  start  experimenting with styles  in new docu-
ments, until the user manages to get used to the new system. For  
this “experimentation” it is useful to remember that it is very sim-
ple to fill pages using the automatic text “Dummy Text” that comes  
preconfigured in Writer: we simply write dt and press F3 (we will  
return to this in the Chapter 10).

Something that usually confuses new users is that in the definition 
of the page style you can decide if that particular style has a header or 
footer,  but it is not possible to decide its content: it must be applied di-
rectly on the page.  It  would be nice if  the content of  the header or 
footer could also be edited from the dialog in which it was enabled, but 
currently it is not possible.

Once the style is applied, we can see its header / footer waiting for 
content. Clicking there, we can now add the information we think nec-
essary: for example, the Page Number field.

By default, the headers / footers use particular paragraph styles (ap-
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propriately called Header, Left / Right Header, etc.), which have two “tab 
stops” defined: one in the center of the text area with centered align-
ment and another at  the right of  it  with right  alignment.  These tab 
stops are useful to insert the content we want and align it in a very 
simple way. For example, we can insert the field of the page number on 
the left, press Tab (the cursor jumps to the middle of the line) and in-
sert the name of the author or a field that reflects the title of the cur-
rent chapter (we will return to this topic in the Chapter 13).

It is important to note that to indicate the content of the headers / 
footers of each particular style it is necessary to apply that style at least 
once and that if we use different content on odd and even pages we will 
need at least two consecutive pages. Once the content has been defined, 
it will remain that way even if all the pages assigned to that style are 
deleted: to modify it, the style must be applied again.

6.3.3 Apply page styles
There are different ways to apply a sequence of page styles. 

The first one is through the next style option in the definition of the 
style: a style is applied to the first page (double click on the name of the 
style) and the other styles follow automatically for the following pages. 

If you want to leave this sequence now (for example, when starting 
a new chapter), it is necessary to insert a page break. Page breaks can 
be applied manually with Insert ▶ More breaks ▶ Manual break ▶ Page  
break  and selecting  the  desired  page  style  from the  corresponding 
drop-down menu. 

It is important to note the  Change page number check box, which 
can be used to restart the page numbering at any time, for example, af-
ter the table of contents.

What this menu actually does is to modify the format of the para-
graph that immediately follows the page break, setting the break in  
the  Text  Flow tab:  that is,  the page breaks are  a property of 
paragraphs5. Did not we already say that Writer is a content-ori-

5 And tables. We will come back to this in 12.2.
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ented program?

In this way we can, for example, insert a “landscape” page between 
two “portrait” pages: we simply need to apply the page break with page 
style  change  twice,  one  before  and the  other  after  the  “anomalous” 
page.

Page breaks can also be automated by associating them with a cer-
tain paragraph style, as mentioned above. 

Suppose that it is necessary that each chapter starts on a new page 
and that the paragraph style “Heading 1” is used to identify chapter ti-
tles. Editing this paragraph style, in the Text Flow tab there is a section 
called Breaks: after selecting Insert we pick, for Type, “Page”, in Position, 
“Before,” With style of page, we take the one that we want and if it is op-
portune we change the page number (zero means “without changing 
the number”). This is exactly what I have done in this book to define 
the beginning of each chapter.

Clearly we can associate breaks not only before but also after the  
paragraph we are considering: everything depends on the format-
ting needs that we have.

6.3.4 Change the page number
Although indirectly addressed in the previous entry, this is a recurring 
question: how to make page 5 become page 1?

Basically, we must enter a page break with page style change and 
there change the number. For this there are basically two methods:

Go to Insert ▶ More Breaks ▶ Manual break ▶ Page break  and se-
lect a page style (it can be the same as the previous one!), without for-
getting to check Change page number and select the desired number.

If the page break has already been entered (for example, because a 
particular paragraph style automatically introduces a page break) we 
must go to the first paragraph of the page following the break,  right  
click ▶ Paragraph (or Format ▶ Paragraph) ▶ Text Flow tab  and in the 
Breaks section activate… well, I already explained it a few paragraphs 
above.
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Keep in mind what was mentioned before: that a paragraph style 
can introduce a page break before it automatically. This, added to the 
possibility of changing the page number means that it is possible to 
build  for  example  a  very  common  numbering  in  manuals,  namely 
“chapter number” – “page number,” where “page number” starts at 1 for 
each chapter: it is  sufficient to enter the corresponding fields in the 
header / footer to get the desired result.

6.3.5 Change the numbering type
Sometimes it is necessary to use Roman numerals, or even letters, to 
number some particular pages such as those in the content index. 

In principle there are two ways to do this, but only one gives the 
best results.

Right one Already hinted in the text above: when you edit the 
page style where you want the particular number-
ing,  on  the  Page tab  and  under  Layout  Settings 
choose the desired numbering type. 

This will be reflected in both, the table of contents 
and in the cross references that call the page num-
ber.

Bad one It is better not to use the following, but as it is usu-
ally “advised” in certain blogs and forums, I men-
tion it here so that no one can think of the damn idea  
of actually using it: double click on the page num-
ber field and in the  Format category of the menu 
that is presented, you can choose a type of number-
ing different from the one configured in the page 
style. 

Doing this is utterly wrong because this configura-
tion only “disguises”  the  number,  does  not  really 
change it, and therefore the index and other fields 
that refer to the page number will be displayed in-
correctly.
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6.3.6 Visibility of page breaks
LibO has quite elegantly solved the problem of visibility of the page 
breaks inherited from OOo. 

Basically, LibO shows a dotted line between both pages and by hov-
ering for a few seconds with the mouse pointer on top of that dotted 
line a button appears that gives us a menu with options to edit the page 
break.

However, this menu has a “conceptual problem” that should be con-
sidered by the user: as we have already mentioned, the page breaks are 
actually a property of the paragraph, not of the page itself, so that with 
this  menu the user  lose  sight  of  the  real  “responsible”  for  the  page 
break. 

In fact, it is equally simple to get to the edition of the page break by 
right clicking on the paragraph that follows.

But now that we know “the truth” the most important thing is that 
the page breaks are easily to find!

6.3.7 “Register-true”
When printing on both sides of a paper that is not of the highest qual -
ity (that is, on the paper used by the books we can buy in a bookstore),  
it could be that the lines of text on one side are visible on the other side 
as a diffuse shadow. 

This will be especially annoying if the lines do not match and those 
on one side of the page fall in the inter-lines on the text on the other 
side.

To avoid these “ghosts,” the lines of a left page would have to be per-
fectly superimposed with those of the right page before it,  in such a 
way that what is written on one side of the page is not “seen” in the 
white spaces on the other side.

Achieving this in Writer is possible… with certain limitations. 
The method we will introduce involves modifying both, page and 

paragraph styles.
Editing the page style used, on the  Page tab we find, below on the 

right, a checkbox called Register-true: if activated, we can select a para-
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graph style from the “Reference Style” menu.
But we are not ready yet: we have to make sure that the paragraph 

style we use in the text has the “Register-true” thing enabled in the In-
dents & Spacing tab.

What does all this do, you may ask? 
Well, using the metric of the “reference style” selected, Writer cre-

ates a “grid” on the page and “accommodates” (i.e., force) all lines of text 
unto to that grid: if the two facing pages use the same grid (the one 
provided by the reference paragraph style), the lines of both  sides will 
be perfectly aligned, avoiding the problematic “phantoms.”

In  a  certain  sense,  activating  the  “Register-true”  leads  Writer  to 
completely ignore the line spacing configured in the paragraph style 
that we use for the text body, forcing all the text in the page to use the 
line spacing of the “reference style” instead. By doing this the text on all 
the pages will be perfectly aligned and all the lines will have exactly the 
same separation.

Now, what happens if we have an object in a paragraph, for exam-
ple a mathematical expression? 

And if  instead of  indentation we use spaces before (or  after)  the 
paragraph to separate them?

Well, in those cases we could have some “inconveniences.”
If in a line of a paragraph we add, for example, a fraction written 

with Math, that object will “push” the lines to separate them slightly, 
but when doing this the lines must “jump” to the  next position of the 
grid, giving an extremely unpleasant effect.

Something similar will happen in the other case mentioned: when 
we use spaces instead of indentations to separate the paragraphs. 

If the space set above or bellow the paragraph is half line, because 
we are adjusting to a fixed grid the line after that space will have to 
“jump” to the next available position in the grid, giving an entire space, 
not a half line.

However, these problems can be mitigated with a little extra work, 
either in general cases (such as a paragraph style to which we want to 
give more “freedom”) as for particular cases of an isolated paragraph: 
again in the Indents & Spacing tab we can disable the  Register-true for 
that style or for that particular paragraph.
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It is important to remember that if we manually modify the “affilia-
tion” of a paragraph with the  Register-true option, it is convenient to 
press  CtrlM (Clear  direct  formatting)  when creating the following 
paragraph to return in this way to the format defined by the paragraph 
style.

Another important thing to keep in mind is that these considera-
tions are important only for printed books, and only when the paper is 
quality “soft  cover book:” if  we only want to generate an electronic 
book in PDF format or we are printing on 80 grams paper, the Regis-
ter-true could be more of a nuisance than a real help.

6.4 Other styles
Writer also offers other styles: lists, frames, tables. But these styles have 
their… peculiarities? 

Anyway, these styles deserve to be treated independently so we will 
devote a good number of pages to them, but later: below, just some 
generalities of these special styles.

Frames are objects that “float” on the page and can accept different 
types of content. They can be created in Insert ▶ Frame ▶ Frame  and 
can be used for many things. 

For example, we could use frames to insert marginal notes or “float-
ing boxes” with extra information. Writer also automatically uses many 
types of frames: each inserted image, each object of the equation editor, 
each inserted “OLE object,” each time we introduce a caption to an im-
age, in all those situations Writer is actually inserting a frame that will  
have its own characteristics.

The characteristics of the frames can be edited in general by modi-
fying the  corresponding frame style,  or  in  particular  with  a  simple 
right click on it.

Now, one thing to keep in mind is that frame styles apply to the 
frame itself,  not  to  its  content.  You can apply different  paragraph or 
character styles (or both) to the text entered in a frame. For those who 
know something about , frames are remotely related to the con-
cept of “mini pages.”
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The frames themselves, but especially the styles that control them, 
have some “idiosyncrasies” that we will deal with in 11.2.

List styles are particular and misused can even give us some prob-
lems. They provide an extremely flexible and powerful tool to create 
numbered and bulleted lists, but it is precisely that power and flexibil-
ity that forces us to be careful and use these styles correctly.

The main problem is that these styles define their own indentation 
to place the number / bullet, so if they are applied to a paragraph that 
already has an indentation, there could be conflicts: it is therefore ad-
visable to apply them only on paragraphs without an indentation.

While we will return to this in  7.1,  it  is convenient to comment 
now that if, with the cursor in a paragraph, we double click on a list 
style we will see that it is applied to that paragraph, which will show 
the numbering or the bullet scheme configured in style. 

The way in which the list style has been applied can be seen if we 
edit the properties of the paragraph ( right click ▶ Paragraph ) to go to 
the  Outline & Numbering tab.  There it  is  possible  to see that under 
Numbering style the list style applied is now selected: to remove it, it is  
enough to select “None” from the drop-down list or if we only want to 
change that style for another one,  we can also choose the new style  
there.

This is of course also valid for paragraph styles: by editing a style, in 
the Outline & Numbering tab we can select the desired list style.

An important point: we should avoid as much as possible the use o 
numbered styles to number chapters, since this can bring consistency 
problems:  Writer  has  other  mechanisms  for  numbering  chapters  of 
which we will deal with in 7.2.

And the table styles… uh, well… Great concept, but… 
In short, we will return to the complex and important topic of the 

tables in 12.2.

6.5 Recycling styles: templates
The first question that arises after spending a while defining, establish-
ing heirs and organizing styles is how can I take advantage of these styles  
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for a new document?
Simple:  File ▶ Templates ▶ Save as Template  saves a copy of the 

file as a “template,” which we can use later to create new documents by 
selecting File ▶ New ▶ Templates  and double-clicking on the template 
of interest.

It must be taken into account that when creating a template from  
an existing file, the content of the document is saved too, not just  
the styles, so we must make sure to erase what we do not need be-
fore saving it.

We can even go a step further and make our favorite template also 
our default template, the one that which will open automatically when 
we launch Writer or when we create a new document. We can do this 
directly when creating the template by simply marking the appropriate 
option in the dialog that  appears,  or  later  from  File  ▶ Template ▶  
Manage Templates : with a right click on the template of interest we 
can set it as default.

If  we  then decide  to  change  something in  one  of  our  templates 
(modify or even add styles), we can go back to that last menu that in the 
right click we also have the possibility to Edit. Once the modifications 
are finished, we just have to save the file as if it were a normal docu-
ment, and everything will be ready.

When we open a document based on a modified template, Writer  
will kindly ask us if we want to update the styles. 

If we say no, the link between the document and the template 
will be definitively broken. 

There is currently no “official” way to assign a template to an ex-
isting document, but an extension called  Template Changer can  
be used for this. 

Of course, do not expect miracles… 

As you can see when using these dialogues, it is possible to choose a 
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“category” to classify the template that we have created. The list of pre-
defined categories is extensive, but if none is useful for us, we can cre-
ate a new one, move templates from one category to another, etc., by 
using the Manage templates tool.

6.6 The “styles” menu
This menu facilitates the application of the most “popular” styles, giv-
ing us also access to several options of great interest.

One option present in that menu and of which we have not yet spo-
ken is that of Load Styles. 

This tool can be used to take a style defined in another document or  
template and load it into the current document. We can filter the styles 
of  that  other  document  by  type  (text,  frame,  page  or  numbering), 
choose if we want to overwrite styles of the same name in our docu-
ment, and so on.

6.7 The “styles” toolbar
With View ▶ Toolbar ▶ Format (styles)  we can activate a toolbar with 
several options, such as a menu for paragraph styles and several but-
tons to apply different styles, types of numbering, and so on.

Unfortunately, this bar does not yet show a feature that would be 
fundamental in a bar dedicated to styles: a drop-down menu with char-
acter styles

Bug 88512 -  TOOLBAR/SIDEBAR: Character style drop down  
control uno command 

Until this report is resolved, the style toolbar does not really con-
tribute anything that was not already present in other toolbars or that 
could not be added to existing (or new) bars. In fact, paradoxically (or  
not), some of the controls in that bar apply direct formatting. So… any-
way.

As I mentioned earlier,  for this document I decided to create my 
own toolbar with the paragraph and character styles that I use enough 
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to always have at hand, but not so much that I need a keyboard short -
cut associated with them.
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Chapter 7

Lists and numbering

In this chapter we will deal with some issues that cause confusion in 
new users… and not so new ones. 

I mean, of course, the differences and similarities between number-
ing lists and numbering chapters, what are the lists styles and which is 
the best way to use them, and how to overcome some limitations of the 
system.

Put on your seat-belt, there we go.

7.1 Numbered and bulleted lists
There are three ways to generate numbered lists or bullets: by activat-
ing them with the corresponding button in the Properties panel of the 
sidebar, using the buttons on the Formatting toolbar or by associating a 
list style to a given paragraph, either directly or modifying the style in 
the Outline & Numbering tab. 

The first two methods have the advantage of being fast: in fact, from 
the sidebar you have a drop-down menu where to choose between sev-
eral predefined types of numbering or bullets. 

The third way provides a method,  thanks to the use of  styles,  to 
have under full control the appearance of all the numbered and bul-
leted lists of our document so it becomes essential when, for some rea-
son, none of the predefined lists pleases us.

On how to apply the first two methods there is not much to say: 
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with the cursor on the paragraph or after selecting a group of para-
graphs, click on the desired option.

To apply the third method it is enough to select, either for the para-
graph style or for the direct format of the paragraph we are modifying, 
in the Outline & Numbering tab, a list style conveniently formatted.

It is important to note that lists can have “levels,” as in the following 
example:

1. First level

1. First sub-level

2. Another first level

1. Sub-level

1. Subsublevel

2. Second subsublevel

In all cases, when the cursor is on a list we find the contextual tool-
bar of Bullets and Numbering with the following series of buttons (from 
left to right):

1. Demote One Level.

2. Promote One Level. 

3. Demote One Level With Subpoints. 

4. Promote One Level With Subpoints. 

5. Move Down (the whole line). 

6. Move Up (the whole line). 

7. Move Down With Subpoints (the whole line, with sublevels). 

8. Move Up With Subpoints (the whole line, with sublevels). 

9. Insert Unnumbered Entry. 

10. Restart Numbering. 
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11. Bullets and Numbering (list properties & settings).

From this toolbar it is possible to control several general aspects of 
the numbered or bulleted lists.

To change the level of a line you can use the buttons on the toolbar  
or, at the beginning of the line, press Tab or ShiftTab to raise or lower 
the level, respectively.

When we enter the menu to customize the list, either because we 
are editing a list style or because we clicked on the Bullets and Number-
ing button to manually modify a given list, we have several tabs, some 
of which only offer different predefined list options. Next we will only 
discuss the most important tabs of this menu, that the others are easy 
to understand.

7.1.1 Customize
This tab is very similar to the one we will see when numbering chap-
ters. 

Basically what we have here is, on the left, a list of the ten levels that 
a list can have. For each level it is possible to select the type of number-
ing, if that numbering should “accumulate” the previous levels or not (a 
second level numbering could be “1.1”), if we must have a “separator” 
before or after (a point, a word, what is needed), select a character style 
to apply on the numbering and separators… everything is clear.

The option Consecutive numbering under All levels is something I re-
ally do not see a point in… but you can play with it if you wish.

7.1.2 List alignment
When we modify a numbered or bulleted list or when we edit a list 
style, in the  Position tab we find again the list of ten levels on the left 
and a series of options to apply for each of those levels on the right.

But what does each entry field and each drop-down menu mean 
there?

For each “level” we can configure the position and alignment of the  
numbers and the behavior of the left margin of the paragraph.
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9. Lorem ipsum dolor  sit  amet,
consectetur adipiscing elit.

10. Vestibulum consequat mi quis
pretium  semper.  Proin
luctus orci ac neque vene-
natis, quis commodo dolor
posuere.

9. Lorem ipsum dolor  sit  amet,
consectetur adipiscing elit.

10. Vestibulum consequat mi quis
pretium  semper.  Proin
luctus orci ac neque vene-
natis, quis commodo dolor
posuere.

9. Lorem ipsum dolor  sit  amet,
consectetur adipiscing elit.

10. Vestibulum consequat mi quis
pretium  semper.  Proin
luctus orci ac neque vene-
natis, quis commodo dolor
posuere.

(1)  (2)   (3)

Figure  7.1:  Three lists, and where the numbering and mar-
gins are placed



In the  Figure 7.1 we see three lists configured to start  at  9,  thus 
showing more clearly the alignment options that we describe.

Aligned at (1) indicates where the numbering goes, but since the 
numbers clearly have a width it is also necessary to indicate where in 
the number we are measuring their position and for this we have the 
Numbering alignment menu: with  Left (default option) we indicate 
that the number (and any separator that surround it) must start at the 
indicated position (that is, the reference position is taken to the left of 
the number), with Right we indicate that the number ends in that posi-
tion (the numbers go before the marker, which, clearly, is on the right) 
while with Centered we say that the number must be, in short, centered.

Numbering followed by (2) indicates how the numbering should 
be separated from the text (if “tab stop” is selected, it is possible to indi-
cate where this tab stop ends with the  Tab stop at option) while  In-
dent at (3) indicates the left indentation of the paragraph as a whole 
(except for the first line, of course, that is controlled by  Numbering 
followed by).

As I mentioned above, I have configured the three lists of the exam-
ple to start at 9. The three have the separator between number and text 
as a tab stop and a different indentation to this tab to show the effect of 
all the parameters.

The numbering of the first list is aligned “to the left,” the second is 
“centered” while the third is “to the right.”

7.1.3 Deactivate a list
If we have applied a number or bullet directly to a group of paragraphs, 
either using the tools or applying a style, applying “clean direct format-
ting” will not eliminate the list.

To remove the created list  we have two possibilities. On the one 
hand we can click on the corresponding button on the formatting tool-
bar or on the properties panel of the sidebar:  Toggle numbered list (or 
press F12) or Toggle bulleted list (or ShiftF12). The other possibility is to 
right click on the paragraph ▶ Paragraph ▶ Outline & Numbering tab  
to select None from the Numbering style drop-down list.
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7.1.4 A problem to keep in mind
If the paragraph on which we apply the numbered list / bullet has a 
“space after text” configured, it will be overwritten when the list is ap-
plied

Bug 83532 - EDITING: Right (after) indent of paragraph does not  
work in lists 

There is no definitive solution at the moment: if you want to re-
cover the right indentation you have to manually apply it again.

7.2 Organize and number chapters
Before starting, it is important to clarify that this section is not only 
about  numbering but mainly about  structure: by leaving the option of 
numbering in “none” the chapters will not be numbered, but they will  
still be “organized.”

What follows provides an automatic index, cross-reference… and, 
certainly, a numbering scheme, but that is only part of the story.

Hands on, then.

7.2.1 Giving a “level” to the styles
Used to other programs, many new users of Writer use numbered 

lists to number chapters, which leads to innumerable problems of con-
sistency in the format.1

The method used by Writer to number chapters may at first seem 
strange and in fact is far from perfect, but it is so simple that it is very  
easy to get used to it.

Everything (or almost everything, see below) we need is in the menu 
Tools ▶ Chapter Numbering . In the  Numbering tab we have a list of 
ten “levels” that form the structure of our document. By selecting each 
of  these  levels  we  can assign a  paragraph style,  a  numbering and a 
character style for that numbering. For the lower levels (from 2 on-
ward) we can choose how many levels to show (the option called Show 

1 Many of which are also present in those other programs.
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sublevels), obtaining for example a numbering like the following:
1
1.1
1.2
1.2.1
2
2.1
2.2
…

The dots or other characters used to separate the numbers can be 
defined with Separator, Before / After.

The styles assigned to each level in this dialog will be automatically 
used to generate the table of contents: Insert ▶ Table of Contents and  
Index ▶ Table of Contents, Index or Bibliography  (Chapter 9).

By default, levels 1 to 10 are associated with paragraph styles from  
Heading 1 to Heading 10, respectively. It is convenient, instead of  
defining new styles to use there, to simply edit the predefined styles  
to give them the desired format.

An important note: in the  Position tab of this dialog box we can 
define how the separation between the number and the text of the title  
will be.  The way to configure this numbering is identical to the one 
used for the numbered / bulleted lists mentioned above, except for a 
great detail: since version 6.1, Writer offers us the possibility of using a 
line break (New Line) as separator, with which results incredibly easily 
to create headings in two lines2 where the number, and its eventual la-
bel, is on the first line and the text of the title goes to a second. This line 
break will be happily ignored by the index.

It  is  important to note that we can have an arbitrary number of 
paragraph styles for each level, which is important to build richer and 
more complex schemes. A possible use is the definition of “appendices” 
that copy the structure of the chapters, maintaining the same scheme 
of levels, but with an independent numbering.

2 Like the ones in this book.
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However, these “extra styles” for each level are not configured in 
Tools ▶ Chapter Numbering , but directly from the definition of the 
relevant paragraph style in the tab called Outline & Numbering: under 
Outline Level we can choose the desired level.

However, we must bear in mind that when configuring the levels in 
this way it is not possible to define a numbering system as is done with 
the “base” styles of each level. To number these paragraphs you must 
select, on the same tab where the “level” has been defined, a numbering 
style… exactly what we said at the beginning that it was convenient to 
avoid.

Yes, life is cruel.

7.2.2 “Continuous” numbering
Writer  does  not  provides  a  tool  to  directly  perform  a  numbering 
scheme like the following:

1
1.1
1.2
2
2.3
…
That is, a scheme in which changing the value of a “level” does not 

reset the numbering of the next level. Fortunately, it is very simple to 
“simulate”  such a  numbering scheme.  In fact,  we have at  least  three 
ways to achieve this.

First method: we number one of the paragraph styles (for exam-
ple, the “Part”) with Tools ▶ Chapter Numbering  while the other styles 
(for  example,  “Chapter”)  is  numbered by selecting a list  style  in the 
Outline & numbering tab of the style.

Important:  Numbering with  Tools ▶ Chapter Numbering  is  
incompatible with the use of numbered lists: as you can see, when  
choosing one for a particular paragraph style, the option to use the  
other is automatically disabled.
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Second method: What I have done in this book is slightly different 
from the previous method. Level 1 is left unnumbered while from level 
2 onward they are all numbered, which gives the continuous number-
ing for the chapters and sections, but leaves the “parts” unnumbered. 

Third method: in Tools ▶ Chapter Numbering  we leave the “level 
1”  empty,  selecting styles  and numbering for  level  2  and successive, 
while “level 1” is configured directly in the paragraph style, in the out-
line & numbering tab.

7.2.3 A problem when using list styles to number 
chapters or appendices
We have said several times that, if possible, it is convenient to avoid us-
ing list styles to number chapters. The problem is that it is not always  
possible to avoid them.

Examples we have already given: the numbering of appendices or 
achieving a “continuous” numbering.

Now, suppose we want to use numbered lists not only for the ap-
pendices  but  also for  the  “sub-appendixes.”  We then have a style  of 
paragraph called “Appendix”  and another one called “Sub-appendix,” 
the first one with a “level 1” and the second one with “level 2,” both as-
signed in the Outline & Numbering tab of the corresponding style. We 
then configure a list style so that it has the numbering that we want in 
both the first and second levels and, again in the Outline & Numbering 
tab of the Appendix and Sub-appendix styles we assign our numbering 
style… all to see that the numbering that applies in both is always the 
first level of the list style.

No problem: with the first button of the bullets and numbering tool-
bar (Demote One Level) we correct the numbering level of the Sub-ap-
pendix.

I know, I know, it is not ideal and you must remember to do that  
each and every time… but it is not that complicated either.
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7.3 “In-line” headings
In technical documents there may be a type of format that “officially” is  
not possible in Writer: in-line (also called “run-in”) headings.

It would be something like this:

7.3.1 Title of the third level: Text in the normal paragraph 
and blablabla.

As we have seen, to have a heading we must apply a particular para-
graph style, but in Writer the paragraphs are defined by the action of 
the Enter key: it is not possible to have two “paragraphs in the same pa-
ragraph.” Or,  seen in another way,  we can not apply two paragraph 
styles without having an Enter in between

Bug  48459 -  FORMATTING -  proposal  for  in-line  headings,  
(run-in, inset headings) 

A “solution” could be to insert a frame (11.2) anchored as a charac-
ter at the beginning of the line and within the frame to enter the head-
ing… except for the fact that it  does not work: the numbering fails  
when we have a heading within a frame

Bug 86297 - Wrong Field reference when heading is in a frame 

A possible trick would be the following: a “number range” variable 
(13.5) is created with a “level” that takes into account chapters and sec-
tions, so it has the correct numbering. Where we want the first “in-
line” heading we insert this variable and a generic text, we select every-
thing and apply appropriate character styles to highlight the “heading.” 
With the text still selected there are two things to do. The first one is to 
go to Insert ▶ Table of Contents and Index ▶ Index Entry  to include 
the selected text as part of the index. The second thing to do, with the  
text still selected, is to create an AutoText to make it easier for us to in-
sert this “trick” as many times as necessary: we will talk about this last 
point in 10.2.

All  ready.  The  numbering  and  cross-references  (13.2)  work  per-

112 “In-line” headings

https://bugs.documentfoundation.org/show_bug.cgi?id=86297
https://bugs.documentfoundation.org/show_bug.cgi?id=48459


fectly: we simply to to the chosen variable and select “number.”
What does not work, clearly, is to insert the text of the reference as 

it copies the whole paragraph. 
But there is something else that does not work, which is more seri-

ous if we want to generate a PDF with “dynamic” links: the “index en-
tries” do not give links in the index:

Bug 65463 - Writer: Index entry in ToC should be clickable

If we want to go one step further we can still use the idea of the  
frame anchored as a character, we simply put the variable and the text 
of  the  paragraph inside  it.  This  would  give  us  more  work  when it 
comes to aligning the text, but it would allow us to use a paragraph 
style within the frame, which in turn could be added to the index di-
rectly,  and cross-references  to  the  title  text  could  be  done  without 
problems.

Finally, a small introduction to the only possibility to simulate in-
line headings that (almost) always works.

Suppose we want our “in-line heading” to be level 3. We make sure 
that “Heading 3” has level 3 in Tools ▶ Chapter Numbering , but when 
setting the style  we give  to it  the smallest  possible  font size  (6 pts), 
without  space  before  or  after  the  paragraph  and  use  white  as  font 
color, to make that paragraph invisible in the document. Finally, in the 
paragraph  following  that  “ghost  heading”  we  have  to  insert  some 
“chapter” fields to simulate the in-line heading… but,  well,  that part 
will be understood only when we get to the Chapter 13.

7.4 The “content” of the headings
We will return to this when talking about fields (Chapter 13), but we 
must bear in mind that if we want to make references to the headings 
(cross-references, get the chapter name in the header or footer, use a 
table of contents) we may have some limitations to the type of content 
that we can use in those headings. 

The fields do not respect the direct format nor the use of character  
styles, so if we have an italicized text or apply sub- or superscripts in a 
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portion of a heading, this format will not be transferred to the fields 
used for the references.

The table of contents will take some, not all, of these additional for-
mats, but we will have to take care to manually update the index before 
printing.

Something that is not transferred to the fields or the index is the use 
of objects: if we insert a Math object or a frame in a heading, it will not  
be transferred to the index.

You should also avoid leaving blank spaces at the end of a heading,  
since these will be taken by the fields and the index, leaving unpleasant  
gaps at the end of the references.

The only one of these problems that can be solved in a more or less 
dignified way is the use of sub- and superscripts: we introduce them as 
special characters instead of using formatting.

In short, better to use simple headings and leave the complication 
for the body of the text.
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Chapter 8

Footnotes and Endnotes

Either from the standard toolbar or from Insert ▶ Footnote and End-
note ▶ what we need  we can use this classic tool to add anecdotal in-
formation and thus distract the reader.1 

So far everything seems simple,  but how do we change the font 
used by the notes, or the type of numbering, or the format of the “an-
chors” of the notes in the text? How do we convert a footnote into an 
endnote (or vice versa)?

Fortunately, this is also very simple: we will see how to do it bellow.

8.1 Notes with style
This being a book about Writer, surely the word style(s) should be the 
most repeated throughout the text.

The footnotes / endnotes could not be alien to its use.
Tools ▶ Footnotes and Endnotes : here we can find almost all the 

necessary information.
This menu allows to change the type of numbering and the styles 

applied to the different elements of the notes.
For example, footnotes use a paragraph style called, appropriately, 

“Footnote,” while the “anchor” (the number, or symbol, that appears in 
the text and which calls the note) uses a character style called “Foot-

1 Hi!
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note Anchor.”
The character style “Footnote Characters” is applied to the number 

(or symbol) that precedes the note.
This  means  that  to  modify  the  characteristics  of  the  notes  it  is 

enough to edit the corresponding styles.
An idiosyncrasy: in  Before and  After we can define characters that 

surround the number…  that is in the footnote area:  there is no auto-
matic  way  for  the  reference  in  the  text  to  the  footnote  to  be  sur-
rounded by some kind of brackets.

For the footnotes we have in the lower part of the menu the possi-
bility of inserting a character that will be shown in the case the note 
extends to the next page. For example, inserting an arrow and a space 
there, in the document we will  see these characters followed by the 
number of the page in which the note continues.

An important detail: the line separating the footnote from the main 
body of the text is set in the corresponding page style (Footnote tab),  
not in the paragraph or character styles used by the notes themselves.

If instead of inserting the note in a normal way we go to Insert ▶  
Footnote and Endnote ▶ Footnote or Endnote , we can choose  
to insert a note that “skips” the numerical sequence of the other  
notes: under numbering, by selecting Character we can choose a  
symbol.

8.2 Transform types of notes
To change a footnote in a endnote (or vice versa) it is enough to do a 
right click on the anchor of the note ▶ Footnotes or Endnotes .

In this menu we only need to change the  Type to pass from foot-
notes to endnotes (or vice versa) in an instantaneous way: it is not nec-
essary to press OK… in fact, it could be useful not to do so, otherwise 
the menu would be closed forcing us to repeat the whole process for 
another note.

The arrows on the bottom left can be used to navigate between the 
notes so you can change them one by one without leaving the menu.
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8.3 Numbering by chapter
In the  Counting option found in  Tools ▶ Footnotes and Endnotes ▶  
Footnotes  we can choose to number the footnotes in correlative form 
for the whole document, number them by page or by chapter.

This last option (numbering per chapter) is based on the configura-
tion of the levels of the document, but it has a great limitation: it con-
siders as “chapter” exclusively paragraph styles with level 1, so if our 
chapters use for example a level 2 the option of counting by chapters 
will work badly.

Bug 94218 - footnote numbering per chapter: define outline level  
that resets numbering 

Bug 112301 - Set outline level for chapters 

In  Chapter 11 we will see a way to overcome this limitation with 
the use of  sections. After all, in this book the chapters are in “level 2” 
and I have numbered the footnotes “by chapter.”

The endnotes work mostly in the same way as the footnotes, except 
for the fact that, by default, they are collected on a special page at the  
end of the document.

On this special page the Endnote page style is applied, so if we want 
to modify its aspect we only have to edit the style associated with it.  
However, this way of presenting the endnotes brings with it some for-
matting problems since, for example, it is not possible with this config-
uration to add content after the endnotes: how do we then group the 
notes at the end by chapter instead of having them all at the end of the 
book? The answer to this problem is also found in the Chapter 11. 

Sections are something serious.

When exporting the document to PDF the anchor links of the end-
notes are lost:

Bug 38187 - BUG : When exporting .odt to .pdf: there is no hyper-
link between main text and endnote, missing both ways 
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8.4 “Tips” related to the footnotes
Having  reserved  the  most  important  trick  about  the  footnotes  for 
Chapter 11 (number the footnotes “by chapter” even when our chap-
ters do not belong to a level 1), we will see here some “dirty tricks” to 
solve minor issues.

8.4.1 Align the numbering, 1: tab stops
The numbering of the footnotes is aligned “to the left” and nothing of  
what we saw when talking about the numbered lists will help us to 
align the numbers “to the right.” After all, the footnotes are  not num-
bered lists.

As we already mentioned, in  Tools ▶ Footnotes and Endnotes ▶  
Footnotes tab  we can add “separators” that surround the number in 
the footnote area. The trick here is that we can also write formatting 
instructions. In fact, writing  \t for both, “before” and “after” separa-
tors, we will indicate to Writer that it must put a Tab before and after 
the number, so if we configure the paragraph style used for the foot-
notes so that it has a first tab stop aligned to the right and a second tab  
stop aligned to the left, this first tabulator will give us the correct align-
ment for the numbers while the second will tell where the text should 
start.

We have already discussed the tabulators in the section 6.1.9.
Where does this  \t come from to represent a  Tab? It is a “regular 

expression:” we will talk about them in the Chapter 18.

8.4.2 Align the numbering, 2: Graphite fonts
Yes, I know I said that they are not so important for the end user, and I  
still  believe  so:  we  only  have  two fonts  capable  of  performing  this 
“trick” so they will not be useful for all our documents.

If we create a document with a “Times” like font, such as the mag-
nificent  Libertinus Serif,  we can use the Linux Libertine G2 font  to 
make some “typographical juggling.”

2 http://www.numbertext.org/linux/ 
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I do not recommend the use of Linux Libertine G as the main font 
of the document because it contains several errors and its development 
has stalled, but it offers some very interesting functions that can help 
us overcome several LibO limitations.

If as a font name for the character style Footnote Characters we use

Linux Libertine G:algn=3

the numbers will be aligned to the right of a “box” of width 3 em,3 
giving the desired effect:

9 �
9 �0

8.4.3 Footnote anchors in round brackets
Another “trick” with the Linux Libertine G font (also works with Linux 
Biolinum  G):  to  put  the  anchors  of  the  footnotes  automatically  in 
round brackets, showing as 1, 2, 3… it is enough to use the “circ” op-
tion in the character style Footnote Anchor:

Linux Libertine G:circ=2

it only works up to 20, though.
If we want the number in a circle instead of round brackets, the pa-

rameter would be circ=1. It also goes up to 20.
There are also OpenType fonts that offer numbers in circles, usually 

in the tags  nalt (Alternate Annotation Forms) and  ornm (Ornaments) 
such as Pali, but it is not very common.

8.4.4 Symbols instead of numbers
We continue with this strange Graphite font. This is perhaps the most 
useful of the tricks we can do with this font: if we have few footnotes 
and we want symbols instead of numbers to indicate them, it is enough 
to use

3 1 em is a distance equivalent to the point size of the font used. For exam -
ple, if the text is set to 11 pts, 1 em = 11 pts.
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Linux Libertine G:foot=1

as a font name in the character styles called  Footnote Anchor and 
Footnote Characters, that in this way we will automatically pass from 1, 
2, 3, 4… to 1, 2, 3, 4…

Of course, if you use this option remember to number the footnotes 
per page that otherwise the situation will quickly become chaotic.
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Chapter 9

Indexes

One word, so many meanings. And so many headaches when we want 
to get away from the predefined values.

Yes, this chapter is about indexes. 
We  will  discuss  here  the  general  index,  its  strengths  and  weak-

nesses, giving some tricks to overcome many of its problems. We will 
talk briefly about the other types of indexes and how to “rescue” a cus-
tom  index.  The  chapter  will  close  with  a  discussion  on  the  biblio-
graphic index offered by LibO, which will force us to take a small devi-
ation to strange lands.

9.1 Initial precaution
It is important to note that if we insert an index in the first line of a 
document, or in the first line of a section (yes, yes, they are coming: 
11.1), or just after a page break we can not move it or insert text before it. 
It is convenient to leave at least one blank line before any index.

If the index has been already included in the document, we have 
two options left, either delete it, insert some spaces and recreate it “be-
low” or perform the following procedure::

1. Right  click  on the  index ▶ Edit  Index ▶  disable  Protected  
against manual changes ▶ OK
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2. With the cursor at the beginning of the index, press  AltEnter 
twice: a blank line will be created before the index

3. It is now possible to re-enable the option removed in point 1: 
there will be an empty paragraph before the index.

Another important thing to keep in mind is that the indexes are not  
automatically updated. A right click on the index give us the chance to 
update it “by hand.” That and the menu Tools ▶ Update ▶ Indexes and  
Tables .

9.2 Insert an index
When we begin to insert an index ( Insert ▶ Table of Contents and In-
dex ▶ Table of  Contents,  Index or Bibliography ),  we are  presented 
with a dialog box where, on the right, we have an outline of how the 
index will look with the things we select on the left.

9.2.1 The “type” tab
In this first tab we can name the index, select its type, 1 allow or not the 
possibility to manually  modify  its  content and to which part of  the 
document this index refers:  the whole document or just the current 
chapter.

Writer considers as “chapter” a level 1 heading, it is not possible to 
tell it to use another level: if the structure of our document forces the 
“chapters” into a level 2 and we need partial indexes for each chapter, 
then we will have problems:

Bug 94218 - footnote numbering per chapter: define outline level  
that resets numbering 

Bug 112301 - Set outline level for chapters 

The only “solution” for this is to change the structure of the docu-

1 Only when it is created. It is not possible to change the type of an already 
inserted index.
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ment so that the chapters are at level 1.
The last part of this first tab tells the index where to get informa-

tion:

Outline It refers to the levels set in Tools ▶ Chapter Num-
bering  or in the  Outline & Numbering tab within 
the paragraph style definition.

As we have already mentioned, it is possible to as-
sign  an  arbitrary  number  of  paragraph  styles  to 
each  level  by  simply  editing  the  corresponding 
paragraph  style  in  the  Outline  & Numbering tab 
and choosing the level in the Outline Level. The in-
dex will also incorporate these paragraph styles.

Additional styles It allows the inclusion in the index of para-
graph styles that do not have an assigned level. 

Selecting this option and opening the correspond-
ing dialog box (with the  Assign Styles button),  we 
find  a  dialog  to  select  a  paragraph  style  among 
those  used  in  the  document  and  make  it  corre-
spond to the “level” that we want, simply by mov-
ing it with the arrows on the bottom left.

Index marks It includes the text “marked” by the user when se-
lecting a certain text and doing Insert ▶ Table of  
Contents and Index ▶ Index Entry .

9.2.2 The “entries” tab
The structure of each line of the index is defined in the Entries tab.

We can define the content shown by a certain level by selecting it 
and modifying what the Structure line offers. Each “button” in that line 
represents a part of the information that will be included in the index 
automatically. We can delete what is already configured by simply se-
lecting the corresponding button and pressing  Del,  or  we can add 
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content by clicking on one of the blank spaces and pressing any of the 
buttons below (chapter number, entry text —title in itself—, a tab stop, 
the page number). It is also possible to write simple texts (to prefix the 
word “Chapter,” for example, or to create a space between the chapter 
number and its name) in any of those spaces.

The meaning of the available entries is the following one:

E# Represents the chapter number. We can choose be-
tween showing only the number without its even-
tual separators or everything (default option).

E Represents the text of the title.

T Represents a “tab stop.” For these tab stops it is pos-
sible to choose a “fill” character (by default, dots). It 
is important to note that these tab stops are limited 
compared to the normal ones and that it is not ad-
visable to use more than one per line:

Bug 32360 - tabstops on TOC are no fully functional (do not sup-
port right and middle alignment) 

# Represents the page number.

The “hyperlink” button makes the index “interactive:” Ctrl + click 
on the corresponding index line  (or  a  simple  click on the exported 
PDF) and the cursor will “jump” to the corresponding page. In the lat-
est versions of LibO this option is activated by default and is seen as 
two buttons, one at the beginning of the line and called “LS” (hyperlink  
start) and the other at the end called “LE” (hyperlink end). If we have an 
old document and we want to activate this option it is enough to place 
the cursor in a blank space in front of where we want the hyperlink to  
start and click on the  Hyperlink button (the LE button appears) and 
then place the cursor on the end and click again the Hyperlink button 
(the LE button appears).

It is important to note that by selecting each of the entries in the in-
dex Structure it is possible to select a particular character style that ap-
plies to it. This includes manually entered text fragments and hyperlink 
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buttons.
By hovering with the cursor over one of these “buttons,” we can see 

not only its name but also the eventual character style that it has ap-
plied.

It is unlikely to happen, but by adding more content to the Structure 
we may have to use the arrows at the ends of this line to access all its 
parts.

By default, on the hyperlinks is applied the character style called  
«Index Link» which does not offer any particular formatting. If  
we want the link to be shown, for example, on another color, it is  
enough to edit that character style.

To add a space between the chapter number and the text you must  
add,  for each level, a space between the E # and E entries. That is, you 
must click on the blank space between the E # and E buttons and add 
one or several spaces.

Let me insist: this configuration of the structure shown by the in-
dex must be made for each level.

9.2.3 Styles tab
Almost everything in Writer is governed by styles and the index could 
not be an exception. In this tab we can select which paragraph style is  
used by each level of the index: it is enough to select a level on the left,  
a style on the right and click on the assignment arrow.

The Default button is the way to return to the default configuration 
while the  Edit button can be used to edit the style without having to 
call the style and format editor.

9.2.4 Columns and Background tabs
There is not much to say about these tabs, except perhaps that the gray 
color that is seen as background of the index during the editing of the 
document even if we have left the background in “without filling” is 
not a true color: it is there only to say that the index has been gener-
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ated automatically  and therefore will  not be  printed or  exported to 
PDF. 

It  is  possible  to  deactivate  this  background (or  change  its  color) 
from the menu Tools ▶ Options ▶ LibreOffice ▶ Application Colors : it 
is enough to remove the check mark in Text Document ▶ Index and  
tables shading …  for my part, I find it useful.

9.3 A few words about the different types of 
indexes
As we have already mentioned, it is possible to create many types of in-
dexes. The indexes of figures and tables work only if you include those  
figures  or  tables  in a “caption” frame,  those  that are  added by right 
clicking on the image and selecting “Insert caption” (we already talked 
briefly about this in 3.8).

Actually, these would be “number range” indexes… we will come  
back to this in the Chapter 13.

The context menu for the tables does not offer the option of insert-
ing a caption, but the contextual toolbar that appears when the cursor 
is in a cell of the table does: click on the Insert Caption button and we 
can start writing.

When creating the figure or table index, under Category and Display 
we can choose which of the categories we want to use to create the in-
dex and what information to use in it. I let you explore the options.

It  is  also possible to create word indexes:  we select the word we 
want to index and from Insert ▶ Table of Contents and Index ▶ Index  
Entry  it is possible to add the selected text to either an alphabetical in-
dex or a custom index (from there it is also possible to add it to the ta-
ble of contents: in that case you can define at which level to add the en-
try).

We must bear in mind that although it is possible when we “mark” 
an entry for the alphabetical index, to say that all similar texts must 
also included in that index, when new text is added after the creation 
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of the entry this will not be automatically indexed so it is convenient to 
leave  the  creation  of  the  word  indexes  for  the  end  of  the  editing 
process.

Bug 48684 - Index is not indexing new versions of already in-
dexed words 

The “keys” (to activate the second, the first one must be used) serve 
to classify the entries. 

In this way we can make the entries “pot,” “pan” and “strainer” ap-
pear under “kitchen tools”  while  getting “towel,”  “brush”  and “toilet 
soap” indexed under “bathroom,” even if  “Kitchen tools” or “bathroom” 
are not found in the text.

A particular type of index, with several differences in the details of  
its  construction with  respect  to  what  is  exposed here  is  the  biblio-
graphic index, of which we will talk about below.

9.4 Save a custom index
If after customizing an index to the smallest details we delete it, all the 
work done will be permanently lost. 

Not to mention about  reusing the customization work in a  new 
document.

So?
We basically have two options. 
The simplest is to create a template that includes the custom index, 

this way every time we create a new document based on that template 
we will have the index ready. 

With the second option it is possible to create a “library of indexes” 
to be used in any document, but before presenting it we have to talk 
about the “AutoTexts,” so we will leave it for the  Chapter 10.

9.5 The bibliographic database
Creating a bibliographic index in Writer implies working not only on 
the index itself, the mere list with which the bibliography will be col-
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lected in the document, but also in the database from which that list is  
constructed.

So, before continuing we must take a small deviation in the topic of 
building indexes to see how to collect the necessary data.

LibO has an interesting, but little used, tool to create, manage and 
use bibliographic databases.

While  there  are  certainly  better  programs  for  work,  with  more 
pleasant user interfaces and that pack a greater number of features, 
LibO’s bibliographic database is a sufficiently useful and flexible tool 
for most of the cases… if, of course, you know how to use it: the default 
options presented are not exactly the best ones,2 but fortunately it is 
very simple to correct these values to obtain the (almost) perfect bibli-
ography.

Unlike other tools such as Zotero that also serve to  collect biblio-
graphic information, Writer’s bibliographic database is dedicated only 
to organize the information previously collected by the user and to in-
sert it in the document with a minimum of effort.

The bibliographic database works on Base, which in turn works on 
Java. 

It is therefore important to have “Use a Java runtime environment” 
enabled in Tools ▶ Options ▶ LibreOffice ▶ Advanced . And, of course, 
to have a java virtual machine correctly installed.

9.5.1 Create a bibliographic database
Everything starts in Tools ▶ Bibliography Database . 

The  database  is  already  loaded  with  several  articles  and  books 
(mostly outdated) related to LibO.

We can eliminate  the  anachronistic  existing records  by selecting 
them and going to Data ▶ Delete Record . 

To create a new entry,3 it is enough to place the cursor in an empty 
entry or create a new one with Data ▶ Record , and then simply com-
plete the necessary options in the lower half of the window.

2 In fact, they are terrible.

3 For example, to refer to this book.
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The options to complete are very clear (and there are so many!), so 
we will not stop to analyze them in detail. We will just comment here  
that it is important to create a correct  Short name because through it 
we have to identify the bibliographic citation when we want to insert it 
in the document: better to choose abbreviations that we can recognize 
in the future.

After completing all the data for that entry, we will see that next to  
its corresponding line in the table we have an icon of a “pencil,” in-
dicating that it is still in edition: we have to right click on that line  
and select Save Record.

9.5.2 Insert references in the document
Insert ▶ Table of Contents and Index ▶ Bibliography Entry . Now we 
select the bibliographic entry from its short name (did I already say that 
a good name is important?) and press Insert.

When inserting the bibliographic entry this way, it appears in the 
document through its short name. But do not worry, we will have the 
possibility to change that later when we finally insert the bibliographic 
index.

At the time of inserting the bibliographic entry in the document, we 
also have the option  From the document content: by checking this op-
tion, the New button is enabled, which permits the creation of a biblio-
graphic entry that is stored only in the document used, not in the gen-
eral database.

When selecting From the document content, we see that in the Short  
name list we have, in addition to the “local entries” that we have gener-
ated, the entries entered from the database. This is because the entries 
extracted from the database are also copied into the document, to en-
sure that they will be available when the document is transferred to an-
other computer.

There is no way to transfer a “local” bibliographic entry to the gen-
eral database. If we receive a document with a bibliographic entry  
that we want to keep in our database, we will have to manually  
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transfer it.

9.5.3 Create the bibliographic index
The last step:  Insert ▶ Table of Contents and Index ▶ Table of Con-
tents, Index or Bibliography  and in the  Type tab, for  Type we select 
Bibliography.

It is precisely in this menu where we can make the entries num-
bered instead of showing through their short names: it is enough to 
check Number entries under Formatting of the Entries.

It is also possible to select there the type of brackets that will sur-
round the number (or short name) of the bibliographic entry. Unfortu-
nately, what is not possible yet is to assign a character style to the entry 
so if we want it to be a superscript, for example, we must do it manu -
ally or through the application of a character style.

Now let’s go to the  Entries tab. The way of giving the structure to 
each entry is similar to that of the normal indexes that we have already 
discussed.

The main difference is that now we have many types of citations to 
make (article,  book,  thesis…) and that each of these types of citations 
have many elements (author, year, editor…).

Here, as with normal indexes, it is possible to associate a character 
style to any of the elements present in Structure, to make, for example, 
that the title entry (Ti) appears in italics or present the year entry (Ye) in 
bold: you only have to associate appropriate character styles to each 
one of these entries.

The elements selected by default in the index structure for each type 
of entry are certainly not the best possible: for example, the type “Arti-
cle” does not include the page number or the name of the journal, so 
we have to do a careful job to customize the index before it turns out 
to be of any use for our document.

There are two ways to organize the citations shown by the index, 
both controlled by the Sort by option: Document position or Content. 

By default the bibliographic index is ordered respecting the order 
in which the citations were entered in the document, but it is also pos-
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sible to make a custom order, for example by type of publication or al-
phabetically, selecting what we want in Sort Keys.

However, as with normal indexes, all  customization work will be 
lost if we delete the index, so to “rescue” everything it is necessary to 
save the bibliographic index that we have created within a template or 
in an AutoText (Chapter 10!).

In the Styles tab it can be seen that, unlike the normal indexes, there 
are now twenty-two levels… and that all of them are assigned the same 
paragraph style called Bibliography 1.

Each of these levels corresponds to one of the “types” of citations 
that can be seen in the Entries tab (article, book…).

The last two tabs (Columns and Background) work exactly the same 
as in normal indexes.

It may be necessary, after adding new bibliographic entries, to up-
date the fields manually by pressing F9 since the fields of the ref-
erences are not updated automatically.

9.5.4 Insert bibliographic data outside the biblio-
graphic index
In some situation may be necessary, in addition to what is described 
above, to enter the complete bibliographic data of a particular entry di-
rectly in the body of the document, and since we are talking about bib-
liography and since we have already taken some “deviations,” then we 
will take just another one.

Writer allows to insert any data from any registered database. To do 
this we have two options: to use the main window of the bibliographic 
database  ( Tools  ▶  Bibliography  database )  or  open the  Data  sources 
toolbar ( View → Data sources , or CtrlShiftF4) and select the biblio-
graphic database from the list.

Selecting with one click to its left the line we want to introduce in 
the document, we can now pick it with the mouse and, without releas-
ing the mouse button, “drag” the entry to the document: when we fi-
nally release the mouse button, a menu will open allowing us to choose 
the desired fields and their formatting.
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For greater flexibility in the format it is better to choose in  Insert  
data as the  Fields option. Now it is enough to select the desired fields 
from the list on the left and click on the assignment button before ac-
cepting with OK.

As we have already mentioned, this same menu is also presented if 
we drag the entry from the Data Sources toolbar.
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Chapter 10

AutoCorrect and Auto-
Text

When Writer changes the "normal" quotes to the “typographical” ones, 
when it automatically passes the first letter of the initial word of a sen-
tence to uppercase,  when replaces -> with and arrow → in all  these 
cases it is making an “automatic correction” or AutoCorrect. 

It must be keep in mind that although some of the automatic cor-
rection options depend on the language of the document, they do not 
have any relationship with the spell checker, which must be configured 
separately (we already talked about that in  3.3).

To understand what “automatic texts,” or AutoText, are, it is enough 
to write, in an empty line, “dt” (without quotes) and press F3 or write 
“fn” and then press F3. In the first example a long paragraph is intro-
duced whereas in the second a table of one row and two columns with 
a Math object and a variable will appear immediately. 

These examples show how AutoTexts work and what  their main 
purpose is: to store fragments of documents that can be introduced at 
will quickly. 

In this chapter we will see how to use both tools
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10.1 AutoCorrect options
All  the  main  components  of  LibO  have  this  “AutoCorrect”  ability, 
which can be configured in Tools ▶ AutoCorrect ▶ AutoCorrect Op-
tions .

This menu is similar in all LibO components:

• Replace tab: displays a list of the text entries that will be re-
placed. There are three types of “corrections:” 

◦ The “traditional” ones require at least one space or punc-
tuation mark before and / or after so that they are com-
pleted. For example, two dashes -- are replaced by an en-
dash – as well  as some common spelling errors (such as 
“comuniti” being corrected by “community”).  

◦ The “immediate” ones that are activated in any position as 
long as they are surrounded by colons. For example, writ-
ing :alpha: we immediately get α. This type of AutoCorrets 
are really useful  for inserting special  characters:  for this 
book I have created a correction that goes from :>: to .▶

◦ Regular expressions. We will return to this topic, which is 
far from being simple, in Chapter 18, so now we will only 
say that it is possible to establish conditions so that, for ex-
ample, when writing A_2 it is automatically converted to 
A₂,  or  that A^2 turns into A2,  but that A-2 remains un-
changed.1 

Clearly, it is possible to create our own AutoCorrect entries: 
we simply need to enter what we want to replace, what we 
want to obtain and press New.

It is important to note that these options depend on the selected  
language: if we define an AutoCorrect for Spanish, it will not be 
available in English.

1 These substitutions are not  present  by default  in English,  but  they  are 
available for Spanish. In  Chapter 18, we will see how to create them.
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Although we can in principle eliminate some of the predefined 
AutoCorrects,  simply by selecting them and pressing  Delete, 
there is a catch: they will continue to apply even when we do 
not see them in the list

Bug 96787 - AutoCorrect: After Removal of Replacement Entry  
the Replacement Itself is still Performed

• Exceptions tab: the list of cases in which you do not want to 
apply some rules. Useful to prevent a text from automatically 
changing to uppercase after an abbreviation or to decide the 
cases in which two consecutive uppercase characters are not 
an error.

• Options tab: the elements found in this tab depends on the 
LibO component used. In general  Use replacement table refers 
to using the list found in the Replace tab.

Here Writer shows a particularity:  two selection marks.  The 
one on the left [M] refers to applying the selected option when 
doing  Tools ▶ AutoCorrect ▶ Apply ,  while the one on the 
right [T] refers to applying the option while writing.

The options that are selected by default in this tab are perhaps 
not the best ones (of some of them, such as Combine single line  
paragraphs if length greater than 50% that is present in Writer, I 
do not even understand its existence) so I recommend to you 
to carefully look at what each one of those options do, and 
only keep those that are useful to you. 

Some options can be customized with the Edit button.

• Localized Options tab: here we can set the change of the 
"normal" quotes to the “typographical” ones (or even the  
«Latin» quotes), as well as other options, such as automatically 
inserting spaces in front of the punctuation marks in French 
of changing from 1st to 1st.  

• Word Completion tab (only in Writer):  Writer collects the 
long words we write and suggests them when we rewrite the 
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first letters of those words. Many people like this option while 
others  hate it… well,  here you can configure it.  The option, 
marked by default in the latest versions of LibO,  Show as tip 
makes it much more interesting.

It is important to note that the list of words is taken from the 
open documents and that they are not kept between sessions: 
if  we  close  all  the  documents  and  open  a  new  one  that  is 
empty, there will be no suggested words.

This option has a serious drawback when working with multi-
lingual  documents,  or  when  several  documents  in  different 
languages are simultaneously open: the system could suggest 
words in the wrong language

Bug 32357 - Autocomplete is not language sensitive

In  Writer,  the  AutoCorrect  options  can  be  disabled  globally  by 
unchecking Tools ▶ AutoCorrect ▶ While Typing .

If you want to undo a particular AutoCorrect, it is enough to press 
CtrlZ immediately after the AutoCorrect has been introduced by 
Writer.

10.2 AutoText
As we have already said, AutoTexts are fragments of documents stored 
by Writer which can be entered through a “shortcut.”

There are no limits to the content of an automatic text: formatted 
text, tables, images, frames… indexes.

The procedure for creating an AutoText is as follows: select what 
you want to include in the AutoText and then go to Tools ▶ AutoText  
to assign it a  Name and a  Shortcut. Finally, in the  AutoText menu you 
now have the New option. If the chosen abbreviation was, for example, 
“mine,”  it  will  be  enough to write  mine and then press  F3 to have 
Writer insert the AutoText that we have created.

The preview that you see on the right of the menu Tools ▶ Auto-

136 AutoText

https://bugs.documentfoundation.org/show_bug.cgi?id=32357


Text  only works for existing AutoTexts and only when LibO has been 
restarted after creating them so it will not show anything while we cre-
ate a new one.

The option  Display remainder of name as a suggestion while typing 
also needs to restart LibO to work. What this option does is that if we 
start to write the name of an AutoText anywhere in a document Writer 
“suggests” it, so it will be enough to press Enter to enter the AutoText.

It seems to me that the abbreviation followed by F3 is simpler, but 
someone could find this option useful.

The drop-down menu of the AutoText button gives us several op-
tions, among which is to assign a macro to the event of entering an Au-
toText and, perhaps the most important, to edit a preexisting AutoText.

When editing an AutoText it opens as a separate document.  It  is 
enough here to modify the necessary and save as if it were a normal 
document. It is important to remember that these modifications will 
only be applied when we insert the AutoTexts  again: those AutoTexts 
entered before having edited it will not be affected.

If we want to edit any of the predefined AutoTexts, we may need  
administrator privileges since these are stored in the LibO installa-
tion directory to which a normal user does not have (or should not  
have) access.

If the AutoText that we create contains a link, it is useful to medi-
tate for a moment on which of the options of saving related links will  
give us better results.

Finally, the Categories button can be used to create new categories 
where we can group our AutoTexts,  also giving us the possibility to 
choose the path where to store them. We can create new paths with the 
Path button.

For those who prefer the mouse to the “shortcuts” it is possible to 
enable the  Insert toolbar ( View ▶ Toolbars ): one of its buttons shows 
the complete list of the AutoTexts.

And to close this section, an example that we left pending in the 
previous chapter: what can be done to “rescue” personalized indexes. 
Well, we simply have to select the index as if it were text, taking at least  
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one empty line before and one empty line after, and create an Auto-
Text.

Done!
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Chapter 11

Sections, frames and other 
floating things

In this chapter we will deal with two tools that are completely differ-
ent, but that can be used for (remotely) similar things: the “sections” 
and the frames.1

11.1 All about the sections
Documents  in  Writer  can  be  separated  into  “blocks”  called  sections, 
which have no limitations on their size: they can take only a few lines,  
several pages or the entire document.

Sections can also be inserted into  frames (we will talk about them 
bellow), occupy one or more columns of a page, we can even have sec-
tions within other sections.

It is important to note that here we have a slight linguistic problem: 
these “sections” have nothing to do with what are normally called “sec-
tions of a text” such as, well this section: what, for example,  calls 
“sections,” in Writer is nothing more than one of the headings with a 
“level” associated to its style in  Tools ▶ Chapter Numbering . Let’s see 
then what Writer means by “sections.”

1 It is my book. I mix what I want to mix.
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11.1.1 Create sections
To understand the use of the sections we must go directly to Insert ▶  
Section  to create a new one.

In the  Section tab of the menu that is presented, we can not only 
give it a name but also choose to show the content of another docu-
ment (the Link option): in this case the section will work as a “window” 
that shows that other document without blocking us from modifying 
it. This option is used automatically, as we will see later, when building 
master documents (Chapter 17).

But even if we do not want to use external documents, the sections 
are really useful for several situations that would otherwise be difficult 
to solve. For example, it is also possible to protect the section against  
modifications  or  even  to  establish  a  condition that,  if  fulfilled,  will  
cause the section to be hidden automatically, not allowing its content 
to be seen.

On the Columns tab we will talk about in Chapter 12. 
The Indents tab can be used to add a space in the left and right mar-

gins of the section. It is interesting to note that these indentations can 
also be negative, which means the content of the section can “cross” the 
margins of the text area.

The Background tab works in a way similar to how the background 
of a paragraphs or characters is set.

With the tab Footnotes/Endnotes it is possible to decide how to treat 
the notes inserted within the section.

In fact, with sections we can finally solve the problem that we left 
pending in the section 8.3: Number the notes “by chapter” even if our 
chapters are not assigned to level 1.

As we saw, Writer considers a “level 1” heading as a “chapter.” In this 
book the “chapters” are in the “level 2” (“level 1” is for the “parts”) and 
yet the notes are numbered “by chapter,” all thanks to the sections!

The first option to activate in the  Footnotes/Endnotes tab is  called 
“Collect at  end of text,”  which is  perhaps one of the worst assigned 
names in the entire program.

And it is that this function does not gather all the footnotes at the 
end of the section: each note will continue to appear on its corresponding  
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page. Only the notes on the last page of the section will be “at the end” of 
it.

Activating  then the  Collect  at  end  of  text we  can now choose  to 
restart the numbering of the footnotes: we just have to include each 
chapter in its own section.

I recommend giving the sections a name that at least remembers the 
chapters, that this will help us organize the document.

The option that  does what it says is  Endnotes ▶ Collect at end of  
section .  This option gathers the endnotes at the end of the section, 
skipping  the  use  of  a  particular  page  style  and  resolving  the  other 
problem that we also comment in the section 8.3.

This is also useful if we want to group our “endnotes” by chapter in-
stead of at the end of the document: we simply put each chapter in a 
section activating the aforementioned option.

11.1.2 Configure sections
From the menu  Format ▶ Sections  we can modify the properties of 
the sections already inserted in the document. We can also access this 
menu if the cursor is inside the section: to the right of the status bar we 
will  see the name of the section (remember my recommendation to 
give it a good name?): with a click there, the configuration menu will 
open.

Except for small details that are easy to understand the options of-
fered by this menu are identical to those given by the Section tab that 
you get when creating a new section.

The options of the other tabs are available by pressing the Options 
button. The menu that is  presented is  identical  to the one you have 
when creating the section with the only difference of the absence of the 
Section tab, whose function is, as we saw, covered in the main dialog.

11.2 All about frames
Frames are like “small pages” that float on top of real pages and accept 
any type of content. They are automatically used by Writer every time 
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an image or a Math object is inserted, but we can also create others 
manually.

We will talk here about frames, about their uses and their peculiari-
ties, about how to create them and how to control them, either directly 
or through styles.

11.2.1 Create frames
If we do Insert ▶ Frame ▶ Frame ,2 we will be presented with a menu 
with several tabs.

In the Type tab we see several important options: 

• The Size options are quite clear so we will not insist on them.

• We will talk about the  Position options later when discussing 
the positioning of figures and tables.

• The  Anchor is used to determine the position of the frame in 
relation to the document. There are several options:

◦ To page: if we insert a frame on, say, page 142 and anchor 
it “to page,” that frame will be maintained on page 142 no 
matter what happens to the rest of the document. In fact,  
if we begin to erase content in such a way that the docu-
ment  fits  in  only  20 pages,  page  142 (and all  the  blank 
pages necessary to reach it) will continue to exist to house 
the image. 

Another situation where anchoring to page can be prob-
lematic is the use of master documents. We will return to 
this in Chapter 17.

Therefore: be careful with the anchor to the page… 

2 The option “Frame Interactively” allows us to “paint” the area that will be 
occupied by the frame instead of using the menu. The option “Floating 
Frame” is to insert a small “window” to an external document, very simi-
lar to what we can do with the sections, but in “floating” mode and with-
out being able to spread over several pages.
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◦ To  paragraph  and  To character:  the  position  of  the 
frame is determined in relation to the paragraph (or the 
character) in which the cursor was at the moment of in-
serting it. They are in general the most useful options. 

◦ As character: the frame behaves as if it were one more 
character  in  the  paragraph  where  it  was  inserted.  Ex-
tremely useful when inserting small images or objects that 
must be placed next to the text. It is the option used by the 
frames of the Math objects.

In the Options tab we can give a name to the frame, which could be  
useful to quickly identify it in the Navigator during the edition of the 
document. About the options Previous link and Next link we will talk in 
the next section. The “protection” options serve to prevent some fea-
tures of the frame from being modified. The  Vertical alignment of the 
content does exactly what its name says. Finally, the option Text direc-
tion is useful only for writings systems from right to left or from top to 
bottom: given that this text is written in English, I will let them pass.3

The Wrap tab regulates what happens when the frame does not oc-
cupy the entire width of the page: if the content of the page should be 
kept completely above or below the frame or if it should surround it, 
for example. The best way to understand how these options work is by 
using them, so although we will return to some of them below I invite 
you to play with them a bit: I will only say that the First paragraph op-
tion makes the adjustment options apply only to first paragraph that 
surrounds the image, while the option  In background (applicable only 
when  you  select  Through wrap)  makes  the  frame part  of  the  back-
ground of what it is anchored to.

If the option In background is active the only way to re-select the  
frame is to Ctrl + click on it.

In the  Hyperlink tab you can define a link between the frame you 
are creating and a file, for example, so that the latter is opened when 
the object is selected.

3 I mean, I have no idea how they work.
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The use of the Borders, Area and Transparency tabs is clear.
In the Columns tab is where it is seen with greater clarity that the 

frames act as small pages. We will talk about all this in the Chapter 12.
Finally,  with  the  Macro tab it  is  possible  to  assign a  macro to a 

frame, in such a way that the macro is activated when performing on 
the frame any of the operations listed in Event.

11.2.2 Linking frames
If we insert two frames in a document we can  right click on one of  
them ▶ Properties ▶ Options tab  to “link” that frame with the other 
using the options  Previous link and  Next link,  so that when the first 
frame is completed the text flow to the next frame.

When selecting one of the frames we can see the link between them 
as a dotted line that unites them.

This could be useful for building more “dynamic” documents where 
many images and objects alternate with short portions of text, as in a 
magazine or a photography book.

11.2.3 Frame styles
By inserting a frame in the way we have already described, a frame 
style called, appropriately, Frame, is automatically assigned to it, while 
if we insert an image the Graphics style will be used, a Math object will 
use the Formula style, and so on.

There are other frame styles (and we can create even more) listed in 
the fourth button of the style editor.

Except for the addition of the  Organizer tab (which works exactly 
the same as the other style types), there are only two differences be-
tween  the  options  present  when  editing  the  frame  style  and  those 
found when manually inserting (or modifying) any frame. The first of 
the differences is evident: there are no options to link, which would be 
impossible to manage from a style and therefore are not present. The 
second difference is in the absence, in the Type tab, of the anchor op-
tions.

This deficiency has already been reported:
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Bug 32484 - Allow anchor settings in frame styles 

11.2.4 Images and tables surrounded by text
We can perfectly control the position of an image and how it will be 
surrounded by text accessing the properties of the frame in which it is 
located. To perfectly control the position of the image,4 after inserting 
it normally with anchor “to paragraph” or “to character” it is enough to 
do a right click ▶ Properties ▶ Type/Wrap tabs .

It is advisable, if the image should be within the text area, to use the 
option  Page/Paragraph  text  area in  the  Type tab,  under  Position,  al-
though any of the other options should work as well. You just have to 
be careful with the Entire page option since it ignores the margins and 
could be a little more complicated to control, although it is useful to 
place objects that are outside the text area of the page.

Something that can be useful is to mark the option Mirror on even  
pages:5 with this option, if we select for example that the image is “ex-
ternal,” it will be automatically placed on the right on the odd pages 
and on the left on the pairs.

It is important, for images surrounded by text, to mark the option 
Follow text flow since in this way the image will remain in a position 
relative to the paragraph or character to which it is anchored,  but al-
ways inside the text area of the page. This avoids the problems that could 
arise if the image falls near the bottom edge of the page.

In the Wrap tab you can select several options to make the text sur-
round the image: Before, After, Parallel, Optimal. There it is also possible 
to modify the distance between image and text. If you also want the 
text to follow the shape of the image, the  Contour option must be se-

4 The option to “drag” the image to the desired position is certainly possible 
in Writer… but as in the other programs where this is possible the lack of  
precision that results usually causes more problems than it solves: drag 
and drop seems simpler than modifying numbers in a menu, but generally 
it is not, so I do not recommend it.

5 Or odd, depending on which page is the image whose options we are edit-
ing.
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lected.  Many  of  these  adjustment  options  are  also  available  with  a 
right click on the image ▶ Wrap . If we are not satisfied with the auto-
matic contour generated by Writer, it is possible to access an editor to 
change it with a right click on the image ▶ Wrap ▶ Edit contour .

The option Outside only that is enabled when selecting Contour 
on the right click on the image ▶ Properties ▶ Wrap tab  pre-
vents text from entering in any gap the image may have.

This option of wrapping text to the shape of the image is only valid 
for isolated images: if we add a caption to the image, the wrap will fol -
low the rectangular shape of the external frame.

To do the same with a table you just have to insert it into a frame 
and proceed on the frame as for the images.

11.2.5 Images that are NOT surrounded by text
In this  is still almost unbeatable, it is true: everything starts with 
a  \begin{figure}, followed by a  \includegraphics{…}, possi-
bly a \caption{…} and ends with a \end{figure}. That’s it:   
does its magic and the figure ends up in the perfect position. In Writer, 
as in any other WYSIWYG processor, this is not the case… but not nec-
essarily the experience has to be “traumatic.” At least not completely.

To begin,  let’s  see  (as  always,  very roughly)  what   normally 
does: considering the point where the figure has been inserted

1. if there is room available, the figure moves to the beginning of  
the page where the insertion point is, without leaving text be-
fore it.

2. If the beginning of the page is occupied by another figure, the 
image moves to the end of the page without leaving text after 
it.

3. If both the beginning and the end of the page are occupied, the 
figure is moved to the next page, respecting the two previous 
points.
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To get close to this in Writer we can start by inserting the figures in  
their own blank paragraph, anchoring them to the character (not  as a 
character) or to the paragraph and only at the end of the document writ-
ing process (that is, when we do not have more text to add to it) right  
click on the frame of the figure ▶ Properties  and at the bottom of the 
Type tab, under Position, in Vertical select Top for the images that should 
go to the top of the page (Bottom for the others) while in to select Page  
text area.

The figure will be placed in the correct position.
Obviously this adjustment of the position can also be done at the 

level of the frame style, but there is a risk that if two images whose an-
chor points fall on the same page, we end up with one image on top of  
the other. This leaves us only two options to work:

• We edit the frame style and then manually correct the possible 
“conflicts” 

• We manually adjust each image only at the end.

If in our document it is very difficult for several images to be on the 
same page we can use the first option, which in practice works (almost) 
exactly like , while in the case where the “probability of overlap” 
(of  having  more  than  one  image  per  page)  is  high,  the  best  option 
would be to manually adjust the position of each frame.

Important Note: The footnotes are part of the text area, so if an  
image is sent to the bottom of the page we have to be careful that  
the image does not cover the footnotes that are there!

Important Note: When a caption is added to the images ( right  
click  ▶  Insert  Caption )  the  image  is  included  inside  another  
frame, which shows the image and the paragraph (with its num-
bering) of the caption.

It must be keep in mind that there is a problem with frame styles 
when a “caption” is applied: the format of the frame style of the image 
is applied as direct formatting on the external frame while the image 
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“loses” its style. To have everything “under control” it is necessary to 
reapply the corresponding frame styles to both, the image and the ex-
ternal frame.

Bug 32485 - Settings on the image frame style lost when caption is  
applied 

ATTENTION TO THE ANCHOR POINT! If in two paragraphs of 
the same page we anchor two images with their respective numbered 
captions and we send to the end of the page the one anchored to the 
highest paragraph while we send the one anchored in the lower para-
graph at the beginning of the page the numbers will be wrong. Writer  
takes the position of the frame anchor as reference for the numerical se-
quence, not the position of the frame itself.

This  is  not necessarily an “error” of  Writer,  but since the anchor 
point of an object is only visible when the object is selected, it is quite  
easy to fall into this situation.

11.2.6 Move the anchor point
Previously I discussed how to correctly position images or any type of  
frame when we create a document, but what happens when we have to 
edit an old document?

Suppose we have a document with a frame anchored to a paragraph 
on page 148 and that we start adding text on the previous pages so that 
the paragraph to which the image is anchored suddenly jumps to the 
following page. In that moment the image will follow the paragraph, 
leaving an unpleasant hole at the end of page 148.

And is that poor Writer is here with a difficult to solve contradic-
tion, because although it has been a gap the text can not “go back” to 
occupy that space as that would imply carrying the image again, but in 
doing so the text would now have to go to the next page and… you get 
the idea.

Bug 89477 - Images and objects should have an option "Anchor to  
page (moves with page)" to deal with page breaks 
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Fortunately it is very simple to change the anchor point of a frame 
anchored “to character” or “to paragraph:” selecting the frame, the an-
chor point will now be visible so we simply have to take it with the 
mouse and move it to another place in the text. If we move this anchor 
point to later paragraphs, we will allow a part of the text to return to 
the previous page thus closing the gap.

With anchorage “to paragraph” the anchor will jump from one be-
ginning of paragraph to another while with anchor “to character”  
moving the anchor will be much “continuous.”

With anchorage “to character” there is a problem with the location  
of the anchor when zooming the document:

Bug 99932 - Erratic behavior of anchor point when figure is an-
chored "to the character" and the document is zoom-in or out

What is commented here does not always work on the first attempt. 
On more than one occasion the “gap” remains until we bring the cursor 
to the end of the previous paragraph and press Enter to create a blank 
line: at that moment Writer “realizes” that there is a gap and the text 
moves to fill it. Then we can delete the line we have entered to “shake” 
the text.

Don’t ask.

11.2.7 Simulate a page header with frames
Strange idea, isn’t it? Why would I have to simulate a page header when 
I can create a real one without problems?

The headers in Writer have a small drawback, which is more an un-
happy design than a true error: the fields (yes, they are coming: Chap-
ter 13), for example the “Chapter” field that show the headings, read the 
information that can be considered valid from the beginning of the 
first line, not on the whole page.

For example, suppose that in the header there is a field that shows 
the level 2 headings and that we have two of these headings, one on the 
previous page and another on the present page:  the field will show the  
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value of the previous heading unless the one on this page is exactly on the  
first line of the current page.

Fortunately  the  footer  correctly  reads  the  heading that  is  in  the 
middle of the page, so a trick to overcome this (which I have applied to 
this book) is to insert a frame anchored at the page footer and modify 
its properties so that is placed simulating the header.

Care should be taken to modify the upper (increasing) and lower 
(decreasing) margins of the page style to give space to the simulated 
page header.

I trust that you will not have problems when implementing this so-
lution.
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Chapter 12

Text in columns and ta-
bles

The idea is always the same: enter content in parallel columns on the 
same page. What changes, clearly, is the method, but also changes the 
scope: the text in columns (what we will see in the first section) is useful 
when we want the content to flow from the first column to the second 
by extensive portions of the document while the tables keep the con-
tents of each column (of each cell!) independent of each other and are 
useful for more limited regions of the document.

Let’s see how to work with all this. 

12.1 Text in columns
There are basically two ways to get text in columns in a Writer docu-
ment:

• With page styles.  This  form is  recommended if  each page 
have a fixed number of columns.

• With sections. Useful when you need to have different num-
bers of columns on the same page.
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12.1.1 With page styles
When editing the page style,  in the  Columns tab you can choose not 
only the number of columns but also the width of each of them, the 
separation between them, if Writer should draw a line of separation, 
and so on.

With this option the text will successively fill each of the columns in 
order from left to right until the page is completed.

The drop-down menu that is  just below the number of columns  
configuration offers us Left-to-right (LTR) (default option), Right-
to-left (RTL) and  Use superordinate object settings. Unless we 
have to write in a “from right to left” writing system, better leave  
the default option.

12.1.2 With sections
Sections can also have an arbitrary number of columns and we can 
have several sections on the same page. In the Columns tab we are pre-
sented with the same options that we had when choosing columns in 
page styles. The difference is in the option, marked by default,  Evenly  
distribute contents to all columns that causes the columns to be filled si-
multaneously instead of one after the other: the section will grow to 
accommodate the extra content.

It must be keep in mind that this option will not work if there are 
footnotes in the text: since the footnote must simultaneously belong to 
the section and at the end of the page, when inserted the section will be 
extended to take all  the  page,  regardless  of  whether or  not  there  is 
enough content to get there.

Unless, of course, the Collect at end of text option we talked about in 
11.1 is enabled. But we already discussed that.

As we have already commented it is possible to have more than one 
section on the same page so, for example, we can start the page without 
columns (title and summary) and continue with two columns simply 
by inserting a section after the initial text without columns, thus build-
ing a typical structure of an article.
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As we have seen in the previous chapter, to modify the characteris-
tics of an existing section we can go to Format ▶ Sections , choose the 
section we want to modify by its name and click on the Options button.

12.1.3 The Columns menu entry
After a brief absence in version 6.0, from 6.1 we can again “enjoy”1 the 
menu  Format ▶ Columns .  This menu is just a “shortcut” to the two 
methods mentioned above: if we have selected some text, it will offer 
us between using a section or modifying the current page style.

It is not that this option contributes that much. 

12.2 Tables
Historically,  the handling of tables in Writer has always been, in the 
best of cases, poor. The good news is that the LibO team is putting a lot  
of work into developing table styles that facilitate the use of this very 
important element of our documents. The bad news is that there is still  
a long way to go.

Here I will tell  you what is available,  what are the problems and 
how to survive the need to use tables. We will also talk about how to 
use the great grandfather of the tables, the tabs, inside a table and some 
“tricks” associated with this topic.

12.2.1 Lights and shadows of table styles
Insert a table in any document. Let’s say, three columns and four rows. 
Now go to the style editor and select the sixth button: table styles.

With the cursor in a cell of your table, double click on any style of  
the list. Applied, fantastic, right?

Well, not so much. It is true that table styles are easy to apply and 
that some of them are even pleasant,  but at the time of writing this  
book table styles have a series of important problems that could make 
you not interested in using them at all.

1 So to speak.
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On the one hand, when applying a table style, the paragraph style in 
use is ignored, generating a kind of “direct formatting” that does not go 
away with CtrlM, forcing us to apply the paragraph style again:

Bug 104389 - Direct formatting instead of styles is used for text  
on table autoformat/styles 

And on the other hand, as you will notice when doing a right click 
on one of the table styles, it is not possible to create a new style or even 
modify an existing one: it is what comes by default and nothing else.

In  summary:  unless  you  really  like  one  of  the  predefined  table 
styles, there is no real advantage in using them versus manually for-
matting your tables. Therefore, in the next sections we will discuss how 
to format a table and how to “rescue” that formatting to use it at an-
other time.

12.2.2 The table formatting tools
Either from the contextual toolbar for tables or from the Table menu, 
we have at hand all the tools we need to select edges, background color 
for cells, whatever is necessary.

It is possible to choose the vertical alignment of the contents of the 
cell,  we can join cells  or divide them, add or remove rows and col-
umns… in short, it is easier to play with the options than to read long 
and dry paragraphs explaining what each button does.

Remember that the paragraphs in each cell are normal paragraphs, 
so you can act on them by applying any paragraph or character style 
you need.

There are, however, a couple of options we can use to provide the 
desired format to tables that may not be as clear or easy to tame as they 
should. We will deal with them bellow.

12.2.3 The table width
The tables inserted in Writer occupy by default all the available width 
of the text area. To change this in a controlled way it is necessary to 
right click on the table ▶ Table properties , or (with the cursor in one 
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of its cells) go to the menu Table ▶ Properties . In the Table tab we have 
the options to control the width of the table and the free space to the  
left or to the right… by default, grayed out. This is because the width of 
the  table  is  in  some way  controlled  by  the  Alignment option:  if  we 
change the alignment from  Automatic to any other of the options we 
achieve greater control.

Something important to keep in mind is that the values for  Width 
and those listed under Spacing are related to each other: when modify-
ing one, the others will be modified accordingly. In this menu, the Rel-
ative option refers to modifying the width of the table «relative to the 
width of the text area» and therefore the boxes to configure the table 
will turn into percentage values.

In this menu the  Columns tab gives us the chance to control the 
width of each column individually.

The Text Flow tab can be used to make the table start on a new page 
or new column (checking the option Break), among other options that I 
let you explore.

On how to insert tables surrounded by text, it is the same as with 
images: they must be included within a frame. More information in 
11.2.

12.2.4 Save a table with an AutoText
We have already discussed the AutoTexts in 10.2: they are a method for 
inserting predefined document fragments wherever we want. And this 
is exactly what we need to “save” a particular table format that we have 
manually created.

After modifying the format of a table according to our convenience, 
we select it as if it were text (we must take at least one empty line be-
fore and one after the table, otherwise it will not work), and then we go 
to Tools ▶ AutoText  (or CtrlF3) to assign to it a name and a “short-
cut.” Finally, on the AutoText button we have to use the New option. If 
the chosen shortcut was, for example, “tb” it will be enough to write in 
any document tb and then press F3 so that Writer inserts the AutoText 
that contains the table.
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12.2.5 Tab stops within tables
We already discussed when talking about tab stops (6.1.9) the possibili-
ties they offer, among which is to align numbers to the decimal point.

Now, if you have tried to insert tab stops in a table you noticed that 
the Tab key actually makes the cursor jump from one cell to the next, 
how to insert a tab stop into a table?

CtrlTab is enough.
Now, it is important to note an idiosyncrasy of the tab stops within 

tables: if in the paragraph style used for the contents of the table we de-
fine a tabulator with alignment to the decimal point, it is not necessary 
to insert the tabulator so that the numbers are aligned,  it is enough to  
have defined it.

123.456789
1.23456789

1234567.89
123456.79

2568.352

In the column on the left we have an ex-
ample of numbers aligned to the decimal 
point within a table: the decimal tab stop 
has been defined, but not used.

Of course: the text of the cell must not be “centered.”

12.2.6 Insert a space before a table
Pressing Enter at the beginning of the first cell (the one on the top left) of 
a table will give us different results depending on where the table is lo-
cated. 

If the table is in the middle of any page with text before or after it, 
Enter will simply add a blank line to that cell, as we can expect from the  
“normal” behavior of this key.

However, if the table is on the first line of the first page or is just at  
the beginning of a section or immediately after a page break, the  Enter 
key will behave differently, introducing a blank line before the table to 
so we can move it freely.

Having a blank line before a table is important as this is the only 
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way to completely select it and “move” it to another part of the docu-
ment: selecting from the previous blank line to the blank line after the 
table we can cut it  and paste it like any other document content or 
even “drag” it with the mouse to a new position.

12.2.7 Remove the extra line under a table
When a table is included in a frame or in the header (or footer) of a 
page, a blank line always appears below it and none of the “traditional”  
ways of erasing spaces will work to eliminate that line.

By placing the cursor at the end of the last cell (the one on the lower 
right), it is enough to press CtrlShiftDel.

This  eliminates the  line immediately below any table,  even those 
that are in between on a common page.

With AltEnter the line after the table can be inserted again.
Actually, what this “keyboard shortcut” does is to erase the sentence 

that follows, so if immediately after the table there is a long paragraph 
consisting of several sentences, this keyboard shortcut deletes  all the 
text  to the  first  period,  question or  exclamatory mark or  paragraph 
break, so it is advised to be careful with it… 

12.2.8 Number recognition
In  Table ▶ Number Recognition  we can activate  or  deactivate  this 
property that let Writer to try to “recognize” the number entered, in 
order to automatically format it.

When this option is enabled, if we insert in a table a number that 
has several decimals it will surely be “rounded” to the second decimal 
or if  we insert for  example “February 10” this will  be automatically 
converted to 02/10/19. 

Notice that the actual formatting depends on the locale settings we  
have  under  Tools  ▶  Options  ▶  Language  Settings  ▶  Lan-
guages : by default in Date acceptance patterns we have the de-
fault options for the language of our system, but we can change  
them if needed.
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I do not know, maybe someone likes it.
The format of each particular cell or the whole table (if  it  is nu-

meric,  a  date,  only  text…) can be manually  configured by using the 
menu Table ▶ Numeric format .
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Chapter 13

Fields, cross-references 
and similar topics

In this chapter we will talk (finally!)  about the tools available in the 
menu Insert ▶ Field ▶ More Fields  or from the corresponding entry in 
the menu that offers the Insert Field button in the standard toolbar.

What we find here will help us to automate the creation of certain 
content that would otherwise be very difficult to manage.

The page numbers, the cross references, the numbers that appear 
when we right click on an image ▶ Caption , the name of the chapter 
that appears in the page headers of this book and many other things 
that we will see below are handled through “Fields.”

A field is therefore a small portion of text whose content is auto-
matically determined by following certain parameters previously se-
lected, being “sensitive” to the environment in which it is located.

We can for example create a special type of field called “variable” 
that stores the name of a product on which we are writing a manual. 
Or insert the date in which a document has been edited without even 
looking at the calendar.  Or establish a condition for a certain para-
graph to be “hidden” when that condition is met…

The list is long and extremely interesting.
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13.1 Document tab
From here we can insert a lot of information concerning the document 
we are creating.

This information can be static, such as the name of the file, the date, 
the name of the user… or dynamic, as the text that in the page headers 
of this book shows the name of each chapter.

The options here are quite clear, so I will not insist on them. The 
only point to highlight is that when you insert the Chapter field, Level 
refers to the outline level set for the paragraph styles used as headings,  
either through Tools ▶ Chapter Numbering  or through the Outline & 
Numbering tab of the heading paragraph style used.

13.2 Cross-references
Writer’s cross-referencing tool is really powerful. With it we can effort-
lessly  cross-references  to  titles,  footnotes,  endnotes,  numbered lists, 
captions  added to  figures  or  tables,  variables  (see  below)  applied  to 
number equations… Each of these things is under its own category in 
the Type list.

It is also possible to “mark” any text or object using Set Reference: it 
is sufficient to select the text or element, assign it a name and click on 
Insert. Then, all references manually marked will be available in Insert  
Reference.

This menu offers a “filter” that allows us to filter the entries and find 
the one we need quickly.

For each element selected to make the reference we can choose, in 
the Insert reference to box what we want to see: the page number where 
the text or object is located, the chapter number of the element, the 
text itself of the reference, its number… I leave you exploring the pos-
sibilities.

Something that still can not be done automatically is to associate a 
character style to the cross-reference:

Bug 119048 - Associate a character style to cross-reference fields
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13.3 Functions
Perhaps very interesting for “office” documents, the options on this tab 
are not very useful when writing a book, a thesis or a manual, topics 
that we are dealing with here.

In this tab it is possible to define text that will be displayed only if a 
logical  condition is  fulfilled,  or we can define a logical  condition so 
when it is fulfilled the corresponding paragraph is hidden.1 I will not 
go into this topic.

13.4 DocInformation
It can be used to insert the information we have in File ▶ Properties ▶  
Description / Custom Properties  tabs.

Like the precedent tab, it is more useful in “office” documents than 
in a book. Let’s continue with what concerns us.

13.5 Variables, number ranges and other 
fields
In the  Variables tab it is possible to create different types of variables 
that can be either fixed or dynamic.

To create a fixed variable (for  example,  a  name that  must  be re-
peated several times in the document or a number that we will use sev-
eral times) we must use Set variable under Type. It is important to select 
the correct format for the variable we are creating, because if it is nu-
merical and then we try to enter text, it simply will not work.

In Show variable we have a list of created variables that we can in-
sert in any part of the document.

1 I remember a person in the forums who needed to generate a template in 
which the page number would be shown if the document had more than 
one page, but the footer would be empty if the document had only one 
page:  inserting in the page footer a page number field and the hidden 
paragraph function with the condition page == 1 was enough to solve 
the problem.
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It is important to note that if  after creating a variable,  we return 
later in the document, on Set variable, but instead of creating a new one 
we select an existing one from the list,  we can redefine it and the new  
value will be taken from the redefinition point. That is, if we create My-
Variable on the first page with value First and then on page 10 we rein-
sert MyVariable but this time with value Second, when we insert a refer-
ence to that variable with Show variable the value shown will be  First 
for the first nine pages and Second from the tenth.

If we have some numerical variables already defined we can create a 
new variable (also numerical) that is the result of an algebraic expres-
sion of the value of the other variables. For example, if we define two 
numerical variables Var1 and Var2 we can define a variable Foo that 
is Var1 + Var2, or even Var1 ^ Var2.

Double click on the variable thus entered to edit its value.
The  DDE field (Dynamic Data Exchange) is not very useful in this 

context since there are much simpler ways to use DDE objects (for ex-
ample, copying a table in Calc and pasting with Paste Special ▶ DDE  
Link) , so I will not talk about this option.

Insert Formula allows us to enter a field with a small mathematical 
expression. Do not confuse this option with the Math equation editor 
that we will discuss in the Chapter 15.

Input field is related to User Field. They are used to insert short texts 
or numbers that can be changed quickly. It’s not something that I use,  
so let’s move on.

The Number range fields are perhaps the most useful that we find in 
this tab. Unless you want “special effects” like making the range grow 
in “jumps” of two units at a time, its Value can be left empty: Writer un-
derstands that you want a range that starts at 1 (or A, or I…) and grows 
one by one.

As an example, suppose that we have created a number range with A 
B C format. When we insert it for the first time Writer shows us the A 
value with gray background (which will not be printed nor exported to 
PDF). If we now copy that A and paste below we will see a B and if we  
paste again a C… Now, if we move B before A, the values shown by these  
fields will be updated to always show the sequence in order (A, B, C): the se-
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quence is not determined by the order in which it is entered, but by the or-
der in which it is found inside the document.

The number ranges are automatically used by Writer to number the 
captions of figures and tables. In fact, we left pending in 9.3 a comment 
indicating that the indexes of figures and tables were actually indexes 
of number ranges: well, now you see why we said that back then.

Suppose we created a sequence called a photo to number our photo-
graphs. If we want to create an index of all the times this number range 
appears in our document, we have to go to Insert ▶ Table of Contents  
and Index ▶ Table of Contents, Index or Bibliography , select Index of  
figures (or tables, does not matter) as Type, and under «category» we can 
now choose the name of the number range created by us.

Last stop in the Variables tab: Set page variable on/off, activates/deac-
tivates a page counter, in such a way that Show page variable will show 
the number of pages between both.

13.6  Database
Another tab very useful for office workers, but of scarce relevance for 
writers.

I will just say that here it is possible to select, and insert, informa-
tion from the different databases registered in LibO, allowing the fa-
mous “mail merge” or use the most varied data about a customer or a  
product, among other things.

13.7 A small drawback: the fields do not re-
flect the format of the original text
Yes, that’s the problem: if we have a chapter that talks about the H₂O 
and  the  subscript  was  introduced  through  formatting,  being  either 
“simulated” or  using an OpenType option,  when we cross-reference 
that heading, it will appear as H2O

Bug 77050 - Cross-reference to heading loses character style / di-
rect formatting (e.g., italics) 
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The only possible “solution” (let’s be honest: a dirty trick) is to use a 
font that contains true sub- and superscripts and insert them as special  
characters (we already say how to do this in 3.5), but this does not solve 
the italics or the bold ones.

In short, it is what it is.

13.8 Configure the numbering of figures and 
tables
As we have told several times, with a right click on an image ▶ Insert  
Caption  we can “enclose” the image in a frame next to a small descrip-
tive paragraph formed by the chosen category, a number range and a 
text of our authorship.

We already discussed it in 3.8, but it is worth insisting that when in-
serting a caption the “category” is not limited to the list present in the 
dialogue (figure,  illustration,  drawing, etc.): we can delete the text there 
and create our own category, for example, Photography. In this way 
the sequence that is entered in the caption will have the name of the 
chosen category and we will be able to see it listed in the Variable tab, 
Number  range type.  And,  of  course,  we  will  have  it  available  when 
cross-referencing.

Either in that dialogue where we create the caption or later, with a 
double click on the number of a caption already inserted we can con-
figure this number range, not only to change how it is numbered, but 
also to show more “levels:” with “none” we have consecutive numbers 
in the whole document while with the first level the numbering will be 
restarted after each level 1 heading, showing a numbering of the type 
<number of the first level>. <figure number>. If we select level 2, then 
<number of the first level>. <Number of the second level>. <Number of 
figure>… and so on.
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Chapter 14

Draw

Many times  we  have  to  introduce  drawings  in  our  documents  and 
Draw is a great tool to create them. Therefore, although this book is 
about how to use Writer, a section dedicated to the vector drawing tool 
of LibO is necessary.

I will only touch on basic issues here, highlighting points that are 
important to work correctly and that the casual user could easily over-
look.

It should be noted that although Writer has drawing tools (accessi-
ble  through  the  corresponding  toolbar)  I  do  not  recommend  using 
them since, despite being tempting, they are much more limited than 
those offered by Draw. It is better to keep a Draw file with our draw-
ings and to copy and paste what we need: this will give us a better con-
trol of the results and it will save us a lot of headaches.

At the end of this chapter we will return to this topic.

14.1 The graphical interface of Draw
This is where the sidebar shines without a doubt, putting at your fin-
gertips very powerful and simple to use tools which allow us to modify 
the properties of objects in real time.

The default options of LibO have improved greatly in the latest ver-
sions, but if it is necessary to change something we have already dis-
cussed at the beginning of this book about how to do it, so let’s see 
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what we have available.
To the right of the editing window we find the sidebar. To the four 

typical tabs (Properties,  Styles,  Gallery and Navigator) is added in Draw 
6.1 a fifth (actually, it appears in second place) with the basic Shapes: ar-
rows, curves, connectors, and so on.

The Properties panel offers many tools to modify graphic objects and 
the text associated with them quickly and without needing to resort to 
special menus. But above all things, it allows us to make the changes in  
real time.

This panel has several sections that will be displayed according to 
the context: when no object in the editing area is selected, we see the 
options to configure the page.

Although Draw works with documents with many pages, it lacks  
the concept of page style, so the format of all the pages will be the  
same

Bug 49787 - Formatting: Allow different slide / page styles (orien-
tation, size) in a single document

If we select any object, for example a rectangle or a line, we are pre-
sented with the tools to handle the properties of the text called Char-
acter and Paragraph. This is because each Draw object can have a text 
associated with it: simply with a double click we can start to write.

We also have tools to modify the lines and the filling of objects,  
their colors, transparency…

In Position and Size we can move, enlarge, reduce or even reflect an 
object with great precision.

Important: There is a serious error in the implementation of the  
size shown in the Draw sidebar

Bug 99711 -  Sidebar Position and Size displays incorrect  width  
and height when units in mm

In short, you should not use the sidebar for this task, it is better to  
trust the menus ( right click ▶ Position and Size ). 
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On the other side of the work area we have the panel called Pages 
that shows thumbnails of all the existing pages in the document: with a 
right click we can create new pages or give them a name, while drag-
ging with the mouse one of the thumbnails we will be able to change 
the order of existing pages. On the left edge of the window we have a 
toolbar with several buttons (many of which are actually drop-down 
menus) that can be used to insert the basic shapes, change the color of a 
line or the filling of an area, and so on.

14.2 Bézier curves
LibO’s drawing tools allow the drawing different types of paths, such 
as polygonal, freehand curves or Bézier curves. This last type of curve, 
very common in vector design programs, is constructed by giving a se-
ries of points where it passes, the inclination on both sides of the point 
and “how flat it is there.”

The gray curve in Figure 14.1 is defined by three points, marked by 
the small yellow squares, and the arrow in it indicates the direction in 
which the curve has been constructed. The first two points that make 
up the curve show the tilt and “flatness” controls: the longer the dotted 
bar is, the “flatter” the curve at that point results (the length and incli-
nation of  the  dotted  bar  can  be  regulated  by  dragging  those  green 
points at their ends). 

The arrows constructed with dotted lines indicate how we have to 
move with the mouse to construct the curve: the curved arrows must 
be  followed  holding  the  left  mouse  button  while  the  straight  lines 
without it. For each point of the curve we have two “tilt controls” that, 
seen following  the  direction  in  which  the  curve  is  constructed,  we 
could call previous and next.

Let’s  select  then the Bézier  tool  (Draw simply  call  it  Curve)  and 
draw the curve in the order indicated both in the figure and in the list 
that  follows  it,  paying attention to  when it  is  needed to  “hold”  the 
mouse button:
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1. One click,  without releasing the mouse button, where we want 
the first point of the curve.

2. Move the mouse in the direction of the  next control of that 
first point and release the button.

3. Click, again without releasing the mouse button, at the next 
point on the curve.

4. Move  the  mouse  backwards in  the  direction of  the  previous 
control of that second point and release the button.

5. Repeat points 3 and 4 until the curve is complete.

6. A double click on the last point of the curve, or at the starting 
point, will terminate the process (in the latter case the curve 
will be closed).
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Starting with the second point, the next control is not specified. This 
control is automatically placed by Draw in the exact opposite direction 
to the previous control.

Playing with the toolbar  Edit points (it is activated and deactivated 
with F8 or with the corresponding button in the Standard toolbar) it is 
possible to add, remove, move points, cut and “break” the curve, sepa-
rating the behavior of the  previous and next inclination controls, thus 
creating angles.

The toolbar Edit points is contextual, so if you do not select an ob-
ject it will not appear even when activated.

14.3 Organization and alignment of objects
When we have two or more overlapping objects we can decide which 
one is above the other, in such a way that the “order” between them be-
comes clear.

With a right click on an object ▶ Arrange  we can choose to “bring 
forwards” or “backwards” the selected object with respect to the other 
objects in the drawing, or even send it directly in top or behind of all  
other objects.

The  Align options are just as simple: center horizontally or verti-
cally, align left or right, up or down… 

An interesting option also appears when three or more objects are 
selected:  Distribution. This option distributes the selected objects with 
respect to the position of the most external ones. This tool is simpler to 
use than to explain, so I let you explore it.

14.4 Working with “Layers”
Surely you have noticed in the lower part of the edit area of Draw that  
there are three “tabs,” called Layout, Controls and Dimension Lines.

Each one of these tabs (you can add more by clicking on the bar that 
contains them) serves to “classify” the objects inserted in the document 
in different “categories,” which allows us to quickly modify some of its 
characteristics.
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For an element to belong to a given layer, it is enough to select the  
corresponding layer before inserting it or to “cut” the object previously 
inserted in one layer and paste it in the corresponding layer.

The advantages of using layers are several. On the one hand, if we 
right click on the layer ▶ Modify Layer  we can choose if the elements 
of that layer are visible or not (for example, to hide some part of the 
drawing) or even if the elements of that layer should be printed or not. 

This is useful, for example, if we use some simple figures as a guides 
to develop the drawing, but we do not want those guides to be printed 
or exported to PDF: we group these guiding figures in a certain layer 
and then edit  the properties of that layer so it does not print. Also,  
from the menu that results from selecting Modify Layer it is possible to 
“protect” a layer in order to prevent it from being modified acciden-
tally while working with other objects.

From the point of view of the work area and unless one of them is 
protected against modifications, it does not matter which layer the ob-
ject is in or which layer is selected for editing: it is possible to move 
and modify the objects independently of the layer in which they are or 
from the layer that we are looking at.

Now, the question could arise, after a long day of making diagrams, 
to which layer a particular element belongs.

The answer is simple, but not so obvious: it is necessary to select the 
object and look in the Draw status bar… next to the slide number! The 
name of the layer is shown there inside round brackets.

14.5 Groups of objects and operations be-
tween objects
By selecting several objects it is possible to “group them” by right click  
on the selection ▶ Group : in this way the objects will remain together 
avoiding accidental modifications.

Just below the Group option we have other interesting options un-
der the Shapes sub-menu: combine, connect, merge, subtract, intersect. The 
effect of these options can be seen in the  Figure 14.2.
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As the example shows, the result of these operations may depend on 
the order in which the objects are found… not to mention that in some 
cases something strange is obtained: the connect option, for instance… 
what the heck is doing?

Also in the Forms menu, but not mentioned in the figure, we have 
the possibility to match the width or height of the selected objects.
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14.6 Color substitution in images and other 
special effects
Draw is not a tool for editing bitmaps but a vector drawing program, 
but it still provides several  masks to produce simple effects in the in-
serted images.

When we select a bitmap picture, in the Image section of the Proper-
ties tab of the sidebar we can change the brightness, the contrast, the 
color balance, the transparency or even turn the image into gray-scale,  
black and white or watermark (Color mode).  These tasks can also be 
done from the toolbar called Image, which also allows the application 
of “filters” to the image to give it some “special effect” (someone might 
like them) such as inverting colors, solarization, tiling, smoothing, wa-
termark… Many of these options open a dialog box to configure the in-
tensity of the effect.

Another interesting tool is that of substitution of colors, with which 
it is possible to “replace” one color with another. This tool is available 
from Tools ▶ Color Replacer .

Keep in mind that these tools do not modify the original image, they 
simply apply “masks” on it so the results will not be perfect: programs 
such as gimp, krita, mypaint, etc. are more suitable for the task of edit-
ing images.

Another useful tool is that of “cropping” an image: both with the 
button called Crop Image in the standard toolbar and with a right click  
▶ Crop , you have a tool to quickly “trim” an image using the mouse. 
Again, it must be keep in mind that this tool does not cut the image “for 
real,” but it “hides” the part that we are “cutting:” the original, complete 
image is still there so if we then select again the cropping tool and “ex-
tend” the selection we will recover the non-visible part.

14.7 The gallery
This  simple  tool  is  used  to  catalog  images  and sounds,  allowing  to 
quickly insert any element in any document. It is enough to select a  
category from the top list and drag one of the images from the list be-
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low to the document.
It is also possible to add new images to the gallery by performing 

the inverse process, that is, dragging and dropping the images to the 
gallery, either from a document or from the file browser.

It is important to note that the predefined categories, being part of  
the installation of the program, can not be modified. So, in order to add 
more objects to your gallery, you need to create new themes by simply 
pressing the New Theme button at the top of the gallery.

On the extensions page there are packages with more image gal-
leries to add to our program.

14.8 Various tips
• Tools ▶ Options ▶ LibreOffice Draw ▶ Grid : change the reso-

lution, horizontal and vertical, to something like 0,01 cm.

• Page ▶ Properties :  use  the  same page format and the same 
margins that will be used in the Writer document, since this 
way we will avoid the problems that could arise when resizing 
the resulting diagram.

• Always  group  the  objects  when  the  drawing  is  finished,  to 
avoid unwanted changes.

• When grouping,  make  sure  that  all  elements  have  been  se-
lected: especially if the mouse has been used the object will not 
be selected unless all of it is in the selection area.

• Never modify the drawings in Writer: although it may seem sim-
pler it is always better to work in the original Draw document 
and re-copy and paste the new result.

• The objects in Draw are also guided by styles: by editing the 
“Default” style,  the default options for line thickness,  colors, 
and so on can be modified. The procedure to create a new de-
fault template for Draw is exactly the same as in Writer.

• When you “paste” a drawing created with Draw in Writer, you 
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should  take  into  account  the  possibility  of  doing  a  “special 
paste” ( Edit ▶ Paste special  or  CtrlShiftV) to use an image 
format instead of inserting the drawing as “Draw object” since 
if the diagram we copy is very complex we could have perfor-
mance problems in Writer: the program could become slow 
when going through the page in which the object is. “Graphic 
Device Interface Metafile (GDI)” is a high-quality vector image 
format that generally gives very good results.

•  It is possible to use the Navigator to locate objects in a Draw 
document, but only if the object has a “name:” 

Bug 62851 -  UI: Shapes without name cannot be selected via  
Navigator.



Draw  has  many  more  tools  than  those  described  here,  but  talking 
about all of them is something that is beyond the scope of this short in-
troduction. This book, after all, is about Writer.

I hope, though, that these few pages will serve as an initial push that  
gives you the chance to discover without problems everything else.
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Chapter 15

Math

In the previous chapter we talked about how to create vector drawings 
with Draw and in the next on how to represent data graphically. In this 
chapter we will explain how to create mathematical expressions using 
the Math component… and other things that we will talk about at the  
end of this chapter.

Insert ▶ Object ▶ Formula  creates a Math object in Writer, ready 
to accept our formulas.

Math works differently to the equation editors of other packages: 
although we have drop-down menus and buttons to select what is nec-
essary, Math is basically a simple text editor where we have to write in-
structions that will be interpreted by the program.

But not be afraid, that after using it a bit this method of construct-
ing the equations in “text mode” (a method that will not surprise any-
one who comes from  ) is more than welcome since with it you 
can work much more quickly than in a system based in menus, espe-
cially in complex expressions that require many “nested” elements.

Math  is  a  correct,  quite  flexible  tool  to  write  relatively  complex 
equations with little  effort.  But  Math also has  serious limitations:  it 
does not know about styles, so beyond the default settings that apply to 
all new objects, the configuration must be made object by object; the 
default configuration is not “retroactive” so if we change something the 
old objects will not be updated, it can not be included in text boxes 
when working in Draw… in short, several problems.
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But in any case you can work, so here I will show some tips to alle-
viate their problems.

Of course,  always use the right tool for each job,  so if you must 
write a thesis on physics or mathematics   (especially if  you use 

) will be a better choice. We will return to this at the end of the 
chapter.

15.1 General concepts about Math
The vast majority of Math instructions are really simple and do not 
need further  explanations,  so  in  this  chapter  I  will  only  talk  about 
those concepts that tend to be more “complicated” for new users. You 
will see, therefore, that some of the examples below will show elements 
not defined in this text, but this will not necessarily be an oversight on 
my part but rather an invitation to review the corresponding docu-
mentation.

By right clicking on the Math editing area you find a drop-down 
menu that shows, perfectly organized, the main functions. This is ex-
tremely useful for users who are just starting to use the program be-
cause it gives a quick reference on how to build the desired expression.

15.2 Entering simple text
There are combinations of letters and / or symbols that are used by 
Math for special purposes that we will see below.

For example, “sum” is used to insert a summation and “int” for an 
integral. The % symbol is used to indicate other symbols:  %alpha in 
Math will insert α. Now, what happens if we want to enter those text 
strings or those symbols?

The simplest way to insert “pure text” is to use the double quotes: 
"%" will insert the % symbol while  "sum" will insert the text “sum” 
without converting them into a summation.

This can also be used so that the entered text is not considered as 
“variable” and does not pass into italics.

And if you want to insert the double quotes? We could for example 
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need to write something like 3º2"1'… 
Beyond adding a new symbol to Math (below we will see how to do 

that) the simplest way is to wrap two single quotes with a pair of dou-
ble quotes: 2 "''".

Single quotes are also best viewed by inserting them as pure text.
Double quotes can be used to insert spaces in expressions by typing 

" ", but there are other ways to do that: with the symbol  ` we get a 
“small space” while with ~ we get a “normal” space.

15.3 Operators and relations
If in the Math editor we simply write an equal sign with nothing to its 
sides,  Math will  give us a red question mark. The same will  happen 
with any other relation (<, <=, etc.). If we write sum to enter a summa-
tion (or  int for an integral, or…), but we do not put anything after 
that, a question mark will also appear. The same if we write to a^ with-
out defining the exponent.

The reason for this is that both the relationships (=, +, -, <, etc.) and 
the operators (sum,  int,  lim, etc.) need  arguments: it does not make 
sense to write an equal sign with nothing on both sides that is equaling,  
or a summation sign without the general term to add.

Now, if we need to insert a “+” sign as an exponent to indicate, for  
example, a sodium atom that has lost an electron, it will be enough to 
use the double quotes:

"Na"^"+" 

will give us Na+.
We could also get the same effect by using a pair of double quotes 

enclosing “nothing:” a = "".
Some operators accept “attributes.” For example, the  from and to 

statements can be used to set “limits” as in the following code:

sum from {n=1} to infty a_n 

which will give ∑
n=1

∞

an .
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It  is  possible to define our own “temporary” operators  using the 
oper and boper instructions with any character. Test what happens 
with: oper P from {n=1} to infty Q_n.

15.4 Groups and brackets
Sometimes it is necessary to “group” terms since 

1 over a + b 

will give 1
a

+b  instead of 
1
a+b

.

The way to group terms in Math is to use the “braces” { }: for ex-
ample, by typing

1 over { a + b }

It is important that the groups are “closed:” if we write only one of 
the braces Math will protest.

The same happens with any other kind of bracket: they need to be 
in pairs.

Inserting any kind of opening bracket Math will automatically in-
sert the closing one, leaving a couple of spaces in between waiting for 
content.

The best way to build brackets is to use the  left and  right in-
structions, which allow the brackets to automatically “grow” if needed. 

Compare for example the result of using the following expressions: 
( a over b ) against left ( a over b right ).

There is a problem with this when the brackets “grow too much”

Bug 32362 - Bad behavior of scalable brackets with large objects

The instructions  lbrace and rbrace stand for the left and right 
braces, respectively: left lbrace a over b right rbrace.

Now, what if we want only one of the brackets? The none instruc-
tion comes to the rescue:
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left ( a over b right none 

will gives us (
a
b

.

15.5 Sizes, colors and line breaks

15.5.1 Size
It can be controlled with the size instruction.

There are two ways to use this expression: providing the absolute 
size in points or a relative size with respect to the predefined font size.  
For example, if the predefined font size for Math objects is 12 points, 
the expressions

size 18 {expression}
size *1,5 {expression}

give the same result, since 18 is 1.5 times larger than 12.

15.5.2 Colors
It is possible to change the color of a Math expression, or only a part of 
it, using the color instruction in this way:

color <the color> {expression}

The color list is wide, but limited. The best way to select colors is to 
use the panel with the Math instructions, selecting the Attributes menu 
entry.

15.5.3 Line breaks
They are done with an instruction called newline. This instruction in-
serts a line break allowing the construction of “multi-line” expressions.

It  must  be  keep in mind that  newline does  not  get  along with 
brackets or other things that need to be “closed” like quotes, groups or 
the recently discussed size and color instructions. That is, to build 
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an expression that needs only an opening bracket in the first line and 
only one closing in the second, we must create it in this way:

left ( "first line" right none
newline
left none "second line" right )

whereas if the  size and color instructions are used they will be 
valid only for the line where they have been inserted.

15.6 “Strange” formatting
The exponents can be introduced with the caret while the subscripts 
with the underscore. It is also possible to insert “pre” sub- and super-
scripts by using the  lsub and  lsup instructions,  as well  as up and 
down indexes with csup and csub.

We can introduce matrices in Math using matrix:

matrix{a # b ## c # d}

As can be seen in the example, the single hash separates columns 
while the double hash separates rows.

Another useful construction is  stack,  which works as a column 
matrix:

stack{a # b # c}

To talk about numbers we have the instructions setN, setZ, setQ, 
setR, setC.

The  option,  within  Math,  that  is  activated  with  Format  ▶ Text  

Mode  can be used to pass from 1
a

+b , useful for expressions that are in 

their own paragraph, to 1a +b , that look better in the middle of the text.

15.7 Different attributes
An example is worth more than a thousand explanations, so I invite 
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you to see what happens with:  phantom,  bold,  italic,  nitalic. 
Next, a “harder” case:

vec a cdot vec b = a_x b_x + a_y b_y 
newline
alignl phantom { vec a cdot vec b } =
abs{ vec a } abs{ vec b } cos %alpha

gives us a⃗⋅⃗b=ax bx+ay by
=|⃗a||⃗b|cosα

.

15.8 Change the default fonts in Math objects
The menu that opens when from a Math object is selected Format ▶  
Fonts  is quite “tricky:” the drop-down menus available for each type 
of font (Variables, Functions, Numbers, text…) only offer the name of the  
font used at the moment.

To modify these fonts it is necessary to select the category to be 
changed with the drop-down list of the Modify button: only this way a 
menu will be presented with the selection of the font and its attributes 
(bold, italic).

After making the changes, do not forget to press the Default button, 
otherwise the changes will only apply to that Math object.

The menu that appears when selecting Format ▶ Font Size  is sim-
pler and does not need further explanations.

Of course, at the end remember to also press the Default button.
As we have said before, this configuration will not change previ-

ously created objects, it will be necessary to modify them one by one.
There is a report asking to add to Math the ability to take the font  

size of the base paragraph:

Bug 32419 - When inserted on Writer, get "Base size" for formulas  
from underlining paragraph

Math objects are not based on styles, so if it is necessary to use dif-
ferent fonts in different documents, everything must be changed each 
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time the document is changed.
Something that can not be changed is the font used by Math to cre-

ate the symbols: it is OpenSymbol or nothing.
Well, almost: there is a “dirty trick” to choose another mathematical 

font. First of all we must select a font that has the OpenType Math1 ta-
ble, such as Libertinus Math, garamond-math, STIX Two Math, etc..  
Then, in  Tools ▶ Options ▶ LibreOffice ▶ Fonts  we have to activate 
Apply replacement table. Done this, in the upper part we select, on the 
left, OpenSymbol, and on the right the font with which we are going to 
replace it, for example Libertinus Math. Finally, we apply the substitu-
tion, check the boxes  Always and Screen only and press  OK: the Math 
objects will begin to use the chosen font.

Keep in mind, however, that there could be alignment problems of 
the  different  elements  of  the  equation,  so  try  beforehand  if  this  is 
something you really want to do.

15.9 Add new symbols to Math
The number  of  “special  symbols”  predefined in  Math is  not  exactly 
“large,” so it may be necessary to define new ones.

It should be noted, though, that the Math editor supports Unicode 
without problems, so if a certain symbol is present in the font used by 
Math to represent text (and we do not have to enter it many times) it is 
enough to enter it first in Writer,  copy it and then paste it  into the 
Math editor. We can also insert any special character if we know its 
Unicode code, as we discussed in the section 3.5.2.

There is a report asking to add to Math an optional a menu to insert  
symbols: 

Bug 32418 - Add an "insert symbol" to Math.

If a certain symbol is really necessary, these options may not be so 
comfortable, so it is convenient to define a new symbol. For this you 
only have to open (or create) a Math object, go to Tools ▶ Symbols , se-

1 No relation to the subject of this chapter.
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lect any symbol and click on the Edit button.
What we are interested in here are the drop-down menus that are 

below the symbol table:

1. Forget for a moment that these drop-down menus are drop-
down menus, delete whatever it is next to  Symbol and write 
the name of the new symbol (for example, MySymbol).

2. Recall  again  that  these  drop-down  menus  are  drop-down 
menus and select a font that contains the symbol you need, the 
subset  of  that  font  in  which  the  symbol  is  located  and,  of 
course, select the symbol from the table.

3. If necessary and the font allows it, select the Style for the sym-
bol (normal, bold, italic, bold-italic).

4. Optionally, it is possible to define a new Symbol set to collect 
all the new symbols.

5. At this point we must review chosen name for the new sym-
bol, which is sometimes replaced by Math without warning by 
its Unicode code… oh well. Finally, click on Add and then on 
OK.

Done. Now you can use the new symbol in any equation by typing 
%MySymbol.

15.10 Spacing and alignment for Math objects 
in Writer

15.10.1 Spacing
With the  default  configuration,  Math objects  are  inserted  in  Writer 
with large spaces before and after them. To eliminate these spaces for-
ever (or, at least, in new objects), it is necessary to follow two simple 
steps:
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• In  the  styles  and  formatting  editor,  go  to  the  Frame  Styles 
(third button from left to right). There you must modify the 
frame style called Formula ( right click ▶ Modify ). In the Wrap 
tab, change the left and right spacing to zero. Finally, save the 
document as the default template.

• Open (or create) a Math object and go to Format ▶ Spacing . In 
the Category menu select Borders and change the left and right 
borders to zero or, at least, to something smaller. Finally, press 
the Default button.

15.10.2 Alignment
In Tools ▶ Options ▶ LibreOffice Writer ▶ Formatting Aids  you have 
an option called  Math baseline alignment that activates the automatic 
vertical alignment of Math objects according to a “baseline.”

It must be taken into account that this option is only used by default 
in new documents: if a document created with a version 3.x where this 
option did not  exist  is  opened,  the only  way to correct the  vertical 
alignment is by selecting the object (a click on it) and using Alt ↑ or 
↓… or by going to the commented menu and activating the option so 
Writer can do the work for us.

With this option enabled it is not be possible to move Math objects 
manually… but neither will it be necessary to do so.

15.10.3 “Internal” spacing
Math automatically includes spaces between different elements of the 
same equation. 

Although this is usually correct in most situations, when two con-
secutive elements with different “attributes” are introduced (italics one 
and not the other, for example), the extra space that appears between 
them can produce an unpleasant effect.

This problem is corrected (in part) with the use of the nospace in-
struction.
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15.11 “Almost graphical” edition
A small and well-kept secret of Math to close this chapter: if we are in-
side the editor and we click on an element in the “graphical” equation 
(the one that is being built automatically while we write the code) the 
cursor will go directly to the corresponding position in the code that 
represents the selected element, which will be “marked” in the graphic 
part with a dotted line rectangle.

This is extremely convenient when editing complex equations since 
us a way to immediately locate the part of the code we need.

15.12 Alternative to Math
When writing mathematical expressions, nothing can surpass  or 
any of its derivatives such as . 

But using those systems does not necessarily mean giving up Writer 
since  with  the  TexMaths  extension  it  is  possible  to  include  /

 expressions in Writer documents:

http://roland65.free.fr/texmaths/install.html 

In fact, I used this extension to write the “logos” of ,  in this 
document.

The extension comes with a toolbar that makes it easy to work with 
numbed equations, modify all the expressions of a document, and so 
on.

Talking about how to use this extension would take us too far from 
the content of this book, so I’ll just say that you need to install a recent 
version of   (TeXLive 2017 or equivalent) plus some other extra 
packages like dvisvgm.

For more information, check 

https://frommindtotype.wordpress.com/2018/06/11/writer-
xetex-texmaths/

Anyone interested in the possibilities of / , can check my 
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book about :

https://frommindtotype.wordpress.com/lyx-book/ 
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Chapter 16

Chart

We have already seen in  12.2 how to insert tables and format them. 
However, in many documents this is not enough and the data of those 
tables must be shown in graphic format. 

In this chapter we will see how to do this, either using the tools of  
LibO or external programs. 

16.1 Create a graphic directly from Writer
Insert ▶ Chart  creates, through the Chart component of LibO, a col-
orful bar graph at the point where we had the cursor, which is an ex-
ample that can be edited without problems both to change its type and 
to modify the displayed data.

With a double click on the inserted graphic it is possible to access 
the tools to change it according to our needs.

With View ▶ Data Table  (or with the corresponding button on the 
Format toolbar) we are presented with a simple window where it  is 
possible to modify the values of the table used to build this sample dia-
gram that we have just inserted.

As you can see it is possible to have text entries to classify the data, 
add or remove rows and columns, and so on.

The buttons in the upper part of the window have the following 
functions:
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1. Insert Row

2. Insert Series (data columns)

3. Insert Text Column (to classify the data)

4. Delete Row

5. Delete Series

6. Move Series Left

7. Move Series Right

8. Move Row Up

9. Move Row Down

By leaving some empty text entries we can “group” columns of data.
But suppose we are not interested in a traditional histogram but we 

want another type of graph, be it another type of histogram, cake dia-
gram or the more traditional scatter plots. If before going to modify 
the data we go to  Format ▶ Chart Type  we can modify the type of 
graph.

There is not much that can be said about this dialogue: selecting the 
type of graphic on the left we have several options to choose from, the 
possibility of activating “3D effects”… the dialogue is simple to use and 
it is simpler to experiment with the options that read arid descriptions  
of them, so I leave you the task of exploring the possibilities.

What is important to note is that unless the XY (Scatter) type is cho-
sen,  the  “categories”  will  still  be  taken as  text  even if  we only  have 
numbers in them. In fact: if we want a traditional plot where the values 
of X represent true numbers and not just uniformly spaced labels we 
must select “XY (Scatter).”

By selecting the different elements of  the graph, such as its  axes, 
points, etc. it is possible to access a menu to modify their properties 
thanks to the options presented by the sidebar.

From the Insert menu it is possible to add a title to the chart, decide 
where in the chart the legend that identifies the data series should (or 
should not) be placed, change the colors of the data series, and so on.
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If we want to add error bars to our scatter chart we must go to the  
menu Insert ▶ X [Y] Error bars . By selecting there  From Data Table, 
when we return to the menu View ▶ Data Table  we will find that for 
each data series two columns that represent the error up and down 
each point where added.

16.2 Create the graph from an existing table 
in Writer
If our document already contains a table with the data that we want to 
represent, the process is somewhat more “direct.”

Selecting the part of the table that interests us (only a few columns 
or all of it) we have to go to Insert ▶ Chart  to see a chart with our data 
appear along with a “wizard” that will guide us to through its configu-
ration.

In  the  second  step,  Choose  a  Data  Range,  we  have  the  options, 
marked by default, First row as label and First column as label. These op-
tions cause the first row and the first column of the table to be ignored 
when making the graph, so if instead of labels they are valid data, you 
must uncheck those options.

The other options are clear so they do not need further explanation.
It is important to note that the chart thus constructed will be dy-

namically associated with the source table, so any change in the value 
of the table will be reflected in the diagram when we double click on 
the chart to update it.

16.3 Build the chart in Calc
The main advantage of working first in Calc is the ease of manipulating 
the data we want to represent: the tables in Writer are useful to  show 
the data, but to  operate with them it is better to use a dedicated tool 
such as Calc.

I do not intend to talk about the spreadsheet here (nor could I do it), 
but it is clear that in Calc it is not only easier to insert the data but 
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mainly to operate with them, perform calculations, modify them, and 
so on.

In addition, by creating the graph in Calc we have the same assis-
tant of  which we have previously spoken so the process is  virtually 
identical.

Finished the graph in Calc we have to return to the spreadsheet, se-
lect the graph with just one click, copy it and paste in Writer.

It is convenient to save the Calc document for any possible subse-
quent modification that is necessary, in this way we will only have to 
copy and paste again.

It might be convenient, instead of doing a “normal paste,” to paste  
as “Graphic Device Interface Metafile (GDI),” that is, not as a Calc  
object but as an image.

16.4 Charts generated in external programs
The safest way to include charts made in external programs is to create 
an image from them, preferably in SVG format, and save it to disk be-
fore including it in Writer from Insert ▶ Image .

It is better to avoid copying and pasting directly from other pro-
grams because the presence of these programs might be necessary in 
order to see the file and print it, which would make it impossible to 
take the file to another systems.
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Chapter 17

Master documents

When a long and complex document is built, especially if it contains a 
large number of figures, tables and objects it might not be convenient 
to entrust everything to a single file: on the one hand, working with 
several smaller files instead of a single giant one improves the perfor-
mance of the program while on the other hand it minimizes the risk of 
information loss when something “goes wrong” (system crashes, power 
interruption… things that can lead to corruption of the file in which 
we are working).

We could also be working in collaboration with other authors, each 
one carrying out a particular chapter, so synchronizing the entire file 
among all authors, all the time would not be practical.

Solution?
A Master document is a powerful tool to work on a single project di-

vided into several files, while maintaining the coherence between its 
parts.

17.1 Starting from the same base
First  of  all,  let’s  define a template with all  the styles of  paragraph / 
character / page / etc, necessary for our document as we have seen in 
previous chapters.

To avoid conflicts and possible problems, we will build our master 
document and the sub-documents that will give it content from the 
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same template.
We must now create a new document from our template. Without 

writing anything in this new document we go to File ▶ Send ▶ Create  
Master Document : a dialog box will open asking where to save the 
master document.

In  the  dialog  to  save  the  master  document  we  have  the  option 
“Styles.” This option is useful when we are creating a master document 
not from an empty file but from an existing document with several 
headings in our outline: selecting an outline level as a separator, sub-
documents will also be created by separating the content in each of the 
headings with the chosen outline level.

Once the odm document is saved, we can close the empty docu-
ment from which we originated it without saving: it will not be neces-
sary.

The next step is  to create,  from the same template,  one or several 
documents with the content of the project. It is possible, for example, 
to create a file for each chapter.

The sub-documents can not be edited from the master document, 
they must be edited independently as normal documents. The master 
document is a “container” that serves to organize and print the docu-
ment as a whole.

When opening Writer in “master document” mode, the sidebar may 
be closed and the Navigator may appear as a floating window. I think 
that by now you know how to work with all this.

Let’s open the master document. If it is not open, start the Naviga-
tor, which will open in “master document mode.”

The first button on the left (Toggle Master View) toggle between the 
Navigator for master documents and the “traditional” Navigator.

 We will see the two buttons that follow as they are necessary.
The fourth button is a menu to insert things: by clicking on it with-

out releasing the mouse button we find three options, namely

• Index

• File

• New Document
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The first option is  clear (insert a table of  contents that show the 
contents of the entire document).

I do not recommend the use of the third option, especially to new 
users of this feature, as it can be confusing.

The second option is used to insert the sub-documents that we have 
created independently. Keep in mind that the sub-documents are in-
serted above the selected entry in the list, so you will always have to re-
order the sub-documents using the sixth (Move Up) and seventh (Move  
Down) Navigator buttons.

After inserting a pair of sub-documents, a new option called  Text 
appears in the Insert menu of the Navigator. With this option it is pos-
sible to insert text between two sub-documents that is contained in the 
master document. This option can be used to separate chapters, to in-
sert the copyright page, and so on.

With a double click on the name of the document displayed in the 
Navigator, this document will open to be edited.

Another way to edit a sub-document is to select the document from 
the list and click on the second button of the Navigator: Edit.

17.2 Cross-references
Suppose we want to refer to a section in a sub-document from another 
sub-document (we have talked about cross references in the  Chapter
13). 

In the document we want to “call” we must select the text we want 
to refer to, go to Insert ▶ Fields ▶ More fields ▶ Cross References tab , 
select  Set Reference and give a  Name before clicking  Insert.  Now we 
must go to the document from which we want to call the reference. 
Let’s go back to Insert ▶ Fields ▶ More fields ▶ Cross References tab , 
but this time select  Insert  Reference:  in the  Name field let’s write the 
name we have used in the other document and disregard the error 
message that appears when we click Insert (Error: Reference source not  
found)  since  in  the  master  document  everything  will  appear  as  it  
should.
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What we want to refer to may be not only the text of a chapter  
heading, it may also be a variable such as the number of a figure,  
any text such as a particular paragraph or a footnote, etc..

It is convenient to create a document (for example, in Calc) with the 
list of all the references that we have defined so far to keep track of  
them, in this way our work will be simpler.

To update the master document we can use the third button of the 
Navigator, also this one a menu (Update), selecting the option All and 
accepting the option to update all the links.

Each time the master document is opened, the question of whether  
we want to update all the links will appear: we must say yes, oth-
erwise the contents of the sub-documents will not be displayed.

17.3 Possible problems
We have already mentioned that although in the sub-documents the 
cross-reference fields give an error, in the master document everything 
will be displayed correctly. This will inevitably cause the distribution of 
text to be different in both, so we should not trust the distribution we 
see in the sub-document: it could be different when we move to the 
master document.

Other fields will also influence the content distribution of the docu-
ment: if for example we use the same variable to number figures in all  
the sub-documents and unless we say otherwise, the numbering in the 
Master will be continuous. For example, the first figure (figure 1) of 
sub-document 25 could be figure 114 of the complete document… and 
certainly 114 will take more space than 1, affecting the distribution of 
the content.

I have also noticed some problems when the sub-documents have 
large images that occupy more than half of the page, for example: blank 
pages that should not be there may appear in the master document be-
fore the images. Usually this is solved by updating the master docu-
ment a couple of times in a row, or even saving, closing and reopening.

Don’t ask…
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It should be kept in mind that the definition of the styles in the mas-
ter document takes precedence over those of the sub-documents: if we 
change a style in the sub-document this change will not be seen in the 
style of the same name in the master document.

On the other hand, if we create a new style in a sub-document it 
will be imported into the master… but it will not be available in the 
other sub-documents.

It is therefore convenient if we want to change a style to directly 
edit the corresponding template and accept changes when we reopen 
the documents based on it.

Important! Do not anchor images or objects “to  page” in the sub-
documents: since the master document “imposes” on the sub-docu-
ments there could be problems (what is a clear page 3 in the sub-
document could be page 50 in the master document), as for exam-
ple that the image does not appear when combining the document.  
It is better to anchor the objects “to paragraph,” “to character” or  
“as a character.”

17.4 Reunify everything
For different reasons it may be necessary to unify all the sub-document 
into a single “real” document. The simplest way to do so is the follow-
ing:

1. From the master document with all the links updated, go to 
Format ▶ Sections .

2. One by one, select the sections and press Remove.

3. Go to File ▶ Export  and select ODF Text Document (.odt) as file 
format, select a name and Save.

4. If we want to keep the original master document too, close it 
WITHOUT saving the changes.

The odt document thus created will have all the contents of the sub-
documents. Some minor format adjustments may be necessary.
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Activating the fifth button of the Navigator,  Writer will  save a  
copy of the sub-documents within the master document, but this is  
not the same as unifying everything because if the sub-document is  
changed the master document will be updated: here we are creating  
a new document, independent of the original.

17.5 When to use master documents
Master documents are almost indispensable when working collabora-
tively: each of the collaborators builds their part and then an “editor” 
creates a master document that gathers everything.

Now, are the master documents also useful when you have only one 
author?

This is not a simple question to answer. As we have seen, the master  
document involves a little more work with cross-references and can 
cause some headaches when you have many objects or images.

If the document is pure text, Writer can handle hundreds of pages 
without problems so in this case the master document does not offer 
many advantages. Even if there are many images that could affect the 
performance of the program, the option of linking them (see  3.7) in-
stead of embedding them in the document could even make it more ag-
ile.

For the rest… everyone should evaluate it for themselves.
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Chapter 18

Search and replace, the 
regular expressions

In addition to the simplified Find toolbar (CtrlF) that can be used to 
quickly find short strings of simple text, LibO offers a powerful tool for 
finding complex texts not only through the text itself, but also its for-
mat and its structure.

The tool that is presented when pressing  CtrlH or when using 
the menu Edit ▶ Find & Replace  offers, under Other options, tools to 
search by styles, to perform searches “by similarity” where the text we 
are looking for is not exactly the same as the searched one (characters 
exchanged or added), a tool to search inside the notes or also look for 
groups of words that have a certain attribute or format.

Of all these options, in this chapter I will only speak of the most 
“complicated” one, a tool that is extremely powerful, but at the same 
time somewhat difficult to tame: the advanced search of text through 
regular expressions.

Since I can not consider myself an expert on the subject I will try in 
this chapter to give only an introduction so that the reader can take 
their first steps in something that, well used, is an important ally for 
the edition of complex texts.
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18.1 What are regular expressions
We have all used, and more than once, the (in?)famous asterisk to find a 
specific file: writing *.odt in the file search engine of our system we ob-
tain all  the  odt  files  that  we have in the directory in which we are  
searching. Here the asterisk works as a “wildcard” that tells the system 
“hey, I am looking for all the files that have any name, but end with 
the .odt extension.”

Well, regular expressions are an extension (to infinity) of this idea.
Let’s suppose that we have a long text which is mixed with numbers 

(integers) scattered all over the document and that for some reason1 we 
want to select all the text but leaving aside the numbers, how can we do 
that?

Open the full search tool with CtrlH, click in Other options and 
check Regular expressions. Now, in Find we write our first regular ex-
pression:

(([^[0-9]]*)*)

If now we start clicking on the different “Find” buttons (Find All, 
Find Previous, Find Next), we can see how the text that does not contain 
numbers is selected.

Well, now that we know what regular expressions are for, let’s see 
how they are used.

Regular expressions can be combined with the search of Attributes 
and Format or with search in Comments, but not with the search  
by similarity or the search of styles.

18.2 Special signs
One of the biggest difficulties of regular expressions is that they are full 
of signs whose meaning changes according to the context.

Let’s take an example. The ^ by itself serves to locate things at the 

1 If you have read my book on  you already know that I am more inter-
ested in the examples being clear, not in if they are realistic.
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beginning of a paragraph. Typing  

^un 

in “Find” those two characters will be selected only if they are at the  
beginning of a paragraph while they will be ignored in any other posi-
tion.

On the other hand, the same expression in square brackets

[^un]

means “a character different from u or n:” if anywhere in the text 
we have the word “universe” and use the regular expression [^un] in 
“Find,” the search tool will ignore the “un” and stop at the “i,” in “utility”  
will ignore the “u” to stop in the “t”, in “note” it will ignore the “n”…

The square brackets, in addition to being used to create “negations”  
like in the previous example, also serve to indicate character ranges. 
For example

[0-7]

indicates any digit from zero to seven.
With all this our first regular expression begins to make sense:

[^[0-9]]

represents any character that is not a number.
On the other hand, the asterisk is used to represent an arbitrary 

number of  characters  equal  to the  previous  one:  a* will  find a,  aa, 
aaa… etc., but will also find  zero instances of that character:  cr*azy 
will find crazy, crrazy, crrrrrrrrrazy… but also cazy.  Clearly, the aster-
isk must be used with care. 

Round brackets are used to “group” expressions. We will talk about 
that below.

At  this  point  our  original  regular  expression  results  completely 
clear:  it  looks  for  an  arbitrary  number  of  characters  different from 
numbers.
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18.2.1 The dot .
It can be used to indicate a generic character. For example

m.s

will look for mas, más, mis… even mXs. An expression equivalent 
to the dot is

[:any:]

18.2.2 The question mark ?
It serves to find “zero or one instances” of the preceding character. For  
example

places?

Will find place and places.

18.2.3 The plus +
Similar to the asterisk, it serves to indicate one or more instances of the 
preceding character.

18.2.4 The braces {}
They can be used to indicate how many repetitions we need. For exam-
ple

a{1,4}y!

Will find a minimum of one and a maximum of four repetitions of 
the “a” and therefore it will find ay!, aay!, aaay!, aaaay! If we put a single 
number the program will search for exactly that number of repetitions, 
for  example  a{3}y! will  only  give  us  aaay!  Finally,  the  expression 
a{3,}y! will find at least three instances of the a, but without a maxi-
mum limit.
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18.2.5 The dollar sign $
Just as  ^ looks for the beginning, the dollar sign  $ preceded by some 
text will look for that text at the end of a paragraph.

The $ sign by itself can be used to find paragraph breaks, but it is  
important to note that it is not possible to search for text at the end of 
the paragraph plus the paragraph break. For example, the expression

\.$

will find a dot at the end of the paragraph and select it, but you can 
not select the paragraph break itself.

Regular expressions only work within a paragraph.

In the “Replace” box  $ has another meaning that we will see later 
when talking about groups and references.

18.2.6 The backslash \
The backslash can be used to say that characters with a special meaning 
should be treated as normal characters: if we want to look for the signs 
. ^ $ * + ? \ [ ( { | as if they there normal characters, we must put a back -
slash before them (exactly:  to search for a \ we must write \\).

But this same backslash can be used to say that some normal char-
acter now act as special ones: \b searches the “boundaries” of a word. 
For example

\bjus

will find the “jus” in just, justice, justly… but not in adjust while

our\b

will find not only the word  our,  but also the “our” in hour, flour, 
pour… but not the one in hourly.

Clearly punctuation marks or any kind of brackets are not consid-
ered part of a word, so the expression our\b will also find the “our” in 
“this is the hour!”
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Speaking of words,  the expression  \w will  search for an element 
withing a word (a character).

\t searchs for a  Tab. We must bear in mind that  \tabular does 
not look for the word tabular, but for a Tab followed by “abular.”

\n has a double meaning; in Find finds line breaks (ShiftEnter), while 
in  Replace introduces a paragraph break. Yes, those that are searched 
with $… I know, it’s weird…

18.2.7 The vertical bar |
Used in square brackets, it serves to “choose” between options. For ex-
ample

bar[r|c]a

finds barra and barca, but not barza. It can be used more than once 
in expressions like [a|b|c].

If we want to search for complete words we can use the bar alone,  
without the square brackets

first|second|third

will find the words “first,” “second” or “third.”

18.3 Groups and references
Round brackets can be used to “group” expressions. The advantage of 
this, in addition to clarity, is that grouped expressions can be “called” 
again. Let’s see the following example. Suppose we want to look for re-
peated text (typical typo that appears when you stop to think in the the 
middle of a sentence…); the regular expression (we will show a better 
one below)

(.+)\1

will find any group of character that repeat, such as twice the same 
word or twice a space, since the group (.+) is called again with the 
expression \1.
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If we had two or more groups, something like (exp1)(exp2)… 
we could call the first one with \1, the second with \2…

If we now want to “clean up” this repetition, we can use $1 in Re-
place.

Yes, Replace works different from Find: the reference is made with $ 
and not with the \. In fact and besides a few exceptions,  Replace does 
not accept regular expressions.

This simple expression will also find two consecutive “l” or two “r” 
so… it can be dangerous.  An expression that gives perfect results to 
find repeated words is the following:

\b(\w+) +\1\b

Notice the space between (\w+) and +\1 
The two \b at the beginning and the end of the expression look for 

the limits of a word, the  (\w+) looks for  at least one word element 
(that is, at least one character). I leave you the exercise of interpreting 
the space followed by the plus.

18.4 Other expressions
Just as  \w searches for a word element,  \W (in uppercase) looks for 
something that is not a word element (a punctuation mark, a space).

It is  possible to search for Unicode characters by using  \uXXXX, 
where XXXX is the hexadecimal code that identifies the character. For 
example, \u03b4 finds a δ.

The expression  [:alpha:] represents an ASCII character,  while 
[:digit:] or [:number:] look for any digit from 0 to 9. 

[:space:] finds any type of space, even those of non-separation.
Typing & in “replace” will introduce the same string found with the 

expression in “Find.”
*? find 0 or more times, preferring the smallest number possible.
+? find 1 or more times, preferring the smallest number possible.
??  find zero or one instances, prefer zero.
{n}? find exactly n times.
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{n,}? find at least n times, but no more than necessary.
{n,m}? find between n and m times, preferring the smallest possi-

ble number, but not less than n.

18.5 Some examples
To  find  empty  paragraphs  that  only  contain  some  spaces,  but  not 
words, characters or symbols, write 

^([ ]*)$

(between the square brackets there is a space) in Find.
For some reason this expression fails to find the case of “zero spa-

ces,” where it should be used

^$ 

To find whole numbers

\b[1-9][0-9]*\b

If we want to find a number “with comma” like 0,1234

\b[0-9]+,[0-9]*\b

And how about finding numbers that can be both integers or deci-
mals, with a comma or a dot as decimal separator?

\b[0-9]+[,|\.]?[0-9]*\b

Let’s see some more difficult examples now. To search for text in 
round brackets we can use: 

\(.*?\)

or

\([^\(]*\)

The explanation for the second expression goes as follows: look for 
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an opening round bracket,  an arbitrary number of  characters  other 
than an opening round bracket and a closing round bracket. Do you 
dare to explain the first expression?

Any kind of brackets are special characters for regular expressions 
and that is why we need to use the backslash, but if we want to find 
something enclosed in «guillemets» for example, we can simply use

«.*?»

Well,  are  we  already  in  rhythm?  Because  now comes  something 
much more complex and interesting.

Suppose we want to select a text that is before another, but without  
selecting the latter. What we need is what in the jargon of regular ex-
pressions is called Look-ahead assertion and that is constructed with a 
pair of round brackets, a question mark and an equal sign:

term we want to find(?=element we do not want 
to select)

Suppose we want to select any word followed immediately by a pe-
riod, but without selecting the period, the expression would be

\b\w+(?=\.)

Let’s now invert the challenge looking for something that comes af-
ter a certain element, but without selecting that element. What we need 
here is a Look-behind assertion strategy which is constructed in a simi-
lar way to the previous one, but strategically adding a “less than” sign:

(?<=element that we do not want to 
select)term to select

Here  for  example  we  could  have  a  text  imported  from  dubious 
sources that has several spaces after each period,  not just one, and we  
want to solve this problem. For this we would have to use

(?<=\.)[:space:]{2,}

But suppose that these unnecessarily repeated spaces appear also 
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after an exclamation point or closing question mark, in this case we 
would have to use

(?<=[\.\?\!])[:space:]{2,}

Another challenge? Well, we could look for a Spanish text between 
two exclamation points (opening and closing) without selecting those 
signs. For that we could use

(?<=¡)[^\!]+(?=\!)

(what follows the equal sign is not an i!)
We could use all this to correct a forgotten space after a period. For 

example, if in a document we have
One sentence.Second sentence.Third sentence? Fourth
and we want to select only the periods that are not followed by a 

space we can use

(?<=\w)\.(?=[\w¿¡])

to then replace them with a period and a space.
Another example? Suppose we want to locate whole numbers be-

tween 1 and 50 in a document, but not larger ones. This is more diffi-
cult, right? Here is the expression that works:

(?<=[^\d]|^)([1-4]?\d)(?=[^\d]|$)|50

Now a complete example, to find and replace. Suppose we want to 
find dates written as 04-11-1934 to replace them in the 1934/11/04 
format. In Find we write 

([0-9]{2})-([0-9]{2})-([0-9]{4})

while in Replace we have to write

$3/$2/$1

As you can see, the possibilities are unlimited.
Last example! For real! I will close this section with the longest reg-
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ular expression I have ever written. The idea is to find chains in round 
brackets that have text  and numbers, not those that have only text or 
only numbers. For example, we want to find

• (20 years)
• (2 years)
• (the 20s)
• (at 20 years)
• (in 20 or 30 years)

but not
• (20)
• (a text)

Here is the expression:

\([:digit:][^\([:digit:]]+\)|\([^\(]+
[:digit:]+[^\(]+\)

I leave you the task of interpreting it.

18.6 Regular expressions and AutoCorrect 
options
We leave it pending in 10.1: the “third type” of AutoCorrect substitu-
tions. 

If we go to  Tools ▶ AutoCorrect ▶ AutoCorrect Options  we can 
create an AutoCorrect as follows: Write .*_0 in Replace and then copy 
and paste ₀ (Unicode 2080) in With. Now in the text write A_0 and see 
how it turn into A₀.2

Yes: AutoCorrect with regular expressions.
There is room to play here… but not too much. Beyond the  .* I 

have not found other regular expressions that work with AutoCorrect, 
but something is more than nothing and with this we already have a 
greater freedom when it comes to simplifying the work of the writer.

2 This  AutoCorrect  is  on by default  for Spanish documents,  but  not  for 
those in English.
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18.7 There is more
I think that for an “introduction” we have already given a lot. Regular  
expressions are more an art than a technique so finding the right ex-
pression that will solve “that situation” is something that will have us 
frowning for a while.

But when we found it… 
For more information about regular expressions:

http://userguide.icu-project.org/strings/regexp 

Not all the expressions found on that page work in Writer, but it is 
an important point of reference.

You may also be interested in the AltSearch extension, which adds 
an alternative search engine with more features, such as being able to 
search several paragraphs simultaneously:

https://extensions.libreoffice.org/extensions/alternative-
dialog-find-replace-for-writer 
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Apendix A

The odt format

The complete specification of the OpenDocument format used by LibO 
has more than seven hundred pages, so clearly we can not see all its de-
tails here… especially if we take into account that I do not know them.

The aim of this appendix is, after a brief introduction to the struc-
ture of an odt file, to deal with some problems that can not be solved 
from the graphical interface of Writer.

A.1 The file structure 
If we take any odt file (although it is better to do this on a copy of that 
“any file”) and change its extension from .odt to .zip we will have a 
normal compressed file with inside several files written in xml format 
and some folders that contain the embedded images, the macros and / 
or toolbars associated with the file, the definitions of the styles, etc..

The most important elements for the purpose of this appendix are 
the content.xml files, styles.xml and the Pictures folder.

Inside  the  content.xml file  is  the  actual  content  of  the  file, 
marked with certain instructions that refer to the different styles ap-
plied, to the embedded (or linked) images, and so on. The syntax of this 
file is not really complex to understand, it should only be kept in mind 
that some symbols are reserved to be used as part of the formatting in-
structions and therefore when these should appear in the content of the 
document they should be represented in a particular way.
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The styles  indicated in the  content.xml file are  defined in the 
styles.xml file. All the styles used in the document are declared in 
detail there.

A curiosity of the ODF format is that the definition of the direct 
formatting uses exactly the same “language” as the definition of styles,  
the only difference being that these “ghost styles” used to define the di-
rect formatting are declared at the beginning of the content.xml file 
and not in the styles.xml file and that is why they are not accessible 
from the style and formatting editor.

The list of “reserved characters” within the xml file, with their cor-
responding representations, is as follows

&  "  '  <  > 

&amp;  &quot;  &apos;  &lt; &gt;

In the Pictures folder we find all the images embedded in the docu-
ment,  which  have  automatically  generated  and  not  very  friendly 
names, something like:

100000000000012900000063D86809C2.ppng

A.2 First example: edit embedded images
Suppose we want to edit all the embedded images in a document using 
an external program. For example, converting all color images to black 
and white. To do so it is enough to unzip the odt file, work on the im-
ages without changing their names and compress everything again, re-
specting the original structure of the file.

A.3 Second example: move from embedded 
images to linked ones
An embedded image is  called,  within the  content.xml file,  as fol-
lows:
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<draw:image xlink:href="Pictures/
100000000000012900000063D86809C2.png" 
xlink:type="simple" xlink:show="embed" 
xlink:actuate="onLoad"

and other codes that do not interest us at this time, while a linked 
image (which, for this example, is in the same file folder) looks like this:

<draw:image xlink:href="../nombre_imagen.png" 
xlink:type="simple" xlink:show="embed" 
xlink:actuate="onLoad"

again with other codes that do not interest us.

If the name of the linked image contains a space, that space is re-
placed by %20.

As can be seen from the example, there are almost no differences in  
the way in which the embedded image and the linked image are de-
clared since both are called with a “href.” The only difference is in the 
structure of the image path: for the embedded image there is an abso-
lute path within the file, while for the linked one, we must first “leave” 
the compressed file with the two successive periods followed by the 
slash.

As we have already commented at the time, to convert linked im-
ages into embedded images it is enough to go to Edit ▶ Links to Ex-
ternal Files  and “interrupt” the link to the image. Now we see that 
making a really simple change in the structure of the  content.xml 
file we can do the opposite: extract the embedded image to turn it into 
a linked one.

The procedure is as follows:

1. As discussed above, change the file extension from odt to zip.

2. Unzip the zip file into an empty folder.

3. Open the content.xml file with a text editor and change all 
instances of Pictures by ../Pictures
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4. At your discretion, in addition to adding the two periods and 
the slash you could also change the name of the folder con-
taining the images (remembering to rename the folder too!).

5. Select all files and folder EXCEPT the Pictures folder and com-
press everything into a new zip file.

6. Change the extension of the compressed file from zip to odt.

Done: the new odt document will have linked images.

A.4 Third example: change anchor images
Here is a problem:

Bug 32484 - Allow anchor settings in frame styles 

Frame styles do not allow you to configure the anchor!
Suppose we want to modify the frame style called Graphics so that 

its  anchor  changes  from  “to  paragraph”  to  “as  character.”  Opening 
styles.xml we need to search for the parameter, within that style 
definition, text:anchor-type and change its value from the default 
value paragraph to a simple as-char.
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Apendix B

The structure of this book

In this appendix I  will  comment on some formatting choices that  I 
have taken at the time of writing this book. I will briefly discuss the 
fonts used and the styles needed.

B.1 About typography
The base font used in this document is  Cochineal,  a fork of Crimson 
maintained by Michael Sharpe.

To give it a “touch” I have enabled the “Q with long tail,” which in 
Cochineal is obtained with the OpenType tag swsh.

The headings use the Cormorant font, a magnificent Garalda for ti-
tles developed by Christian Thalmann.

The sans font used to give internet links and the menu “paths” is 
Eau de Garamond, another interesting project by Christian Thalmann, 
who has taken the classic ideas of Garamond and has “distilled” them 
by removing all the serifs.

The mono-spaced font is Source Code Pro.
Other fonts have been used for the different examples.
In  my personal  blog I  have  several  articles  describing  these  and 

other typographical fonts,  as well  as some articles on typography in 
general  (basic  concepts,  nomenclature,  how to  know the  OpenType 
features offered by a font…). You can find all those articles under the 
“font-review” category and in the “typography” tag:
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https://frommindtotype.wordpress.com/category/software/
font-review/ 

https://frommindtotype.wordpress.com/tag/typography/ 

B.2 Styles used
Page styles:

• A generic style for the cover and the copyright page1

• A style for the index pages, with only the footer and numbered 
in roman numerals formatted in small caps

• Two page styles for the “parts:” 

◦ The main one, with the heading

◦ The “following” one, with a comment on what follows and 
the partial index of the chapters of that part

• Two page styles for the content:

◦ The first page of each chapter with a greater upper margin 
and only the footer

◦ The “body of the document,” with “simulated” headers us-
ing a frame anchored at the footer, and the option “same 
content on left and right pages” turned off

Paragraph styles:

• Part,  with “level 1” in  Tools ▶ Chapter numbering ,  unnum-
bered

• Chapter heading with the option “line break” as separator be-
tween number and text, level 2 in Tools ▶ Chapter numbering  
and numbered

1 Copyleft is nothing more than a more pleasant form of copyright.
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◦ Linked to this style,  Appendix heading, level 2 in the style 
settings and using a list style to number it

• “Subchapter” heading with level 3 in  Tools ▶ Chapter number-
ing  and numbered, with sublevel

◦ Linked to this style,  “Subappendix” heading, level 3 in the 
style settings and using the same list  style to number it 
(Tab at the beginning, remember?)

• “SubSubChapter”  heading with  level  4  in   Tools  ▶  Chapter  
numbering  and numbered, with sublevels

• Text Body as “text body” level, with first line indent and space 
under the paragraph,  but  with the option of  not  using that 
space between paragraphs of the same style

◦ Linked with this style, a no-first line indent text body, iden-
tical to the original except for the missing first line indent: 
used after headings

◦ Also linked to this style: the notes, the code, the style used 
for drop caps… all the special paragraphs

• All the classics: footnotes, headers and footers, etc.

Character styles:

• Styles to be applied on the numbering of each heading

• Style to apply to cross-references

• Style to apply on Small Caps Text 

• Style to apply on “paths” that indicate menus

• Style to apply to indicate code

• Style to apply to indicate keyboard shortcuts
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B.3 Sections
Each chapter and appendix is included in its own section, in order to 
be  able  to  restart  the  numbering  of  the  footnotes  even though  the 
“chapters” are not in level 1.

B.4 Frames
Except for the frame that “simulates” the page header and the possible 
frames that surround figures and Math objects, I have not needed other 
frames in this document.

B.5 Indexes
Yes, in the plural, that since I wanted them to be very “personalized,” I  
had no alternative but to do some “dirty tricks.”

Since there is no “official” way to get the numbers of the headings in 
the index aligned “to the right,” I had to invent one: I created two in -
dexes that take the headings not of the outline but of a manual selec-
tion. Then, to the paragraph style used for the chapters in the index I 
associated a correctly aligned list style, removing the chapter numbers 
from the index structure.

The second index only shows the styles used by the “appendixes” 
and the “subappendixes.” They use another paragraph style and show 
their own numbering.

Then there are  the  partial  indices  of  each “part.”  These are more 
“normal” indexes, where only the option to create them “per chapter” 
was selected. Which is the part, but that’s fine.

And… that’s it!


If you got here, congratulations! I hope these pages are useful for 
you. If so, you can continue reading what I write, both in my blog and 
in future editions of To Tame a Writer.

Until the next typographic adventure!
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